Virtualbox in infinite loop since today

Hello guys,

yersterday virtualbox was working fine, since last update when i start a virtual machine (a new one or existing one) i have a windows with starting virtual machine which hangs infinitly and nothing in the logs.

Here are the logs of the vm:

00:00:02.556390 VirtualBox VM 7.0.8_SUSE r156879 linux.amd64 (no date no time) release log
00:00:02.556394 Log opened 2023-06-12T09:07:41.168981000Z
00:00:02.556395 Build Type: release
00:00:02.556398 OS Product: Linux
00:00:02.556399 OS Release: 6.3.6-1-default
00:00:02.556401 OS Version: #1 SMP PREEMPT_DYNAMIC Mon Jun  5 07:58:35 UTC 2023 (f583ba4)
00:00:02.556433 DMI Product Name: MS-7D43
00:00:02.556443 DMI Product Version: 1.0
00:00:02.556449 Firmware type: UEFI
00:00:02.556684 Secure Boot: Enabled
00:00:02.556733 Host RAM: 64143MB (62.6GB) total, 61441MB (60.0GB) available
00:00:02.556738 Executable: /usr/lib/virtualbox/VirtualBoxVM
00:00:02.556738 Process ID: 3233
00:00:02.556739 Package type: LINUX_64BITS_GENERIC (OSE)
00:00:02.559292 Installed Extension Packs:
00:00:02.559302   None installed!
00:00:02.560830 Console: Machine state changed to 'Starting'
00:00:02.561245 Qt version: 5.15.9
00:00:02.561288 X11 Window Manager code: 3
00:00:02.575076 SUP: seg #0: R   0x00000000 LB 0x00065000
00:00:02.575110 SUP: seg #1: R X 0x00065000 LB 0x001a0000
00:00:02.575119 SUP: seg #2: R   0x00205000 LB 0x0006e000
00:00:02.575126 SUP: seg #3: RW  0x00273000 LB 0x0002eae8
00:00:02.581284 GUI: Show mini-toolbar for window #0
00:00:02.619085 GUI: Adjust mini-toolbar for window #0
00:00:02.619219 GUI:  Resize mini-toolbar for window #0 to 1920x1080
00:00:02.619445 GUI:  Move mini-toolbar for window #0 to 0x0
00:00:02.637847 X Server details: vendor: The X.Org Foundation, release: 12101008, protocol version: 11.0, display string: :0
00:00:02.637880 Using XKB for keycode to scan code conversion```

I have no idea where it's comming, no problems in logs.

Does anybody have the problem / or do you have any idea ?




First, welcome to the openSUSE Forums.

Did you notice that there’re no VirtualBox Extension Packs installed?

00:00:02.559292 Installed Extension Packs:
00:00:02.559302   None installed!

Which host Operating System is running the Oracle VirtualBox?

Hello, i run on windows 11, but i tried to create an ubuntu vm and have the same problem.

For the extension pack, i used to have one but i uninstall it, because i wanted to know if the problem is coming from the extension pack.

I found on virtualbox forum the same problem: same problem, but the guy is on open suse 15.4.



OK downgrading the kernel fix the issue. This issue seems to be on a kernel update, which could be the same for opensuse 15.4.



“which” kernel does it not work?
“which” kernel did it work ?

OK i found the answer, excuse me for beeing not precise.

The kernel which works is the 6.3.4 , the one which does not is the 6.3.6.

The link i share, is the problem: it’s seems that ibt has been activated on opensuse kernel, which implies that virtualobox get in infinite loop (since the time there should have been a readable warning message on virtualbox side ).

To fix this, and boot with last kernel, i remove ibt, by setting ibt=off in the kernel booting config ( )

Hope this will help, because the error message isn’t obvious and not lot of help is found on google.



1 Like

Then you should see something in kernel logs (dmesg) at the time VB fails.

Good to know - thanks for follow-up! I use V’Box on four machines, so I’ll keep this documented!

I am on 6.3.6 and virtualbox works fine - but I also have secure boot disabled in the bios

user@LLR4:~> uname -a
Linux LLR4 6.3.6-1-default #1 SMP PREEMPT_DYNAMIC Mon Jun 5 07:58:35 UTC 2023 (f583ba4) x86_64 x86_64 x86_64 GNU/Linux
user@LLR4:~> psg virtual
user 3829 1 0 Jun09 ? 00:07:06 /usr/lib/virtualbox/VBoxXPCOMIPCD
user 3835 1 0 Jun09 ? 00:32:28 /usr/lib/virtualbox/VBoxSVC --auto-shutdown
user 3861 3807 0 Jun09 pts/7 00:02:48 /usr/lib/virtualbox/VirtualBox6 %U
user 6375 3835 3 06:52 ? 00:04:04 /usr/lib/virtualbox/VirtualBoxVM --comment suse15 --startvm 7e154200-c32c-40ac-a01d-1b7632c55598 --no-startvm-errormsgbox
user 14879 3835 4 Jun11 ? 00:40:16 /usr/lib/virtualbox/VirtualBoxVM --comment Ubuntu --startvm d5db27f0-e3b3-4e18-84a2-2d999edf7504 --no-startvm-errormsgbox
user 19499 3835 4 Jun10 ? 02:21:53 /usr/lib/virtualbox/VirtualBoxVM --comment Manjaro --startvm 1222f84b-36a0-4b58-b84a-526d7a225af5 --no-startvm-errormsgbox
user 20149 3835 3 Jun10 ? 01:38:42 /usr/lib/virtualbox/VirtualBoxVM --comment tumbleweed --startvm 4713d533-f86c-463c-8da8-ee67427a1fed --no-startvm-errormsgbox
user 20424 3835 15 Jun10 ? 07:35:26 /usr/lib/virtualbox/VirtualBoxVM --comment win11 --startvm ce4f8eb9-4894-4373-89fb-dbc625899167 --no-startvm-errormsgbox
user 20748 3835 16 Jun10 ? 08:12:45 /usr/lib/virtualbox/VirtualBoxVM --comment win10 --startvm b791d51d-ccab-4e90-bef1-2bfa508394d8 --no-startvm-errormsgbox
user 21318 3835 4 Jun10 ? 02:17:31 /usr/lib/virtualbox/VirtualBoxVM --comment twkde --startvm 25ebb4a2-a3af-4a44-a3da-88fc2adf06dc --no-startvm-errormsgbox
user 21381 3835 0 Jun10 ? 00:00:02 /usr/lib/virtualbox/VBoxNetDHCP --comment Gnome --config /home/user/.config/VirtualBox/Gnome-Dhcpd.config --log /home/user/.config/VirtualBox/Gnome-Dhcpd.log
user 21382 3835 0 Jun10 ? 00:00:28 /usr/lib/virtualbox/VBoxNetNAT --network Gnome
user 21600 3835 6 Jun10 ? 03:14:30 /usr/lib/virtualbox/VirtualBoxVM --comment fedora --startvm d6da2ee7-920b-413f-8f9c-f944c8a6fa76 --no-startvm-errormsgbox
user 21878 3835 4 Jun10 ? 02:07:58 /usr/lib/virtualbox/VirtualBoxVM --comment gnome --startvm 04aa4c99-1973-469c-8c57-8d44d2628ca6 --no-startvm-errormsgbox
user 27600 3835 3 Jun11 ? 00:34:32 /usr/lib/virtualbox/VirtualBoxVM --comment Mint --startvm da7f2283-4722-4d94-890a-93c03e4b8178 --no-startvm-errormsgbox

@larryr it depend of your processor, ibt is a technology for securing intel processor, it’s available only if you have a version processor greater than 11.

I’m not an expert, i’m not sure it’s on every intel processor since version 11.


Here, still on Leap 15.4 with Leap 15.5 running in an Oracle VirtualBox –

  • EFI, PAE/NX, Nested VT-x/AMD-V, and TPM v2.0 all activated.

The Leap 15.5 client boot looks like this:

 # journalctl -b 0 --output=short-monotonic --no-hostname  --system | grep -iE 'secur|cert|box|tpm|spect'
[    0.000000] kernel: Command line: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150500.53-default root=UUID=4bada658-07f5-4d80-9bae-2daa5d9f3482 splash=silent preempt=full mitigations=auto quiet security=apparmor
[    0.000000] kernel: efi: ACPI=0xdef7e000 ACPI 2.0=0xdef7e014 TPMFinalLog=0xdefd6000 SMBIOS=0xdefd5000 MOKvar=0xdecfb000 TPMEventLog=0xdd7d1018 
[    0.000000] kernel: secureboot: Secure boot enabled
[    0.000000] kernel: Kernel is locked down from EFI Secure Boot mode; see man kernel_lockdown.7
[    0.000000] kernel: DMI: innotek GmbH VirtualBox/VirtualBox, BIOS VirtualBox 12/01/2006
[    0.026806] kernel: secureboot: Secure boot enabled
[    0.026817] kernel: ACPI: RSDP 0x00000000DEF7E014 000024 (v02 VBOX  )
[    0.026821] kernel: ACPI: XSDT 0x00000000DEF7D0E8 000054 (v01 VBOX   VBOXFACP 00000001      01000013)
[    0.026826] kernel: ACPI: FACP 0x00000000DEF79000 0000F4 (v04 VBOX   VBOXFACP 00000001 ASL  00000061)
[    0.026831] kernel: ACPI: DSDT 0x00000000DEF7A000 002352 (v02 VBOX   VBOXBIOS 00000002 INTL 20180105)
[    0.026837] kernel: ACPI: APIC 0x00000000DEF78000 00006C (v02 VBOX   VBOXAPIC 00000001 ASL  00000061)
[    0.026840] kernel: ACPI: TPM2 0x00000000DEF77000 000034 (v04 VBOX   VBOXTPM2 00000001 ASL  00000061)
[    0.026843] kernel: ACPI: SSDT 0x00000000DEF76000 000124 (v01 VBOX   VBOXTPMT 00000002 INTL 20180105)
[    0.026846] kernel: ACPI: SSDT 0x00000000DEF75000 00036C (v01 VBOX   VBOXCPUT 00000002 INTL 20180105)
[    0.026867] kernel: ACPI: Reserving TPM2 table memory at [mem 0xdef77000-0xdef77033]
[    0.043155] kernel: Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.14.21-150500.53-default root=UUID=4bada658-07f5-4d80-9bae-2daa5d9f3482 splash=silent preempt=full mitigations=auto quiet security=apparmor
[    0.105712] kernel: LSM: Security Framework initializing
[    0.107539] kernel: Spectre V1 : Mitigation: usercopy/swapgs barriers and __user pointer sanitization
[    0.107542] kernel: Spectre V2 : Mitigation: Retpolines
[    0.107543] kernel: Spectre V2 : Spectre v2 / SpectreRSB mitigation: Filling RSB on context switch
[    0.107544] kernel: Spectre V2 : Spectre v2 / SpectreRSB : Filling RSB on VMEXIT
[    1.054154] kernel: tpm_tis MSFT0101:00: 2.0 TPM (device-id 0x0, rev-id 1)
[    1.302143] kernel: Loading compiled-in X.509 certificates
[    1.302194] kernel: Loaded X.509 cert 'SUSE Linux Enterprise Secure Boot Signkey: a746b64b6cb71f13385638055f46162bac632acd'
[    1.306847] kernel: integrity: Loading X.509 certificate: UEFI:db
[    1.306887] kernel: integrity: Loaded X.509 cert 'Microsoft Corporation UEFI CA 2011: 13adbf4309bd82709c8cd54f316ed522988a1bd4'
[    1.306888] kernel: integrity: Loading X.509 certificate: UEFI:db
[    1.306910] kernel: integrity: Loaded X.509 cert 'Microsoft Windows Production PCA 2011: a92902398e16c49778cd90f99e4f9ae17c55af53'
[    1.307001] kernel: integrity: Loading X.509 certificate: UEFI:MokListRT (MOKvar table)
[    1.339911] kernel: integrity: Loaded X.509 cert 'SUSE Linux Enterprise Secure Boot CA: ecab0d42c456cf770436b973993862965e87262f'
[    1.339928] kernel: Loading compiled-in module X.509 certificates
[    1.340029] kernel: Loaded X.509 cert 'SUSE Linux Enterprise Secure Boot Signkey: a746b64b6cb71f13385638055f46162bac632acd'
[    1.383638] kernel: evm: security.selinux
[    1.383641] kernel: evm: security.SMACK64 (disabled)
[    1.383643] kernel: evm: security.SMACK64EXEC (disabled)
[    1.383645] kernel: evm: security.SMACK64TRANSMUTE (disabled)
[    1.383659] kernel: evm: security.SMACK64MMAP (disabled)
[    1.383662] kernel: evm: security.apparmor
[    1.383663] kernel: evm: security.ima
[    1.383665] kernel: evm: security.capability
[    1.430435] systemd[1]: systemd 249.16+suse.171.gdad0071f15 running in system mode (+PAM +AUDIT +SELINUX +APPARMOR -IMA -SMACK +SECCOMP +GCRYPT +GNUTLS +OPENSSL +ACL +BLKID +CURL +ELFUTILS +FIDO2 +IDN2 -IDN +IPTC +KMOD +LIBCRYPTSETUP +LIBFDISK +PCRE2 +PWQUALITY +P11KIT +QRENCODE +TPM2 +BZIP2 +LZ4 +XZ +ZLIB +ZSTD -XKBCOMMON +UTMP +SYSVINIT default-hierarchy=hybrid)
[    2.122450] dracut-cmdline[207]: Using kernel command line parameters:  rd.driver.pre=btrfs resume=UUID=8a594343-93ad-439f-a8ed-6df47e19fe9d root=UUID=4bada658-07f5-4d80-9bae-2daa5d9f3482 rootfstype=btrfs rootflags=rw,relatime,space_cache,subvolid=268,subvol=/@/.snapshots/1/snapshot,subvol=@/.snapshots/1/snapshot   BOOT_IMAGE=/boot/vmlinuz-5.14.21-150500.53-default root=UUID=4bada658-07f5-4d80-9bae-2daa5d9f3482 splash=silent preempt=full mitigations=auto quiet security=apparmor
[    3.076155] kernel: ata3.00: ATAPI: VBOX CD-ROM, 1.0, max UDMA/133
[    3.210184] kernel: ata1.00: ATA-6: VBOX HARDDISK, 1.0, max UDMA/133
[    3.210843] kernel: scsi 0:0:0:0: Direct-Access     ATA      VBOX HARDDISK    1.0  PQ: 0 ANSI: 5
[    3.212729] kernel: scsi 2:0:0:0: CD-ROM            VBOX     CD-ROM           1.0  PQ: 0 ANSI: 5
[    3.407484] systemd[1]: Found device VBOX_HARDDISK 1.
[    3.416249] systemd[1]: Found device VBOX_HARDDISK 2.
[    3.644402] kernel: usb 1-1: Manufacturer: VirtualBox
[    3.654590] kernel: input: VirtualBox USB Tablet as /devices/pci0000:00/0000:00:0c.0/usb1/1-1/1-1:1.0/0003:80EE:0021.0001/input/input4
[    3.654751] kernel: hid-generic 0003:80EE:0021.0001: input,hidraw0: USB HID v1.10 Mouse [VirtualBox USB Tablet] on usb-0000:00:0c.0-1/input0
[    5.292003] systemd[1]: systemd 249.16+suse.171.gdad0071f15 running in system mode (+PAM +AUDIT +SELINUX +APPARMOR -IMA -SMACK +SECCOMP +GCRYPT +GNUTLS +OPENSSL +ACL +BLKID +CURL +ELFUTILS +FIDO2 +IDN2 -IDN +IPTC +KMOD +LIBCRYPTSETUP +LIBFDISK +PCRE2 +PWQUALITY +P11KIT +QRENCODE +TPM2 +BZIP2 +LZ4 +XZ +ZLIB +ZSTD -XKBCOMMON +UTMP +SYSVINIT default-hierarchy=hybrid)

More stuff:

test01@localhost:~> lsmod | grep -i 'box'
vboxguest              49152  4
test01@localhost:~> grep IBT /boot/config-5.14.21-150500.53-default 

No sign of IBT in the Kernel …
OK – I removed all the Oracle VirtualBox Server packages from the client and, also the links in /usr/lib/systemd/system/ – there’s only a vboxguest installed on the Leap 15.5 client.

Please open a Bugzilla on this issue - My newest CPU is an i7-10700T.


i will open , i’m using virtualbost as an host not as guest.

@larryr, it’s as i told you you have an i7 version 10. Ibt exists on version upper than 11 (according to virtualbox forum).

my processor: i9 12th Gen (Intel® Core™ i9-12900KF)



So i’m sorry, but bugzilla ask me to log again (since i’m already log on) and when i log again, he’ll tell me that my email address already exists …

I’ll try tomoiroow promise (i change the password of my account which didn’t work today, seems there may be a batch problem).



There is a virtualbox ticket with quite a few references to the virtualbox forums.

@susejunky , they speek a lot of this, and there seems to be the problem since months.

In the virtualbox forum they say that this feature is well known but not activate in lot of linux distribution.

So i wonder if the open suse activate it on kernel 6.3.6 (since the problem seems to be according to the virtualbox forum for opensuse 15.4 too, maybe a kernel compile script ).

If so why ? this is not a major kernel linux update ?

Or is this a kernel bug ( the ibt was working fine , but since there may be a kernel bug fix in 6.3 and 15.4 Leap kernel it doesn’t work anymore ).

I’ll promise when i access to bugzilla i write a bug record, to investigate (since the problem may not be an open suse problem, it could be a virtualbox one / or kernel one).



1 Like

In case you have not seen my post for instruction to fix GRUB in YAST rather than the command line to boot without IBT.

The problem is Oracle’s VirtualBox kernel module. Hopefully, they will get it sorted out and send a new updated module soon.

Yes, but, you seem to be running Oracle VirtualBox on a Redmond (Windows 11) host operating system and –
You’re trying to run Linux as a guest operating system.

As demonstrated above –

  • Using openSUSE Leap 15.4 as the Oracle VirtualBox host operating system and then –
    Installing openSUSE Leap 15.5 as guest operating system on that host operating system –
    Functions perfectly well and, as expected …

The issue is possibly caused by –

  • Oracle VirtualBox executing on a Redmond host operating system …

As far as I understand the virtualbox problem discussed in this thread has two key components:

  1. The CPU in use must support IBT (which to my knowledge is true for intel Tiger Lake CPUs or later).
  2. CONFIG_X86_KERNEL_IBT=y must be set in the kernel config (as far as I know this is the case with openSUSE kernel 6.3.6 or later).

I do not know

  • whether IBT needs to be disabled in an openSUSE guest system with kernel 6.3.6 or later (when the host system runs on a CPU >= intel Tiger Lake).
  • what happens when the host system is MS Windows 10/11 (running on a CPU >= intel Tiger Lake) and the guest is an openSUSE system with kernel 6.3.6 or later.

All my CPUs are intel Kaby Lake or older and do not support IBT therefor I cannot run any tests.