Virtualbox hangs at installing guest

I have OpenSUSE 11 with KDE 3 running (also did the same thing with KDE 4). Downloaded and installed Virtualbox from Sun. Installed fine. Able to set up everything but when I click “Start” I get a window that it is spawning session and it just hangs! I can’t get it to stop or close and have even done a hard shutdown to try again, but the same results. I have tried everything here etc/config changes, made myself part of the correct group…I am out of ideas and tired of hard booting :). Help is greatly appreciated

This thread discusses the same issue, I was in on it.
VirtualBox 2.0.0 OSE error - openSUSE Forums

You should not need to re-install Suse though!

Double check everything.

? How did you install the Sun .rpm

I had previously used the OSE version 1.6 from the build service repo - and it was fine. But I latter removed all those packages ans manually installed the Sun .rpm from a terminal
Went without a hitch, all my VM’s worked no problem.

Thanks for the link to the other thread. OK before I start installing stuff I just want to double check. I went to yast (which was where I installed from), only Sun’s VB was installed. Did a search and I do not have “kernal source” and “gcc” installed. Are these the one’s I need? I don’t want to mess anything major up as this is my backup computer while my main is in the shop and I am working on my BSN online. Thanks in advance!!!

First let me clarify:

There is VBox OSE (open source edition)

and VBox from the Sun website

Earlier you said:

Downloaded and installed Virtualbox from Sun

Installing that (the .rpm from Sun) would normally be done from a terminal, as it is not in the repo’s - which would not involve Yast. Unless you just clicked on the .rpm - in which case Yast may install it.

Your best option is: decide if you really need USB support.
If you do. the get the .rpm direct from Sun.
Remove any OSE Vbox packages you have installed.


to run the .rpm - in a terminal from the same directory and as su

rpm -ihv packagename*.rpm

If you don’t need USB then use this repo, add it to your list:
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

it’s more up to date
from software management - filter by repo - go to the new repo
check the Vbox package
read here:VirtualBox Installation - openSUSE

OK been working on this all day!! Still no joy! Followed all instruction now get the following error:

Makefile:169: *** Error: unable to find the include directory for your current Linux kernel. Specify KERN_INCL=<directory> and run Make again. Stop.

I uninstalled Vbox by yast
Installed :
Reinstalled from shell as su
still can’t seem to get this right!!! Sorry to be such a noob! Any help is appreciated. Also thanks for the help give up to now!!!

Any ideas on this? I uninstalled again but have not tried to reinstall yet as concerned I’ll get the same thing. Should I try VMWare or Xen instead? What are your thoughts and experience? TIA


Try using the OSE version first to see if we can get you going:
add this repo
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

Now open Yast - Software - Software Management
filter by repo
go to the new VBox repo
check Virtual box for install

remember to add yourself to vboxusers–
YaST → Security and Users → UserManagement, and edit your user and add them to the vboxusers group

And to get the Vbox driver to auto load at boot
YaST -> System > System Services (runlevel)-> vboxdrv and select the enable button and finish.

Now try it.

We can try and upgrade to usb support later.

NB* VMware is OK many use it. I would give Zen a miss.

Ok reinstalled as you suggested. Followed all your instructions. Even deleted and reconfigured the VM. Still get spawning session. I have tried with iso and actual cd with same result. I know I am a noob but why does it have to be so frickin complicated…arghhh :slight_smile:

I finally got it running! Thanks to all of you for your help!!!

If you know how - tell us please!

Actually, I did everything that was suggested in the forums. Then , since I have an external moniter on my system, I reset the time to wait for a reply with grub. I saw I had 2 different kernals, selected the newer one and it worked. Not sure when the new kernal was created but I’m not going to complain. :).