Virtualbox GUI no longer launches

I’ve been using Virtualbox without difficulty on my PC until recently. Now when I try to launch the app, it shows the mini bouncing icon as if it is preparing to launch, but never successfully does. I have made sure all the software is up to date and restarted the computer. The problem persists.

I have version 7.0.18-1.1 which was installed via YAST. I have extension pack 7.0.18.

Any ideas on how to fix this? Can I provide any more info?

The extension pack is only needed for advanced networking - the main reason for needing it in Virtualbox 6 was added automatically in 7.

If you have a saved machine - the saved machine may need to be Discarded to get past the differences from the old version to the new one.

If all else fails - I would uninstall and reinstall virtualbox (It does not change any virtual machines).

show what is installed here with

sudo zypper se -si virtualbox

Post it here so I can see where they came from - it should look like this:

> zypper se -si virtualbox
> 
> Loading repository data...
> Reading installed packages...
> 
> S  | Name                   | Type    | Version                                   | Arch   | Repository
> ---+------------------------+---------+-------------------------------------------+--------+--------------------------
> i+ | virtualbox             | package | 7.0.18-lp155.2.24.1                       | x86_64 | openSUSE-Leap-15.5-Update
> i  | virtualbox-kmp-default | package | 7.0.18_k5.14.21_150500.55.59-lp155.2.24.1 | x86_64 | openSUSE-Leap-15.5-Update
> i  | virtualbox-qt          | package | 7.0.18-lp155.2.24.1                       | x86_64 | openSUSE-Leap-15.5-Update
>

to uninstall and reinstall

sudo zypper rm virtualbox*

sudo zypper in virtualbox

You will have to say yes to proceed with the uninstall and the reinstall

It looks like I have two different versions, if I’m interpreting this correctly

Loading repository data...
Reading installed packages...

S  | Name                   | Type    | Version             | Arch   | Repository
---+------------------------+---------+---------------------+--------+------------------------
i  | virtualbox             | package | 7.0.18-1.1          | x86_64 | openSUSE-Tumbleweed-Oss
i  | virtualbox-kmp-default | package | 7.0.18_k6.8.9_1-1.2 | x86_64 | (System Packages)
i  | virtualbox-kmp-default | package | 7.0.18_k6.9.1_1-1.3 | x86_64 | openSUSE-Tumbleweed-Oss
i+ | virtualbox-qt          | package | 7.0.18-1.1          | x86_64 | openSUSE-Tumbleweed-Oss

I’ll go ahead and do the install and uninstall and report back

Uninstall and install complete. System restarted. Unfortunately the problem isn’t fixed. Here is the new result when I run: se -si virtualbox. It looks like the conflict is resolved there, but it just doesn’t work still:

Loading repository data...
Reading installed packages...

S  | Name                   | Type    | Version             | Arch   | Repository
---+------------------------+---------+---------------------+--------+------------------------
i+ | virtualbox             | package | 7.0.18-1.1          | x86_64 | openSUSE-Tumbleweed-Oss
i  | virtualbox-kmp-default | package | 7.0.18_k6.9.1_1-1.3 | x86_64 | openSUSE-Tumbleweed-Oss
i  | virtualbox-qt          | package | 7.0.18-1.1          | x86_64 | openSUSE-Tumbleweed-Oss

Any other ideas?

Do the logfiles in “/home/USERNAME/.config/VirtualBox/” give any hints?

If you do

> VirtualBox

in a konsole will this show any errors?

I ran the command “VirtualBox” and here is the output:

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

qt.qpa.xcb: could not connect to display 
qt.qpa.plugin: From 6.5.0, xcb-cursor0 or libxcb-cursor0 is needed to load the Qt xcb platform plugin.
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: wayland-egl, wayland, eglfs, linuxfb, minimal, minimalegl, offscreen, vkkhrdisplay, vnc, xcb.

/usr/bin/VirtualBox: line 58: 25221 Aborted                 kdesu /usr/sbin/vbox-fix-usb-rules.sh
Qt CRITICAL: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

Don’t know why - but my guess is that either qt5 or qt6 is missing some pieces.

I use X11 and not wayland - so I don’t know what I have that is missing from wayland. Also my Tumbleweed was installed 5 years ago, things that might have been installed years ago are not in the current dup and never were removed.

I would try installing qt5 and qt6 develop libraries and see what fails or runs.

sudo zypper in qt5-devel qt6-devel

Are you running this command using sudo or su?

Here are the results of that command:

Loading repository data...
Reading installed packages...
'qt5-devel' not found in package names. Trying capabilities.
No provider of 'qt5-devel' found.
'qt6-devel' not found in package names. Trying capabilities.
No provider of 'qt6-devel' found.
Resolving package dependencies...
Nothing to do.

I used: sudo

Did you check that libxcb-cursor0 is installed as this was mentioned in the error output?

Are you missing some repo’s? I guess you do not have the Tumbleweed debug repo.

provide this output

sudo zypper lr -d

it should show something like this:

zypper lr -d
# | Alias | Name | Enabled | GPG Check | Refresh | Priority | Type | URI | Service
—±----------------±-----------------------------------------±--------±----------±--------±---------±---------±--------------------------------------------------------------±-------
1 | Packman | Packman Tumbleweed Repository | Yes | (r ) Yes | Yes | 99 | rpm-md | Index of /packman/suse/openSUSE_Tumbleweed |
2 | repo-debug-oss | openSUSE-Tumbleweed-Repository (DEBUG) | Yes | (r ) Yes | Yes | 99 | rpm-md | https://provo-mirror.opensuse.org/debug/tumbleweed/repo/oss/ |
3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | https://provo-mirror.opensuse.org/tumbleweed/repo/non-oss |
4 repo-oss | openSUSE-Tumbleweed-Oss | Yes | (r ) Yes | Yes | 99 | rpm-md | https://provo-mirror.opensuse.org/tumbleweed/repo/oss |
5 | repo-source-oss | openSUSE-Tumbleweed-Repository (Sources) | Yes | (r ) Yes | Yes | 99 | rpm-md | https://provo-mirror.opensuse.org/source/tumbleweed/repo/oss/ |
6 | repo-update | openSUSE-Tumbleweed-Update | Yes | (r ) Yes | Yes | 99 | rpm-md | https://provo-mirror.opensuse.org/update/tumbleweed/ |
7 | teamviewer | TeamViewer - x86_64 | Yes | (r ) Yes | Yes | 99 | rpm-md | https://linux.teamviewer.com/yum/stable/main/binary-x86_64/ |

Here is what my debug repo in /etc/zypp/repo.d/ looks like:

cat repo-debug-oss.repo
[repo-debug-oss]
name=openSUSE-Tumbleweed-Repository (DEBUG)
enabled=1
autorefresh=1
baseurl=https://provo-mirror.opensuse.org/debug/tumbleweed/repo/oss/
path=/
type=rpm-md
keeppackages=0

There are no such packages in any official Tumbleweed repo…

Here is the output to that command:

# | Alias               | Name                                   | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                | Service
--+---------------------+----------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------------+--------
1 | openSUSE-20230707-0 | openSUSE-20230707-0                    | No      | ----      | ----    |   99     | rpm-md | hd:/?device=/dev/disk/by-id/usb-Samsung_Flash_Drive_FIT_0364620100002717-0:0-part1 | 
2 | packman             | Packman                                | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/               | 
3 | repo-debug          | openSUSE-Tumbleweed-Debug              | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/debug/tumbleweed/repo/oss/                            | 
4 | repo-non-oss        | openSUSE-Tumbleweed-Non-Oss            | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                              | 
5 | repo-openh264       | Open H.264 Codec (openSUSE Tumbleweed) | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Tumbleweed                            | 
6 | repo-oss            | openSUSE-Tumbleweed-Oss                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                  | 
7 | repo-source         | openSUSE-Tumbleweed-Source             | No      | ----      | ----    |   99     | N/A    | http://download.opensuse.org/source/tumbleweed/repo/oss/                           | 
8 | repo-update         | openSUSE-Tumbleweed-Update             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/     

Virtualbox does not run as root.

It has to be run as a user that is a member of vboxusers

please provide:

cat /etc/group | grep vboxuser

cat /etc/group | grep vboxuser
vboxusers:x:451:user

Ahh, I didn’t realize that.

Here is the output for that command:

vboxusers:x:460:love

So only user “love” can run virtualbox gui

1 Like

Good news. I just attempted to launch the GUI and it works now. I’m back in. I’m not exactly sure which action fixed this though.

Either way, thanks for the help.