VirtualBox fails with symbol error message

I’ve tried installing VirtualBox OSE and VirtualBox binary packages (v. 1.6.2) and neither application will start. The kernel modules compile and load (lsmod) no problem, but when I try to load the application all I get is a busy cursor for about 1 minute then nothing. I added my user account to the vboxusers group, etc. I had no problem installing and running this app under 10.3.

When I execute the program from console I’m told there is a symbol error. I installed the kernel-sym package, but that did not help.

I tried installing the older version (1.5.6) but there is a library dependency problem that cannot be resolved. I’ve searched several forums and it seems others are successfully running this app without issue. What am I missing?

If you install Virtualbox from the RPM, it will show any dependencies.

I’ve installed VB with both YAST and RPM. I have never gotten any error messages or dependencies, nor have I experienced any problem compiling the modules. As I said, the kernel modules are loaded and running as shown by LSMOD.

Following is the error message I get when I try to run VB from the command line:

/usr/lib/virtualbox/VirtualBox: symbol lookup error: /usr/lib/virtualbox/VirtualBox: undefined symbol: _ZN5QChar4nullE


ldd /usr/lib/virtualbox/VirtualBox

and see if there are any missing dynamic libraries.

Oh, and also keep an eye out in that output for any libraries that are not the standard ones. If you say had a private version of libstdc++ in /usr/local/lib and it’s used instead of the standard one, that would also stuff you up.

Not sure what I’m looking for so here’s the output from LDD: => (0xffffe000) => /usr/lib/ (0xb7f58000) => /usr/lib/ (0xb762a000) => /usr/lib/ (0xb75be000) => /usr/lib/ (0xb74c7000) => /usr/lib/ (0xb7430000) => /lib/ (0xb7418000) => /usr/lib/ (0xb7327000) => /lib/ (0xb7319000) => /lib/ (0xb71d6000) => /usr/lib/ (0xb70b5000) => /usr/lib/ (0xb70ab000) => /usr/lib/ (0xb7090000) => /usr/lib/ (0xb7087000) => /lib/ (0xb7083000) => /usr/lib/ (0xb7074000) => /usr/lib/ (0xb706a000)
libstdc+± => /usr/lib/libstdc+± (0xb7028000) => /lib/ (0xb7001000) => /lib/ (0xb6ff8000)
/lib/ (0xb7f7f000) => /usr/lib/ (0xb6ff5000) => /usr/lib/ (0xb6fdc000) => /usr/lib/ (0xb6fd6000) => /usr/lib/ (0xb6fd1000)

Well mine’s the x86_64 version so you would have to change the lib64 to lib to compare, but at first sight you seem to be missing lots of dependency libraries, e.g. libexpat. I’m surprised the RPM install didn’t catch that. What did you install from the Sun RPM (10.3 RPM will work on 11.0) or the generic .run file? Or the OSE (presumably) version from some repository that I’m told has VirtualBox. =>  (0x00007fffa17fe000) => /usr/lib64/ (0x00007fbf99301000) => /usr/lib64/ (0x00007fbf98868000) => /usr/lib64/ (0x00007fbf985ee000) => /usr/lib64/ (0x00007fbf982ce000) => /usr/lib64/ (0x00007fbf9802f000) => /lib64/ (0x00007fbf97e13000) => /usr/lib64/ (0x00007fbf97b07000) => /lib64/ (0x00007fbf978f0000) => /lib64/ (0x00007fbf97597000) => /usr/lib64/ (0x00007fbf9725a000) => /usr/lib64/ (0x00007fbf9704f000) => /usr/lib64/ (0x00007fbf96e27000) => /lib64/ (0x00007fbf96c11000) => /usr/lib64/ (0x00007fbf96a07000) => /usr/lib64/ (0x00007fbf967fd000) => /usr/lib64/ (0x00007fbf965f5000) => /usr/lib64/ (0x00007fbf963f2000) => /usr/lib64/ (0x00007fbf961dd000) => /usr/lib64/ (0x00007fbf95f5b000) => /usr/lib64/ (0x00007fbf95d25000) => /usr/lib64/ (0x00007fbf95b13000) => /usr/lib64/ (0x00007fbf9590a000) => /usr/lib64/ (0x00007fbf956ed000) => /lib64/ (0x00007fbf954e9000) => /lib64/ (0x00007fbf95293000) => /lib64/ (0x00007fbf9508a000)
        /lib64/ (0x00007fbf99510000) => /usr/lib64/ (0x00007fbf94e88000) => /usr/lib64/ (0x00007fbf94c6c000) => /usr/lib64/ (0x00007fbf94a66000) => /lib64/ (0x00007fbf9483c000) => /usr/lib64/ (0x00007fbf94639000)

I tried the Sun RPMS (1.6.2 and 1.5.6) for 10.3 as well as their generic Linux RPM. I also tried the openSUSE OSE from the repository. Of course I removed each version prior to installing a different version.

I can’t believe neither YAST nor RPM would miss all the extra libraries that show up on your list. Either those libraries aren’t required, or YAST and RPM are seriously broken. A broken YAST would not be surprising, as it’s NEVER worked properly as a package installer. RPM on the other hand?

I think I’m going back to 10.3 as I’ve also just discovered a problem with openOFFICE. When I try to save new WRITER documents, my system freezes up. I tried removing OFFICE, including deleting the hidden user directories and config files and reinstalling it without success. I simply can’t live with that.

On a final note, YAST fails to read one of the main repositories. I get the following error (posted elsewhere):

There was an error in the repository initialization.
‘repo-oss’: Valid metadata not found at specified URL(s)

I’ve been using openSUSE for years and have never been completely happy with it. Unfortunately, I can say the same thing about any of a dozen other distributions I’ve tried over the years. The last distro I was happy with was Libranet before they went under. Prior to that I liked RedHat (before they adopted GNOME). Libranet was the best ever IMO. Stable, fast, functional, easy to manage. Seems like each new release cycle things get less reliable with all the new distros.

Apologies for the rant. I’m just very annoyed.

I’m afraid it sounds like you have some sort of corruption of your system, or disk errors. Perhaps a reinstall would be in order.

Evidently, the biggest problem must have been configuration files. When I installed 11.0 I was surprised the installer didn’t automatically re-format the partition my home directories are located on. I thought this was a good thing, since keeping /home on a separate partition is SUPPOSED to make upgrading straightforward by avoiding data and configuration restoration from backup.

Unfortunately, this doesn’t seem to be the case. I re-installed 10.3 and chose to keep my /home partition (for the same reason). Not only was VirtualBox STILL broken, so was openOffice. I realized at that point that the problem must be with personal configuration files. This meant a clean installation was required. With nothing to lose, I decided to give 11.0 another shot.

The good news is that everything is working, except VirtualBox, which exhibits the same problem as before (symbol errors).

The bad news is that VirtualBox still won’t run–not to mention I had to reconfigure EVERYTHING from scratch. I lost emails, email server connection info, desktop icon settings, wallpapers, game configuration settings, bash profile aliases, etc. etc. etc. This simply should not be required when undertaking what is essentially a MINOR upgrade (from kernel 2.6.x to kernel 2.6.y and from KDE 3.5.x to KDE 3.5.y).

I must say that EVERYTHING is now running very fast, even YAST. But VirtualBox appears to be a lost cause. Maybe it’s time to re-visit the more conservative approach of Debian with the hope of avoiding multiple major re-installs just to accomplish a minor upgrade?

I’m using VirtualBox-1.6.2_31466_openSUSE103-1.i586.rpm

Here’s my ldd output and hope it helps! =>  (0xffffe000) => /usr/lib/ (0xb7f0c000) => /usr/lib/ (0xb7808000) => /usr/lib/ (0xb779e000) => /usr/lib/ (0xb76a7000) => /usr/lib/ (0xb7613000) => /lib/ (0xb75fc000) => /usr/lib/ (0xb750d000) => /lib/ (0xb7501000) => /lib/ (0xb73ce000) => /usr/lib/ (0xb72b3000) => /usr/lib/ (0xb72a9000) => /usr/lib/ (0xb7284000) => /lib/ (0xb7270000) => /usr/lib/ (0xb7267000) => /usr/lib/ (0xb725e000) => /usr/lib/ (0xb7257000) => /usr/lib/ (0xb7253000) => /usr/lib/ (0xb7240000) => /usr/lib/ (0xb71c8000) => /usr/lib/ (0xb719c000) => /usr/lib/ (0xb718d000) => /usr/lib/ (0xb7184000) => /usr/lib/ (0xb716b000) => /lib/ (0xb7167000) => /lib/ (0xb7141000) => /lib/ (0xb7138000) => /usr/lib/ (0xb711d000)
        /lib/ (0xb7f3c000) => /usr/lib/ (0xb711a000) => /usr/lib/ (0xb7101000) => /usr/lib/ (0xb70fa000) => /lib/ (0xb70d9000) => /usr/lib/ (0xb70d5000) => /lib/ (0xb70a0000) => /usr/lib/ (0xb7099000)

Not sure what to do with that info. I mean, the output I get from LDD is different, but what does that mean? For example, ncurses doesn’t show up–but it is installed on my system. Also, aren’t links to these libraries supposed to be established by the installation routine included in the package if they’re necessary? I’ve done muliple CLEAN installs with various versions all with the same result.

Lastly, I was too quick to assume the problem with openOffice was resolved. I did successfully create and save a file, twice, but that is no longer possible. Office simply freezes whenever I attempt to save something. Since this is a clean install and no configuration files were retained from the original installation I have to assume there is something wrong with the openSUSE installer in version 11.0

It’s all very frustrating. YAST finally works 10 times better than it ever has, but I can no longer run openOffice or VirtualBox. Unacceptable compromise. I’m looking at Debian to see if I have as many problems getting it properly installed.

openOffice has magically started working again. Not sure why. I had a problem installing Debian (the installer failed to load either grub or lilo) and didn’t have time to sort it out. I decided to try a reinstall of openOffice (third attempt) on my openSUSE machine.

First, I decided to copy all of my old configuration files to my new system to see if I could restore some of the stuff I lost during the upgrade–like all my contact info, which mysteriously disappeared. Anyway, prior to doing that I noticed there were quite a few very old, no longer used, config files so I started cleaning house. Nothing related to openOffice, since I had previously deleted those. I also went back and reviewed all my installed packages and removed stuff I didn’t need or want, like KDE4 games (??? after selecting a KDE3 install, why???), beagle, mono, etc. Again, nothing I could see that was related to openOffice.

When I was done cleaning house, I decided to install openOffice piecemeal with the idea that I might identify a specific component that was causing the problem. At each step, I tried loading one of the office programs and attempted to save a file. First was Writer, and I was surprised to find it was now working. Next up Calc. It too worked fine. In fact, openOffice seemed to be much more responsive than it ever was. Emboldened, I continued adding packages, Presentation, thesaurus, clipart, etc. Everything EXCEPT KDE extensions.

Everything is now working as it should–better than expected. I have no idea what the original problem was or how it was corrected. I don’t think I’ll take any chances with reinstalling VirtualBox until Sun releases a binary specifically for this version of openSUSE as everything is now working better than it ever has.

Will still be looking at Debian (Lenny) this weekend as I’m really tired of spending days sorting out my system every time I do an upgrade. So far (installer failure) it doesn’t look any better than any other distro out there, but it’s early yet.

I just installed the Sun Virtualbox 1.6.2 RPM for 10.3 on 11.0 after installing dependencies (pam-devel, gcc, make, kernel-source) and it works just fine. Even get a 1024x800 XP screen. This is on an old i586 machine.

Guess I’m just the unlucky one–though luck shouldn’t play any part in routine package management practices. I had no problem with VB 1.5.6 under 10.3 but I’ve never gotten 1.6.2 to run. As I said before, I never see any dependency warnings, the modules install and load (lsmod), but the application WILL NOT run.

I’ve installed via both YAST and RPM. Same result. I even tried installing 1.5.6 as another poster suggested, and the vanilla “linux” version. EXACT same problem with the EXACT same symptoms–a “symbols” error. I’ve tried ALL of the above SEVERAL times. I even tried the OSE version without success (though I can’t recall the error).

I’ve flat out given up unless someone can come up with something more specific than “it works for me”.

I’ve been through a long and torturous journey, but I do finally have VirtualBox running under 11.0. I won’t go through all the gory details of moving to SIDUX then to Debian Lenny, back to openSUSE 10.3, before finally returning to openSUSE 11.0–via broken audio, broken wireless, broken “downgrades”, broken “upgrades”, bad DNS servers, and a complete loss of all backup data–as that story is just too long and painful to retell.

Suffice it to say that VirtualBox is apparently dependent on some KDE4 libraries. I can’t verify this, as I never received any dependency warnings during any of my numerous attempts to install various versions of the software. But after a clean install of openSUSE 11.0 in which I allowed a number of KDE4 specific applications and libraries remain (even though I’m not using KDE4), VirtualBox is now working.

ALL OPERATING SYSTEMS SUCK. Most Linux distros merely suck a little bit less than any of the alternatives.