Virtualbox error - Kernel Driver not installed


I’m new to Linux, but already learned a lot of it from the web.
I managed to install Virtualbox on my opensuse 11.2
I configured it for a windows xp guest OS.
When I start the guest OS, I get error mesages.

[ - Error In suplibOsInit.png]( - Error In suplibOsInit.png)
[ - Error.png]( - Error.png)

When I execute the command “/etc/init.d/vboxdrv setup” it failed.
I checked the directory and saw that the file vboxdrv is missing.

Can someone help me with this problem?

Thanks in advance


Alain Janquart

become su -

and do:

/etc/init.d/vboxdrv setup

Become su in Terminal - HowTo

I already tried that.
This is the result :
And this is the log file :

But that’s it. My knowledge does not reach far enough to go further.


Alain Janquart

Put the contents of
/etc/init.d/vboxdrv setup

in pastebin and link us to it

cat /etc/init.d/vboxdrv setup
will show the contents in a terminal

I hope I did this correct : Link


Alain Janquart

You did it right but I gave you the wrong location. Here, sorry

cat /var/log/vbox-install.log

Here is the new link

Please post result of:

rpm -qi kernel-source make gcc


zypper lu
uname -a

Here is the result of what you asked for : Link

su terminal

zypper in kernel-source

try again with vbox

This works fine now.

Thanks you very much for your help.


Alain Janquart

Good news
Thanks for getting back to let us know

Thank you for your help on this. I had to remove the open-SUSE completely to get this to compile. I would not have completed this without your help. Thank you again.


Maybe I’m too late, but I solved my problem with Virtualbox with the information at Virtual Box (Sun Version) Install HowTo

Excellent news!

For some reason I installed this today. (Ok been chomping at the bit to try LMDE)
I had to:
install vbox download
run:sudo /etc/init.d/vboxdrv setup
then reinstalled vbox download
then ran modprobe vboxdrv
To get rid of the error and failed building the kernel modules
"modprobe vboxnetflt failed. Please use ‘dmesg’ to find out why"
For some reason unknown to me it wouldn’t build without the reinstall step. I did try the prescribed methods first a couple times.
Now runs as advertised :slight_smile:
Updating my VBox LMDE installs 390 packages…

The issue I found is you have to completly remove openSUSE Vbox and then try the complie. If you have any part, then it will not compile and error out. this is what I found and had to solve.



I’m new in this forum (sorry if it’s not the right place to add a new thread).

I’m a beginner concerning virtual box (from Linux_Downloads - VirtualBox) installed on Opensuse 11.2 (uname -r: as kernel).
I ve read the information concerning the installation and installed the required files (make, gcc…) and kernel updates…
But I still get the same log error and i don’t now why my “kernel configuration is invalid”(see log) . How can i fix it?
Could you help me please?

Makefile:162: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
make KBUILD_VERBOSE=1 -C /usr/src/linux SUBDIRS=/tmp/vbox.1 SRCROOT=/tmp/vbox.1 modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || (
echo " ERROR: Kernel configuration is invalid.";
echo " include/linux/autoconf.h or include/config/auto.conf are missing.";
echo " Run ‘make oldconfig && make prepare’ on kernel src to fix it.";

ERROR: Kernel configuration is invalid.
include/linux/autoconf.h or include/config/auto.conf are missing.
Run ‘make oldconfig && make prepare’ on kernel src to fix it.

mkdir -p /tmp/vbox.1/.tmp_versions ; rm -f /tmp/vbox.1/.tmp_versions/*

WARNING: Symbol version dump /usr/src/linux-
is missing; modules will have no dependencies and modversions.

make -f scripts/ obj=/tmp/vbox.1
/tmp/vbox.1/Makefile:162: Warning: using /usr/src/linux as the source directory of your Linux kernel. If this is not correct, specify KERN_DIR=<directory> and run Make again.
gcc -Wp,-MD,/tmp/vbox.1/linux/.SUPDrv-linux.o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.4/include -Iinclude -I/usr/src/linux- -include include/linux/autoconf.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mno-red-zone -mcmodel=kernel -maccumulate-outgoing-args -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -fomit-frame-pointer -I/usr/src/linux/include -I/tmp/vbox.1/ -I/tmp/vbox.1/include -I/tmp/vbox.1/r0drv/linux -I/tmp/vbox.1/vboxdrv/ -I/tmp/vbox.1/vboxdrv/include -I/tmp/vbox.1/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.1/linux/SUPDrv-linux.o /tmp/vbox.1/linux/SUPDrv-linux.c
/tmp/vbox.1/linux/SUPDrv-linux.c:1: error: code model ‘kernel’ not supported in the 32 bit mode
/tmp/vbox.1/linux/SUPDrv-linux.c:1: sorry, unimplemented: 64-bit mode not compiled in
make[2]: *** [/tmp/vbox.1/linux/SUPDrv-linux.o] Error 1
make[1]: *** [module/tmp/vbox.1] Error 2
make: *** [vboxdrv] Error 2

Virtual Box (Sun Version) Install HowTo

Thank you for your answer!
… but is this guide ok for opensuse 11.2 ?