VirtualBox Effective UID is not root

Hello all, i have one small problem, i installed VirtualBox, and every time i start VirtualBox for the second time (just after the install and first run it works) i get Effective UID is not root. Now the funny part, i am in vboxusers group

cat /etc/group | grep vboxusers

and despite that i can’t run it as a normal user. I read somewhere to chmod it but it always works only one time, if i try to run it for the second time it is back in the same situation. I am using secure file permissions btw.

Anyone help plz :wink:

I checked permissions from /etc/, here’s the output for VirtualBox

cat /etc/ | grep vboxusers
/usr/lib/virtualbox/VirtualBox root:vboxusers 0755
/usr/lib/virtualbox/VirtualBox3 root:vboxusers 0755
/usr/lib/virtualbox/VBoxBFE root:vboxusers 0755
/usr/lib/virtualbox/VBoxHeadless root:vboxusers 0755
/usr/lib/virtualbox/VBoxSDL root:vboxusers 0755

Should i adjust it somehow different?

I guess i solved it. I changed permissions in /etc/ for virtualbox to 2755 instead 0755 and it works now every time. The permissions.easy got 4750 so maybe i could adjust it even more to 2750 ??

For your information, you can get VirtualBox 2 ways:

  • the VirtualBox repository
  • the VirtualBox web site

I have discovered that VB3 from the VB repo has this very problem you’ve had.
If you download the Suse rpm from the VB web site, you will not have that problem.

Actually i donloaded it from the website and i always do. As i explained later it is a matter of permissions in /etc/

If i had it as 0755 then i couldn’t run it BUT if i changed it to 2755 or 4755 then it worked with no problems. So that’s the issue here.