Virtualbox doesnt start VM, problem with vboxdrv?

Hi everybody.

When i try to start a XP Vm, virtual box shows two dialogs, the first:

Código Resultado: 
NS_ERROR_FAILURE (0x80004005)
IMachine {540dcfda-3df2-49c6-88fa-033a28c2ff85}

The second dialog is:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Re-setup the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.

So, it doesnt start. I execute that command and shows:

alex@altair:~> sudo /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module                                                                                                 done
Recompiling VirtualBox kernel module, NOT. It has been packaged.Recompiling VirtualBox netflt kernel module, NOT. It has been packdone.
Starting VirtualBox kernel module                                                                                                 failed
  (modprobe vboxdrv failed. Please use 'dmesg' to find out why)

If i check the dmesg, it doesnt show any error message :S …

The installation was with: sudo zypper in virtualbox

And, this are the packages that are already installed:

alex@altair:~> sudo zypper se virtualbox
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre                         | Resumen                                    | Tipo
i | virtualbox-ose                 | VirtualBox OSE is an Emulator              | paquete
  | virtualbox-ose                 | VirtualBox OSE is an Emulator              | paquete src
i | virtualbox-ose                 | virtualbox-ose: fix for denial of service  | parche
i | virtualbox-ose-guest-tools     | VirtualBox guest tools                     | paquete
  | virtualbox-ose-kmp-debug       | Kernel Module for VirtualBox               | paquete
  | virtualbox-ose-kmp-default     | Kernel Module for VirtualBox               | paquete
i | virtualbox-ose-kmp-desktop     | Kernel Module for VirtualBox               | paquete
  | virtualbox-ose-kmp-pae         | Kernel Module for VirtualBox               | paquete
  | xorg-x11-driver-virtualbox-ose | VirtualBox X11 drivers for mouse and video | paquete

The computer its a core2duo with 3 gigs of ram.

So, whats the problem? What do i am missing? :frowning:

Thanks in advance for all your help :smiley:

Don’t know I installed the generic Vbox from Sun have no problems. Note it requires Kernel-source and gcc compiler installed.

Do you have anything special installed maybe a other then default kernel. What repositories are you drawing from?

zypper lr -d

This are my repos:

#  | Alias                 | Nombre                | Activado | Actualizar | Prioridad | Tipo   | URI                                                                                 | Servicio                                                                                          
1  | Juegos                | Juegos                | Si       | No         |   99      | rpm-md |                      |                                                                                                   
2  | KDE_3.5_Stable        | KDE 3.5 Stable        | No       | No         |   99      | rpm-md |                   |                                                                                                   
3  | KDE_4.3.5_Stable      | KDE 4.3.5 Stable      | Si       | Si         |   99      | rpm-md | |                                                                                                   
4  | Libdvdcss repository  | Libdvdcss repository  | Si       | No         |   99      | rpm-md |                                                |                                                                                                   
5  | OpenOffice_3.2_Stable | OpenOffice 3.2 Stable | Si       | Si         |   99      | rpm-md |     |
6  | Packman Repository    | Packman Repository    | Si       | No         |   99      | rpm-md |                                         |
7  | google-chrome         | google-chrome         | Si       | Si         |   99      | rpm-md |                                          |
8  | repo-debug            | openSUSE-11.2-Debug   | No       | No         |   99      | NONE   |                      |
9  | repo-non-oss          | openSUSE-11.2-Non-Oss | Si       | Si         |   99      | yast2  |                        |
10 | repo-oss              | openSUSE-11.2-Oss     | Si       | Si         |   99      | yast2  |                            |
11 | repo-source           | openSUSE-11.2-Source  | No       | No         |   99      | NONE   |                     |
12 | repo-update           | openSUSE-11.2-Update  | Si       | Si         |   99      | rpm-md |                                           |
13 | subpixel repository   | subpixel repository   | Si       | No         |   99      | rpm-md |      

Thanks :smiley:

I don’t know what 1 and 13 are the rest look ok. What kernel?

I still suggest you get the generic package from Sun it will compile to any kernel.


alex@altair:~> uname -a
Linux altair #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 i686 i686 i386 GNU/Linux

1 are Games, and 13 are Font Smooting from xD

Well, i will download the package from sun, but why this doesnt work?

New to suse and vbox but i had the same problem.
Just restart your new kernel after vbox installed.
Then edit your user account settings to allow access to vboxdrv in Yast under user managment.

ANd logout and back in.

Hi there.

Thanks for your reply, but that was the first thing that i did after i intalled vbox :wink:

And nothing :frowning:


According to your second and third snippets… the reboot and adding yourself to the vbox group should have worked. have you tried to start virtualbox by using the virtualbox ose gui? If you’re using kde, then it should show up in the menu search for virtualbox ose.

Hash: SHA1

Add the VirtualBox repo: zypper ar VirtualBox
then zypper in VirtualBox-3.1

You also need the gcc, kernel-desktop-devel, kernel-source and
linux-kernel-headers packages installed

No in elenath hîlar nan hâd gîn
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


I dun think so… If he installed it via yast=>software management all the required packages would have been installed automatically by default. Although, deleting and reinstalling the packages via yast might help.

Hash: SHA1

Yes and no, zypper/YaST install all the packages required for running
VirtualBox, but not to compile the vbox kernel module, if you don’t have
the kernel sources and install VirtualBox you have to install it, at
least for the 32 bit version, x86_64 I had always installed it with all
the development stuff

No in elenath hîlar nan hâd gîn
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE -


Well, added the Virtualbox repo, then checked and installed the VirtualBox package, and now its working pretty good :smiley:

Thanks to everybody for your help :smiley:

Does this mean that the version of VirtualBox that can be installed from the openSUSE repository is old? The reason I’m asking is that I just installed VirtualBox (OSE, v. 3.0.6-9.11.2-x86_64) and ran into the same problem:

$ modprobe vboxdrv
FATAL: Module vboxdrv not found.

I’m not new to Linux but I’m quite new to kernel modules. From what I understand from the following code, the vboxdrv module is older than my kernel, which might be causing the problem:

$ modinfo /lib/modules/
filename:       /lib/modules/
version:        3.0.6_OSE (0x000e0000)
license:        GPL
description:    VirtualBox Support Driver
author:         Sun Microsystems, Inc.
srcversion:     0A5D4A3A3D4724CDBC705A8
vermagic: SMP preempt mod_unload modversions
parm:           force_async_tsc:force the asynchronous TSC mode (int)

$ uname -a
Linux linux-xw60 #1 SMP PREEMPT 2010-01-27 08:20:11 +0100 x86_64 x86_64 x86_64 GNU/Linux

Am I completely wrong?

Not really. Suse usually likes to test it and configure the packages before they release into their repos. And suse had to break some repos/packages due to legal issues; like mp3. Don’t know if that’s relevant to this though.

Did you do a full system reboot? I pretty sure thats from the module not being loaded when starting the kernel. Or you can see if you can push it with insmod.

The problem is that the OSE version has to be updated everytime the kernel is updated to keep the versions the same and the OSE package doesn’t always track the kernel package. There is no provision to recompile in the OSE package. Just the way it has been packaged, not a limitation of the OSE sources.

The PUEL edition can be recompiled whenever the kernel is updated, however this means having the kernel-source package installed also keeping it up to date whenever the kernel is updated. Normally this happens automatically as kernel-source tracks the other kernel packages.

Yes, I did a full reboot. It didn’t help. This, on the other hand, did (until the next reboot, of course):

$ insmod /lib/modules/

After the above command, VirtualBox starts and works just fine. However, I don’t feel perfectly confident about this approach. Somehow it feels “wrong” that I push older modules into my kernel. May be just my imagination, though…

Thanks for your help!

Found the same problem with Virtualox-OSE. Even after fullfilling the requirements mentioned.
Downloaded the one in and it worked like a charm. lol!