VirtualBox can't install GuestAdditions after update to VB 5.2.4 (Tmblwd host, Win 8.1-64 guest)

Host system: openSUSE Tumbleweed, updated to version 20180110 yesterday (01/15/2018), and installed Intel microcode update today (01/16)

Oracle VirtualBox: Updated to version 5.2.4 yesterday, had 5.1.30 before; each one with appropriate extension pack

Guest system: Windows 8.1 Pro 64-bit, virtual machine built from scratch approx. two weeks ago under VB 5.1.30, including 5.1.30 GuestAdditions back then

The problem now is: After updating to VB 5.2.4 under Tumbleweed (via zypper dup --no-allow-vendor-change) including the new VB extension pack, VirtualBox now stubbornly refuses to get the new GuestAdditions installed for my Win 8.1 virtual machine. Both the VirtualBox menu bar “Devices” → “Insert Guest Additions CD Image” procedure and the virtual media manager procedure “Devices” → “Mount CD/DVD ROM” → “CD/DVD ROM Image” do fail stubbornly. The VirtualBox error message from both procedures is:

Das virtuelle optische Medium /home/myself/.config/VirtualBox/VBoxGuestAdditions_5.2.4.iso konnte nicht in das Laufwerk der Maschine Win8.1-Pro-64_DynVD eingelegt werden.

Could not mount the media/drive '/home/myself/.config/VirtualBox/VBoxGuestAdditions_5.2.4.iso' (VERR_PDM_DRIVER_NOT_FOUND).

Fehlercode:NS_ERROR_FAILURE (0x80004005)
Interface:IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
Callee:IMachine {85cd948e-a71f-4289-281e-0ca7ad48cd89}

I tried to resolve this failure first by de- and re-installing VirtualBox again today, but this didn’t help; same error and same error message. I also uninstalled the old GuestAdditions 5.1.30 in my virtual machine manually; yet no success with the new GuestAdditions thereafter.

Everything regarding VB, this Win 8.1 VM and the GA had worked fine under VB 5.1.30. I should also like to add that the virtual machine does handle the physical optical drive fine under VB 5.2.4.

What’s going wrong here with VB 5.2.4 and the GuestAdditions? Thanks in advance for any community help available.

SOLVED. Oops, my fault. It took creating an empty virtual media slot underneath the SATA controller in VB 5.2.4. I don’t think I had done this under previous 5.1 versions.