Virtualbox Bridge

Virtualbox 2.2.4 Fedora 11 on Suse 11.1 host

My LAN consists of a laptop and several pc’s connected via a router to the net. It uses dhcp mostly for networking. The network address can be the same if you switch off one box and start another. That same address is retrieved from the router.

I would like to set up some static address for virtualbox distros. To do this I have to bridge the eth device on my Suse box, and then pick this as the network device in Virtualbox Settings. If I set up a bridge in Yast Networking I have to change the eth1 (connected to the net) address to

My question is, will this stuff up my existing network ? Will it stop my Suse box from accessing the net ?

I don’t think you need to do this muckety-muck with VBox bridges since 2.2. Just set the VBox interface to Host Interface Networking, attach it to a physical interface and assign whatever IP address you need to the VBox interface. No need to create a bridge device, etc.

Ok. This is one area where googling may get you into trouble. Some of the posts re Vbox Networking may not apply to the most recent release - leading me down the wrong path.

I will look again at host only networking.

Ok if you choose the Host-Only Adapter in Settings > Network,it creates the vboxnet0 interface, and assigns a network address. I can ping this on my Suse Host.

I am not sure how to use this interface in the Virtual Machine. Does this become my ip address ? And does vboxnet0 become the ethernet device in the virtual machine ?

I’m looking at 3.0 at the moment, hopefully 2.2 is the same. The “Attached to” dropdown should be set to Bridge Interface, out of a choice of five: Not attached, NAT, Bridge Interface, Internal Adapter and Host-only Interface. Previously a bridged interface was described as HIN in the documentation, hence the confusion.

Once you have chosen that, the “Name” dropdown gives you a choice of eth0, eth1, etc up to all the physical interfaces you have on your system.

That’s all there is to it.

If you don’t find it in 2.2 perhaps you should update to 3.0.