VirtualBox add hard disk

Virtual Box 1.6.2 Sun/Innotek version on SuSE 10.3.

My XP guest is starting to fill up the virtual hard disk. So, I follow
instructions and create a second 10Gb dynamic *.vdi, register it as
primary/slave and restart XP.

Both hard disks now appear in Device manager but only the primary/master
(C: drive) shows up in “My Computer”.

Much rereading of manual/help file has left me no closer to a solution.
Probably something stupid I’ve missed. Any suggestions?](http://www.sosonike.com)

Not “stupid,” but remember that you now have to make Windows recognize the drive. Do the same things you would if you’d installed a physical hard drive on a Windows PC: run fdisk or some other partitioner to create the partition, format it, and reboot. Windows will then recognize and include the new drive (typically as D: or E:, depending on where your CD/DVD is at in the scheme).

Out of curiosity, it is intentional or there is a malware on your system that you are now aware of?

As smpoole7 suggested you should somehow format your new disk. One way of doing this in XP is: right click on My Computer->Manage->Disk Management. A wizard window appears on your screen, click Next and convert your unformatted disk. Then choose the appropriate settings and format the disk, the rest is easy.

You can assign it a drive letter in “Disk Management”.
Right mouse click My Computer > Manage > “Disk Management”