VirtualBox 4.0

VirtualBox 4.0 is now available from the Oracle VirtualBox repo. You could install it directly by just typing:

zypper in virtualbox-4.0

However (unlike in Ubuntu), it won’t cleanly deinstall the previous version (3.2), so that under openSUSE, it seems more reasonable to deinstall version 3.2 first:

zypper rm virtualbox-3.2
zypper in virtualbox-4.0

Since 4.0, USB support is not included in the PUEL version anymore but has to be installed separately: Installing VirtualBox and extension packs.

The script VBoxExtensionPack below can be used (on any Linux distro) to install the Extension Packs provided by Oracle:

#! /bin/bash

# download VirtualBox Extension Pack
echo "- Downloading $pkg_url ..."
wget $pkg_url -O $pkg_tgz

# extract archive in current directory
if  -f ./$pkg_tgz ] ; then
	VBoxManage extpack install $pkg_tgz
	echo "No extension pack found"

Or … if it looks too complicated - scripts (especially mine) often look more complicated than the task they perform - simply copy/paste the following two commands in a root terminal:

wget [noparse][/noparse] -O Oracle_VM_VirtualBox_Extension_Pack.tgz ;
VBoxManage extpack install Oracle_VM_VirtualBox_Extension_Pack.tgz

Provided the kernel sources and compiler are already installed (which will be the case if you used the 3.2 PUEL version before), the kernel module will be compiled an installed and the program will be usable right away.

To have the module automatically recompiled after a kernel update, you can use the modautocompile service as before: automatically recompile kernel modules after kernel update. Well … I would assume that it still works, but will be able to tell for sure after the next kernel update.

Thank you. Your suggestions on deinstall and reinstall worked perfectly and I am enjoying the new 4.0 verson! :slight_smile:

What are the advantages of this new version? I’m quite satisfied with the previous one. But if this one includes something interesting…

Changelog - VirtualBox

Does not work for me. Under VB4, all of my existing virtual machines crashes my system at boot

Hi please_try_again,

Worked like a charm :slight_smile:

Many thanks!

You also might be interested in this;

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (i586) Kernel
up 2 days 18:21, 2 users, load average: 0.11, 0.14, 0.06
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I have 2 GB of memory on a x64 system, and i tried to use 768MB on a XP VM, wich was ok un 3.2 version but now it gives me VERR_NO_MEMORY!
4.0 is just a c*ap!

There is a bug however in 4.0: it crashes with a segfault as soon as you try to edit vm properties: virtualbox segfault when try edit VM properties. I confirm the bug on Ubuntu but I haven’t experienced it on any on my openSUSE machines (weird, as others confirmed the bug on openSUSE too). I tried on several machines, under Gnome, KDE and IceWM, all running kernel, 32 and 64 bit, ATI un Nvidia, single and dual screen, PC un Mac hardware … it just hasn’t crashed a single time for me under openSUSE. :\

I was happily running VirtualBox 3.2 on my openSUSE 11.3 installation but have been forced to upgrade my kernel to the 2.6.37 version from the Kernel:Head repo due to a massive bug that was ruining my system for months. Problem is I had to pull in VirtualBox 4.0 from the Kernel:Head Virtualization repo to resolve dependencies (no I didn’t uninstall 3.2 first) and now trying to run a VM prompts to run vbox setup, which produces this error:

Stopping VirtualBox kernel modules                                   done
Uninstalling old VirtualBox DKMS kernel modules/etc/init.d/vboxdrv: line 278: /usr/share/virtualbox/src/vboxhost/do_dkms: No such file or directory
Removing old VirtualBox netadp kernel module                         done
Removing old VirtualBox netflt kernel module                         done
Removing old VirtualBox kernel module                                done
Trying to register the VirtualBox kernel modules using DKMS/etc/init.d/vboxdrv: line 296: /usr/share/virtualbox/src/vboxhost/do_dkms: No such file or directory
  (Failed, trying without DKMS)
Recompiling VirtualBox kernel modules                                failed
  (Look at /var/log/vbox-install.log to find out what went wrong)

That log file show this:

/etc/init.d/vboxdrv: line 300: /usr/share/virtualbox/src/vboxhost/vboxdrv/build_in_tmp: No such file or directory

There is no /src/ folder in the above path, only /nls/
Any idea how to get around this? I tried uninstalling, rebooting and then reinstalling VirtualBox to no avail.

May have answered my own question, since finding the same query on another forum post:
Virtual Box (Sun Version) Install HowTo
where it is suggested to run
zypper in -t pattern devel_basis devel_kernel devel_c_c++

I tried selecting those patterns for install in YaST and it wants to pull in well over 100 packages. There’s simply no way I can accept that. I didn’t need them before, so why should they be necessary now?

That’s right. To use this version, you have to compile the vboxdrv module at installation time and after each kernel update - same as for the proprietary video drivers from ATI and Nvidia. However I don’t think that devel_c_c++ is needed. devel_basis and the kernel headers should be sufficient. So that would be:

zypper in -t pattern devel_basis
zypper in  kernel-devel kernel-source kernel-desktop-devel (or kernel-default-devel).

Notice that the first command installs patterns while the other one installs packages.

I you were using the OSE version before, there were not needed, as the kernel module came precompiled. You can safely install these packages.

There is a reported bug in virtualbox-host-kmp-(default|desktop)-4.0.0_k2.6.37-6.1

In order to load the vboxdrv module I found it necessary to install virtualbox-devel at the same time.

If you install from the openSuSE repositories there is no need to compile, and no need for the kernel development stuff required when using the Oracle rpms.

The segfault issue seem to be fixed in version 4.0.2 r69518. Although I did not encounter this bug previously under openSUSE (4.0.0 r69151), the new version fixed it to day on Ubuntu and Fedora.
Just refresh the virtualbox repo and update to that version.

This is correct. But in order to avoid confusion, I should point out that this thread is about the Oracle version, which can be installed from the Oracle repository: [noparse][/noparse]]( As for “kernel development stuff”, many users need it already, as it is also required by ATI and Nvidia kernel proprietary drivers. Recompiling can be achieved automatically at the next reboot after a kernel update with the modautocompile script, that works as a service.

Downloaded virtual box 4 from website and installed, but it did not install kernel drivers. Had a look at the kernel that am using and is kernel-desktop. How does one go about getting the kernel driver for virtual box?

Install the required packages as described in post #12 above.
Then run the following command as root:

service vboxdrv setup

I successfully installed VirtualBox-4.0 on 4 PCs thus far (all running a 64-bit openSUSE-11.3 with KDE-4.4.4):

  • 64-bit Intel P8400 Core2 duo
    w/4GB RAM (64-bit Dell Studio 1537 Laptop), w/ATI Radeon 3450HD graphics [age ~2+ years] running 64-bit openSUSE-11.3 KDE-4.4.4 and latest proprietary ATI Catalyst driver (this is the laptop I use for business trips, and also take on vacations)
  • 64-bit Intel Core i7 920
    w/6GB RAM (Asus P6T Deluxe V2 motherboard) w/ PCI-e nVidia GeForce GTX260 graphics [age ~2 years] runing openSUSE-11.3 KDE-4.4.4 and latest nVidia proprietary graphic driver (this is my main desktop PC).
  • 64-bit Intel Core i7-860
    w/6GB RAM (Asus P7H55-M, H55 motherboard) w/GeForce G210 graphics [age ~2 months] (my wife’s new PC) running openSUSE-11.3 KDE-4.4.4 and latest nVidia proprietary graphic driver (but my wife mainly boots direct to winXP on this PC).
  • 64-bit HP P6510F w/AMD Athlon II X4 630 cpu
    w/4GB RAM, w/ATI Radeon 4200 graphics [age ~3 months] (my mother’s PC) [which is using the open source radeon driver to make my remote updates less risky] running openSUSE-11.3 KDE-4.4.4 with radeon open source graphic driver. My mother’s PC is in Canada and I live in Europe, so I installed this remotely from Europe using vnc to take over her desktop for the install.

Thus far it works well.

Here’s an updated version of the VBoxExtensionPack script posted in #1

#! /bin/bash
# Install VirtualBox (Oracle) extension pack. 

which vboxmanage > /dev/null 2>&1 || exec echo "vboxmanage not found"
ver=$(vboxmanage -v)


# download VirtualBox Extension Pack
echo "- Downloading $pkg_url ..."
wget $pkg_url -O $pkg_tgz

# extract archive in current directory
if  -f ./$pkg_tgz ] ; then
        vboxmanage extpack install $pkg_tgz
        echo "No extension pack found"