VirtualBox, 3D acceleration & GNOME - icons are not shown

I installed OpenSUSE 13.2 with GNOME in VirtualBox (version 4.3.26 running on Windows 7 Professional 64-bit) with 3D acceleration enabled. When selecting Activities > Show Applications > All several pages are shown, but no icons are displayed. On the other hand, if I disable the 3D acceleration, the icons are shown. When searching for an application and while 3D acceleration is enabled the application icons are only displayed when the result contains 4 or less matching applications. Is there a solution for this problem? Or is this a known bug?

Nobody else encountering this behavior?

You might want to try asking this question in the Virtualbox forum.

Did that and now waiting for somebody that has experienced the same problem. Btw, also installed OpenSUSE in a fresh VM from the GNOME live ISO, but with no success to get icons back when enabling 3D acceleration.

Virtualbox-Guest-Additions are installed inside openSUSE?

Please delete all installed packages with virtualbox or vbox in the name in Yast-----Software and install the Guest-Additions.

Yes, they were installed by default. I uninstalled and installed the guest additions provided by VirtualBox itself. No change :frowning:

In the Virtualbox Settings for that Maschine 3D ist set and 2D is disabled?

How many Memory has the Graphics Adapter?
How many Memory the Maschine?
PAE, nested Paging and VT-x is enabled? Also in Bios?

I am here on openSUSE Host and openSUSE Gnome Guest without any Problems.
4GB Guest, 128 MB Graphics Memory.

VM settings:

  • memory: 2048 MB
  • VDI: 40 GB, dynamically allocated
  • CPU: 2 processors
  • display memory: 128 MB
  • 3D acceleration: enabled
  • 2D Video acceleration: disabled
  • 1 shared folder with auto-mount
    otherwise default settings for VM as proposed by Virtualbox:
  • Motherboard > Chipset: PIIX3
  • Pointing Device: USB Tablet
  • I/O APIC enabled
  • PAE/NX disabled
  • VT-x/AMD-V enabled
  • Nested Paging enabled

Btw, when looking at Activities > Show Application > Frequent icons are shown, but they are missing when clicking on All.