VirtualBox 3.0.4 opensuse 11 and abnt2 keyboard

Hello, I’ve installed VirtualBox 3.0.4 from the official RPM in my openSuSE 11 machine. Everything worked quite well but my keyboard.

My keyboard is an ABNT2 Brazillian Portuguese keyboard. The KDE environment is correctly configured with this layout, but in my VirtualBox machines the non-numpad ‘/’ ‘?’ and numpad ‘.’ keys do not work. All other keys work correctly, but these just don’t seem to work at all.

I saw the same version in Ubuntu working properly, so this may be really related to openSuSE 11.

I think it’s a glitch with the way X is configured in opensuse. This problem also happens with vmware. For a vmware solution google “vmware abnt”.

The solution involves editing /usr/lib/vmware/config
to add this line:

xkeymap.keycode.211 = 0x073

I think you can do this generally for your user by adding something similar to ~/.xmodmap. This will require some research, however.

Good luck.

Actually, I’m familiar with that error in vmware and used to fix it just the way you told me to, but this error also happens in Ubuntu, so it probably is not the same error.

Im trying to find differences related to xmodmap between my openSuse and the Ubuntu that doesn’t have this problem to see if I can work something out. If someone already fixed this, please let me know.