Virtualbox 2.0.6 on Opensuse11 network bridging

Hello, I am getting stuck about the bridging configuration on a VM host (Virtualbox 2.0.6) running opensuse11, wherein I am attempting to use several guests, as XP, Solaris 10 and Opensolaris 2008/05.

What I want is to bridge the virtual interface “tap0” with the wifi interface “wlan0”.

Please note: This kind of bridging works perfectly on a “mirror” environment, wherein I use a VM host running windows XP, along with a Solaris 10 as guest.

I followed several how-to and instructions, as the ones reported here VirtualBox - openSUSE as well the ones we can read onto the Virtualbox Help GUI.

Unluckily I get the following issues:

  1. My bridge “br0” interface never starts on boot; I have to manually start it with “ifup br0” also if I have the ifcfg script on place
  2. “br0”, whenever starts, pull down the connection from wlan0, managed by Networkmanager, which lacks the connectivity from the Internet, as well as the routing toward the outside
  3. I don’t understand why into many “/etc/sysconfig/network/ifcfg-br0” is present just one interface into “bridge-ports”, when I suppose to have at least two: the primary and the virtual.
  4. All the issues I revealed above, attempting to use the wifi interface “wlan0” are exactly the same also if I try to use the primary ethernet “eth0”

It seems that something is lacking on my configuration.
I would like to know if someone have been able to configure and use a network bridging on Virtualbox host running opensuse11 and a guest running other O.S.
both using the ethernet interface or wifi.


I think you’ll find that bridging will not work with wireless devices. It’s in the VirtualBox docs. However bridging works fine with wired devices. Yes I had it working. Unfortunately for you my setup was for Ubuntu. But you should find a worked example for OpenSUSE in the docs I believe.

Thanks ken_yap; after some investigations I understood that at the moment are existing some limitations both on bridge_utils as well as on Virtualbox, regarding the wireless bridging.

Hopefully it seems that such limitations will be eliminated with next maior release.

By the way the solution to configure a bridge between virtual interface and wireless physical interface, is by using parprouted :](

Is this a new Bridging issue with OpenSuse11 ?

I know when using SLED 10.3 I had to jump through a few hoops to configure the bridge to work fior wireless but I was eventually able to make it work. I believe it was tricking the Windows Guest to think that the wireless was a wired connection or something.

I haven’t tried Virtual Box on OpenSuse11 yet.

Bridging on Virtualbox hosts running Opensuse 11 is proved to works using ethernet interface (i.e. eth0) but this is not yet supported with wireless cards.
The only way for the moment is by using proxy arp parprouted.

I have my system bridged (wlan0-tap0) through parprouted and it is working.