VirtualBox 2.0.0 OSE error

I have isntalled VirtualBox 2.0.0 OSE and I have an error when I click “finish” at the end of new virtual machine wizard

Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)

Any ideas?

Had the same exact problem after I upgraded from 1.64 to 2.00 today. I cannot start my existing VM.

Try the new version 2.02 of virtualbox.

Thomas

I tried but it is more buggy than 2.0.0 OSE :slight_smile:

Tried it and it works for me.

I had this error too. I had been using the OSE version too. Anyway, I decided to remove OSE and installed the Sun version. Working fine. Remember to enable USB in the settings for the VM’s or like mine it may crash.

It works directly run as root. It’s a known problem with setuid root and now hardening features that will be hopefully fixed soon in the OBS package (maybe once update to 2.0.2).

Yeah but when click “Finish” in new New Virtual Machine wizard (in Sun’s 2.0.2) there a “spawning sessions” window appear and it stays at 0% forever :confused:

Is there an error log?
The whole box is still operational - Yes?

Can you get a screen shot. I just can’t picture what you mean.

Here –>

http://img.wklej.org/images/66193Screenshot.png

And it stays at 0% forever :\

Any ideas?

I don’t just recall ever seeing that ‘spawning session’.

I’ll have a go at creating a VM from scratch, because all mine ar from the OSE version.

I’ll report back.

Ok :slight_smile: I have seen this error also at ubuntuforums :slight_smile: but I haven’t found any solution.

Ok. I set up a new machine with 6GB allocated VMHD
Disc created, no problem

Just ran DSLinux from an .iso

No problem.

At what point are you getting this error?

At the end of New Virtual Machine Wizard, it appear when I click “Finish”

I ran into this problem yesterday. My problem was that I did not have the kernel source installed. You may want to check if this is what is happening.

See my previous post about kernel sources. (I guess previewing the post is not such a bad idea…)

Ok, now it go forword but now when I start virtual machine I got:


The VirtualBox support driver which is running is from a different version of VirtualBox.
You can correct this by stopping all running instances of VirtualBox and reinstalling the software..
VBox status code: -1912 (VERR_VM_DRIVER_VERSION_MISMATCH).


Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {d5a1cbda-f5d7-4824-9afe-d640c94c7dcf}

I didn’t have this problem. If there is nothing you need saving, you could 1) remove or rename your ~/.VirtualBox directory, 2) uninstall and reinstall your software, and 3) reboot, if you haven’t done it already.

I tried but nothing helps :
Guess I have to wait for 2.0.2 OSE

Check you have no old packages installed - in Yast look for virtualbox
remove any ose vbox packages

in zypper as su

zypper se virtualbox

after it runs the repo’s it will output the installed packages
you should have only one

i | VirtualBox                     | Powerful PC virtualization solution        | package
  | virtualbox-ose                 | VirtualBox OSE is an Emulator              | package
  | virtualbox-ose-guest-tools     | VirtualBox guest tools                     | package
  | virtualbox-ose-kmp-debug       | Kernel Module for VirtualBox               | package
  | virtualbox-ose-kmp-default     | Kernel Module for VirtualBox               | package
  | virtualbox-ose-kmp-pae         | Kernel Module for VirtualBox               | package
  | xorg-x11-driver-virtualbox-ose | VirtualBox X11 drivers for mouse and video | package

that’s mine

notice the top one is the (i) installed and it’s not OSE - it will appear in Yast too as above.
If necessary re-run the rpm installer
Do a reboot too