Virtual PC 2007 sound problem

I have installed openSuse 10.3 on virtual PC 2007. By now, I have solved theese issues:

  • Solved X problem: boot level 3 and ‘sax2 -r -m 0=vesa’
  • Solved mouse problem: i8042.noloop
  • Partially solved sound problem: manually added sb16 with theese parameters:
    - Address: 0x220
    - IRQ:5
    - DMA8: 1
    - DMA16: 5
    - MPU adress: 0x330

When testing sound on YAST, sound blaster 16 appears perfectly configured, and sounds with NO PROBLEM.

But when I check sound in system monitor, I recceive no sound. Volume Monitor still appears INACTIVE. When trying to open it, I receive a error message telling me GStreamer is not properly configured becouse I don’t have installed the proper plugin(I don’t know if I need to install anything more) or because I don’t have any sound card installed and configured(but I have, installed, configured, an set as my primary sound card).

When checkin GStreamer properties in System Monitor, and test with output plugin set to Autodetect, I receive an error. GStreamer exists and sends bug report to internet.

What’s the problem? Anyone knows?

Thanks!

I have new details: I HAVE SOUND WHEN LOGIN AS ROOT.

Reading other posts I have added my user to the Audio group, but it doesn’t solve the problem.

So, for now, what i have to do is, logout (by now, i’m autologin), log as root (sound enables), logout again, and then login with my user. Then I HAVE SOUND with my user.

Any better workaround?