virtual keyboard

After upgrading to Leap15.4/KDE the virtual keyboard appeared again at login. Previously I deleted it (it was just one or two files) but this time when wanting to delete it it wants to remove all kind of other files:

zypper rm libqt5-qtvirtualkeyboard 
Reading installed packages... 
Resolving package dependencies... 

The following 15 packages are going to be REMOVED: 
  libqt5-qtvirtualkeyboard libqt5-qtvirtualkeyboard-hunspell plasma5-addons plasma5-addons-lang 
  plasma5-defaults-openSUSE plasma5-desktop plasma5-desktop-emojier plasma5-desktop-lang plasma5-session 
  plasma5-session-wayland plasma5-theme-openSUSE plasma5-workspace plasma5-workspace-branding-openSUSE 
  plasma5-workspace-lang sddm-theme-openSUSE 

15 packages to remove. 
After the operation, 73.9 MiB will be freed. 
**Continue? [y/n/v/...? shows all options] (y): **n

I don’t know if there are files in between which are used elsewhere (e.g. plasma5-desktop) but this keyboard is a nuisance. Can it simply be turned off? How can I get rid of this nuisance?

Yes, but, the setting ain’t nowhere in KDE … >:)

  • It’s in SDDM – man page for ‘sddm.conf’ but, please, don’t drop the setting into ‘/etc/sddm.conf’ – currently, it’s an empty file – use local administration files located in ‘/etc/sddm.conf.d/’

              Set the Qt input method for the greeter.  Tablet users with Qt Virtual Keyboard installed can set this to  "qtvirtualkeyboard"  for  the on-screen keyboard.
              Other known values are "ibus" for the Intelligent Input Bus, or "compose" for dead keys support.
              Leave this empty if unsure.

If you have a Tablet then, by default the KDE Virtual Keyboard is enabled and, in the KDE Plasma System Tray, an Icon should appear to allow you to control the Virtual Keyboard.

  • And, the SDDM Login Screen should offer an option to use the Virtual Keyboard or not, which should “remember the last status” from one login to the next …

To disable the KDE Virtual Keyboard when SDDM starts, create the file ‘etc/sddm.conf.d/General.conf’ – the SDDM parameter is located in the “General” SDDM configuration parameters section – with the following SDDM parameter setting:

  • An empty value – may well do the trick because, there’s nothing in the SDDM parameters set up in the system files located in ‘/usr/lib/sddm/sddm.conf.d/’ …

[HR][/HR]BTW – not a Tablet and therefore no Virtual Keyboard issues:

 > LANG=C zypper search --installed-only virtualkeyboard
Loading repository data...
Reading installed packages...

S | Name                              | Summary                                      | Type
i | libqt5-qtvirtualkeyboard          | Qt 5 Virtual Keyboard                        | package
i | libqt5-qtvirtualkeyboard-hunspell | Hunspell Plugin for the Qt5 Virtual Keyboard | package
i | libQt5VirtualKeyboard5            | Qt5 Virtual Keyboard library                 | package

Thank you very much, dcurtisfra, I created this file and it is working OK now without showing the virtual keyboard. First I have to say I upgraded my second computer from LEap15.3 to 15.4 and the virtual keyboard didn’t show up there - why? I don’t know. I played around with different display managers but could not find a satisfactory alternative. Now I have as you suggested:

**linux-tl1r:/etc/sddm.conf.d #** ls 
**linux-tl1r:/etc/sddm.conf.d #** cat General.conf  
**linux-tl1r:/etc/sddm.conf.d #** 

And the keyboard does not show up any more.

Just as an extra remark about my experience.

Some time ago I switched (using KDE System Settings) from Breeze for openSUSE to Elarun. The rseult was this virtual keyboard :(. I started a thread about this, but no easey solution came forward, so I switched back (after all, it is only eye candy).

I now used the solution above and switched again. No virtual keyboard anymore. Thanks @dcurtisfra.

The question is of course: why does that Elarun press the virtual keyboard upon the system, where Breeze for openSUSE doesn’t. About the same question that the OP has about why it does in 15.3 and not in 15.4.

As @dcurtisfra explains that the Virtual keyboard should be the default on tablets, I guess that the finding out if a system is a tablet is (or at least was before 15.4) still wonky.

I have had this on Leap 15.3 and 15.4. Both KDE.

In 15.3 you can delete libqt5-qtvirtualkeyboard without any problem and dependency, in Leap 15.4 it is not possible any more (see above).

So I added the entry after installing Leap 15.4, but here in this thread dcurtisfra was quicker…