Virtual Desktop Shortcuts Not Working

Got SUSE installed (11.2) but for some reason my virtual desktop shortcuts aren’t working. I have my drivers installed (Nvidia 8200M G) and the system sees and is using the device. Compositing is active, but Ctrl-Alt-Arrow Keys and my TAB combos do not work at all.

I installed Compix thinking that was it, but still no dice.

Any thoughts would be appreciated.

Not sure what you mean by “virtual desktop shortcuts”. Does the virtual desktop pager on the panel work when you click on it? Or are you just looking for keyboard shortcuts so you can switch virtual desktops without the mouse? You say you installed Compiz so is that with Gnome, or did you install Compiz in KDE and disable Kwin?

The little snapshot/pager is present in the taskbar and I can switch by clicking with the mouse. I’m a newbie, not sure what Kwin is.Don’t think I disabled it, but who knows! I’m running KDE.

Just the Ctrl-Alt-Arrow key and TAB stuff isnt working. They just wont swap.

OK, so what did you use before you installed openSUSE? And what do you want those keyboard shortcuts to do? And why did you install Compiz? A combination of the answers to these questions will, I suspect, solve your puzzle.

I used Ubuntu 9.08 I think and I used the Ctrl-Alt-Arrow keys to switch desktops (right to move right, down to move down, etc). I installed compiz thinking this was my problem (didn’t work before install either).


I believe Ubuntu uses compiz, so that would be the reason why your ctrl+alt+arrow key doesn’t work. In KDE to do this, click on the application launcher then choose Configure Desktop (Personal Settings). Under the category Computer Administration click Keyboard and Mouse. Click Global Keyboard Settings and then click the drop down menu next to KDE component and choose Kwin. Scroll down until you find Switch One Desktop to the Left and Switch One Desktop to the Right. Set the controls for those.

You’ll also have to set the control for Switch One Desktop Down and/or Switch One Desktop Up. This will let you use all four desktops (otherwise just left and right only let you go between desktops 1 and 2).

Take Care,


Ian, you are awesome, problem solved.

No problem,

Thank gminnerup for the process of elimination. I only knew what your situation was through the questions you answered.

Also, if you find Kwin does not meet your needs you can try my how-to on how to install and configure compiz here:

Installing and Configuring Compiz - openSUSE Forums

If you have anymore questions just post them on the forums :slight_smile:

Take Care,


Well to be honest (as a former Gnome user) I knew all along what his problem was… Just wanted to teach him to ask the right questions for others to be able to help him (which you then did), or alternatively to figure it out for himself, something like this: that keyboard shortcut did this in Ubuntu. It was defined in Compiz. I don’t need Compiz in KDE because of something called Kwin. Maybe KDE has its own way to define shortcuts?

I’ve got a similar problem. All global shortcuts for KWin have stopped working ─ no matter if they’re the default ones, or ones defined by me. All the window/desktop switching, compositing disabling shortcuts, hell, even alt+f4 have stopped responding. Other shortcuts, global or normal, are workingp perfectly fine. I’m running KDE 4.3.4 from the 11.2 Factory repo.

Why not just use the KDE 4.3.4 in the kde43 repo?

Try hitting alt+f2 to open Krunner then type:

kwin --replace

See if that then enables the keyboard shortcuts. I know that’s a problem in the unstable repository with KDE 4.3.81, that keyboard shortcuts don’t work upon the loading of KDE but after the kwin --replace command everything works fine.

Take Care,