Virtual Box

Not sure if this is the right area, if not, I apologize.

I have OpenSuse v11 KDE4. Used Yast to install VirtualBox. When I selected virtualbox-ose it also selected virtualbox-ose-kmp-pae. I did not select any of a few other options.

The install went well and quickly.

Creating a new box (for XP) was dead easy.

I click start in the VirtualBox window and I get the following error window…

VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing ‘/etc/init.d/vboxdrv setup’ as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).

Result Code:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}

When I run ‘/etc/init.d/vboxdrv setup’ as root, as instructed I get this…

linux-0l6j:/home/simon # /etc/init.d/vboxdrv setup
Stopping VirtualBox kernel module done
Recompiling VirtualBox kernel module, NOT. It has been packaged. done
Starting VirtualBox kernel module failed
(Kernel module not found)
linux-0l6j:/home/simon #

How do I address this? I love Linux but I must get some XP stuff running here (for work) and have had dismal luck earlier with dual-booting. VisrtualBox seems a good choice but I am stumped now.

Thanks in advance,

The vboxdrv has to start every time your PC starts. To do this, edit the followng file:

Go to /ect/sysconfig/kernel and add vboxdrv to MODULES_LOADED_ON_BOOT=“vboxdrv”

Now you need to add your user to the virtualbox group:

Make sure you are root when you type the following command in Konsole: usermod your username -A vboxuser

Thanks very much. When I run usermod I get this …

linux-0l6j:/home/simon # usermod simon -A vboxuser
usermod: Unknown group `vboxuser’.
linux-0l6j:/home/simon #


check and see if you are in vboxusers
YaST -> Security and Users -> UserManagement, - vboxusers group

have a read here
VirtualBox Installation - openSUSE

All suggestions checked out. I don’t know what I changed but I uninstalled and reinstalled and got a different error (something about version issues). Uninstalled again and reinstalled and it now seems to be working. As I type I am installing XP in VirtualBox.

Thanks for your patience and your help.


Just by way of interest. If you installed VBox from the standard repo/dvd, you can add this repo to your list Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0
It provides a more up to date version.

Also, once you have xp installed and then the VB additions, check out seamless windows.
A word of advice, I like to also use the ‘adjust window size’ from one of the tabs at the top left, once clicked, go to the maximaize on the xp machine. That way the xp desktop doesn’t keep disappearing - which I prefer sometimes.
Shared folder is handy, but takes a while to figure out, download the Vbox manual!

I have the same problem
when I go to Go to /ect/sysconfig/kernel and add vboxdrv to MODULES_LOADED_ON_BOOT=“vboxdrv”

I am not able to save the file since I am just a user.
How to I become a superuser?

If you don’t know that then chances are it’s not your PC. Ask the owner of the PC. He will have the root password.

I am the owner I have the root password but it doesnt ask for it.

if you use terminal you type su then password but if you use file manager to navigate to the file and open it. It never asks for the password.

do it this way

open YaST -> Security and Users -> UserManagement, and edit your user and add them to the vboxusers group. To do this, select your user name, click on Edit, switch to the Details tab and check the vboxusers check box.


YaST -> System -> /etc/sysconfig editor -> System -> Kernel -> MODULES_LOADED_ON_BOOT and just type in vboxdrv in the input box.

help page here
VirtualBox Installation - openSUSE

that was all done with no problems, actualy I have done it like 5 times since I keep unistalling it.

the problem is that after all that is done I get this message
The VirtualBox support driver which is running is from a different version of VirtualBox. You can correct this by stopping all running instances of VirtualBox and reinstalling the software

I also tried deleting the entire .virtualbox folder in home/user
any other ideas?

And thanks to all those trying to help

Add this suse 11 VBox repo to your list, unless you have it already
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

Then use Yast-software management
filter by repo and select the newly added VBox repo
update all in the list

see if this helps

I had the repo installed, but You were correct about the update.
Thanks You. I have been fighting that thing for 2 days now.

I didnt know that the blue kernels meant there was an update till a few minutes ago.

Thanks Everyone
:)Problem Solved.

Recap the original problem was the update.