Virtual Box (Sun Version) Install HowTo

Are you installing on 11.2, because if so you shouldn’t need any additional or modified fstab statement. :wink:

I very recently did a new install of 11.2 (from KDE livecd) with desktop kernel. For VirtualBox 3.1.4 sourced from its repo, all I needed to add were these packages: gcc, make, kernel-source, linux-kernel-headers, and kernel-desktop-devel (for building kernel modules). Nothing else!

Then I added my userid to vboxusers group. Since this was a new install, no need to run vboxdrv setup. No need to modify fstab or any other config file, and USB worked OOTB in my VM, as it did throughout 11.2 milestone testing prior to release.

This was a key improvement in 11.2. Maybe the problem is in your system or you are using some special usb device. I don’t see why caf4926 has to modify the howto for that. :\

That’s a very old solution from 11.0 (IIRC). It wasn’t needed for 11.1 with virtualbox 2.x.x releases at that time, and didn’t work for many users. There are some very long threads from that time in the forum (I was involved in them) that discovered a better solution covering a range of devices i.e. better than modifying fstab. If you don’t believe, you can search for them. :slight_smile:

Ubuntu hasn’t needed an fstab entry in a long time…I’ve got usb working, but the last time I installed on 11.2KDE I couldnt’ get usb working work until I did that…I’ll comment out the line and try it…

Btw, VB Puel 3.1.6 is out now…

You are posting about info in another post of mine
Virtual Box USB tips - openSUSE Forums

Which I have now edited - as no special adjustment is needed for USB now.

Ok…I’m going to comment out my fstab entry, and see if I can scan…darned if I didn’t think last time it wouldn’t go until I did that entry. I’ll change my blog for that. That IS old fashioned to have to do that :slight_smile:

Just FYI - here is my fstab

cat /etc/fstab
/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part2 swap                 swap       defaults              0 0
/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part5 /                    ext4       acl,user_xattr        1 1
/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part7 /STORE               ext4       defaults              1 2
/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part6 /home                ext4       acl,user_xattr        1 2
/dev/disk/by-id/ata-FUJITSU_MJA2250BH_G2_K95CT9A2D4UF-part1 /windows             ntfs-3g    defaults 0 0
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0

Thanks…in KDE 4.3.5, I’m not seeing a removable devices gui configurator in Control Center or YaST…I need to automount my usb drive each time I boot because I work off a VM there…KDE4.4.1 had this.
Q: Do you know the fstab entry for this? I’m searching now, thought I’d ask while I was here :stuck_out_tongue: :wink:

There are no fstab settings for removable devices.
And I’m not entirely clear what you are saying.
But USB devices that you want to use in a VM should not be mounted in the Host.

For example, when I launch VirtualBox, whose .vdi file resides on a connected .5TB usb harddrive, it will say that the .vdi file is NOT FOUND until I launch dolphin and manually mount the usb drive. In KDE 4.4.1 there existed a ‘removable media’ gui configutator in Control Center I think where I told it to either mount at boot, mount only when it’s plugged in, only automount devices that have been manually mounted in the past, etc.

I just want to automount my usb HD each time I boot the machine like I was doing in KDE 4.4.1 (which by the way is grand improvement over 4.3.5)

You need to use 4.4 to get that feature, as you realize.
Either upgrade to 4.4 or remember to mount the device.

that’s what I was afraid of :wink: Not a big deal, but I remember long long ago before my memory of doing that in fstab…haha…I went back to 4.3.5 as a clean install because I got a kernel panic while working on corp tax return in my VM…it might have been my vid ram set too high in VB settings, but I wasn’t sure and wanted to redo some things anyway.

And openSUSE 11.2 hasn’t needed this fstab line in its default install:

usbfs                /proc/bus/usb        usbfs      noauto                0 0

Its not present in my fstab, since it wasn’t put there by the default 11.2 install. Although some users copy lines over from a previous release, it doesn’t mean they are necessary. IIRC it was present in 11.1 (and not in kubuntu), but could be removed after a simple modification was used to workaround some particular usb device issue with virtualbox.


Says: there is not text on this page. check your URL’s please

This : SDB:Install guest operating system on Virtualbox - openSUSE

that article is great once vbox is working.
my problem so far is I had virutalbox-OSE installed on opensuse 11.3.
I removed it (virtualbox-ose) and added the virutalbox repository, then run *zypper in virtualbox 3.2", seems like installed fine.

after that I run as root: /etc/init.d/vboxdrv setup and I got error located on this virtualbox-install log file:

make KBUILD_VERBOSE=1 -C /lib/modules/2.6.34-12-default/build SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 modules
make -C …/…/…/linux-2.6.34-12 O=/usr/src/linux-2.6.34-12-obj/i386/default/. modules
make -C /usr/src/linux-2.6.34-12-obj/i386/default
KBUILD_EXTMOD="/tmp/vbox.0" -f /usr/src/linux-2.6.34-12/Makefile
/usr/src/linux-2.6.34-12/scripts/ line 25: gcc: command not found
/usr/src/linux-2.6.34-12/scripts/ line 26: gcc: command not found
make[3]: gcc: Command not found
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (
echo " ERROR: Kernel configuration is invalid.";
echo " include/generated/autoconf.h or include/config/auto.conf are missing.";
echo " Run ‘make oldconfig && make prepare’ on kernel src to fix it.";
mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
make -f /usr/src/linux-2.6.34-12/scripts/ obj=/tmp/vbox.0
gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d -nostdinc -isystem -I/usr/src/linux-2.6.34-12/arch/x86/include -Iinclude -I/usr/src/linux-2.6.34-12/include -include include/generated/autoconf.h -I/tmp/vbox.0 -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -fno-delete-null-pointer-checks -O2 -msoft-float -mregparm=3 -freg-struct-return -march=i586 -ffreestanding -pipe -Wno-sign-compare -fomit-frame-pointer -fasynchronous-unwind-tables -g -I/lib/modules/2.6.34-12-default/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_X86 -DVBOX_WITH_64_BITS_GUESTS -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -D"DEBUG_HASH=27" -D"DEBUG_HASH2=27" -c -o /tmp/vbox.0/linux/.tmp_SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
/bin/sh: gcc: command not found
make[4]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 127
make[3]: *** [module/tmp/vbox.0] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make: *** [vboxdrv] Error 2

Do you have all the required packages mentione.
Have you tried running VBox
Have you added yourself to vboxusers???

thanks for your input,
yes I had added myself to group vboxusers.

And After researching for 6 hours I followed a recommendation about deleting any of the following:


I had both installed when I installed “virtualbox-ose” and after removing this applications I run:

surdo strace /etc/init.d/vboxdrv setup

and all went ok, I placed the strace to see in detail what was going on, and finally I could run VirtualBox
just that I could run it as root, and because I had not rebooted the regular user could not run it, but after reboot all went fine.

Thanks for this thread, it really helped me alot as you may guessed I’m kinda newbie still with Linux in general.

It goes without saying that those OSE packages needed removing…
It’s like trying to drive to work in 2 Cars at the same time. No go.
OSE means open source edition.

Sun/Oracle is licensed, which you have to accept, but it has USB support.
I expect we may even see USB support in the OSE at some point.

Good to know you are OK now.

Greta job Carl. I’ve been driven away from VMware Server by the slackness of the VMware corporation re recent Linux kernels, and I must say VirtualBox is superior and superb.


Q1: If I install the RPM VirtualBox-3.2-3.2.6_63112_etc, do I still need these files:

* kernel-source
* linux-kernel-headers
* kernel development Eg: kernel-default-devel
* pam-devel
* gcc
* make

Q2: the linux-kernel-headers RPM isn’t in 10.3, does that matter?
Q3: What GUI for creating and managing the VMs will I use, since I don’t much like /usr/bin/VBoxManager
Q4: do I still need xog-x11-driver-virtualbox-ose

Thanks caf. There is an interaction /etc/permissions.{secure,paranoid} you might want to document. In those, the setuid bit is taken away from VBox binaries. But that prevents non-root users from running VBox. So those files need to be edited. People using the default /etc/permissions.easy will not see this problem.