virtual box, shared folder and boot message..

os: opensuse 11.0 (host: opensuse, guest: windows xp mce 2005)
installed virtualbox from sun’s site. (not the ose)
installed the kernels and others except the virtual box from suse repo.
installed guest additions , every thing including usb works except folder sharing.
it says the networkname couldnot be found, error 67, ??

i found these lines included in suse boot log:

Starting VirtualBox Additions failed
(modprobe vboxadd failed)

Starting VirtualBox host networkingdone

Starting VirtualBox Additions shared folder support failed
(modprobe vboxvfs failed)

Starting VirtualBox kernel moduledone

Failed services in runlevel 5: vboxadd vboxvfs

Check the VM settings - Shared Folders
Make sure you have the correct folder path and Name and it’s Full access

open windows explorer
go to my networking places - entire network - virtual box shared folders
map network drive: use x: \vboxsvr\sharename

see vbox manual

In a Windows guest, starting with VirtualBox 1.5.0, shared folders are
browseable and are therefore visible in Windows Explorer. So, to attach the
host’s shared folder to your Windows guest, open Windows Explorer and look
for it under “My Networking Places” -> “Entire Network” -> “VirtualBox Shared
Folders”. By right-clicking on a shared folder and selecting “Map network drive”
from the menu that pops up, you can assign a drive letter to that shared folder.
Alternatively, on the Windows command line, use the following:
net use x: \vboxsvr\sharename
While vboxsvr is a fixed name (note that vboxsrv would also work), replace
“x:“ with the drive letter that you want to use for the share, and sharename
with the share name specified with VBoxManage.

I dont have “entire network” in windows xp mce 2005 edition. Instead , i have checked all the network there is nothing as virtualbox shared folder.

I think there is some problem with suse also as it says it cannot initialize the vbox share service

And i have tried net use from command line too. not working.

OK. I just went to MY xp mce and opened windows explorer
Accross the top go to tools - select map network drive
Mine uses the drive letter Z
the folder is: \VBOXSVR\Downloads

Downloads being the name of the folder in my Linux host - name your folder accordingly
This is the folder you have also put in the folders section of the vbox settings for the xp vm

Thanks… that works…:smiley:

but still i cannot do it from command line. but it worked from tools > map networkdrive, (last time it was not working, may be case sensitive? i used VBOXSVR this time instead of vboxsvr… !!)

Thanks again

Try seamless windows - (better without comiz though) it’s very neat.
Or go to Machine adjust window size - then maximize the xp machine window (not the same as seamless but quite good too)

Ya. those things are pretty neat. I was using those features. The most important for me were usb and shared folder for now. Only the folder sharing was giving some problems. now its good.

I’m having a very similar problem, but the Explorer trick hasn’t fixed it for me.

At boot, I have observed a similar message, saying that the services vboxadd and vboxvfs failed to start, also because the modprobe failed. Trying the modprobe vboxvfs manually, I get

WARNING: Error inserting vboxadd (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)
FATAL: Error inserting vboxvfs (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)

And modprobe vboxadd gives me

FATAL: Error inserting vboxadd (/lib/modules/ Unknown symbol in module, or unknown parameter (see dmesg)

Here are the unkown symbols that I find in dmesg:

vboxadd: Unknown symbol RTSpinlockReleaseNoInts
vboxadd: Unknown symbol RTHeapSimpleAlloc
vboxadd: Unknown symbol RTSpinlockCreate
vboxadd: Unknown symbol RTHeapSimpleFree
vboxadd: Unknown symbol RTHeapSimpleInit
vboxadd: Unknown symbol RTSpinlockDestroy
vboxadd: Unknown symbol RTSpinlockAcquireNoInts
vboxvfs: Unknown symbol vboxadd_cmc_open
vboxvfs: Unknown symbol RTLogBackdoorPrintf
vboxvfs: Unknown symbol vboxadd_cmc_ctl_guest_filter_mask
vboxvfs: Unknown symbol RTSpinlockReleaseNoInts
vboxvfs: Unknown symbol RTHeapSimpleAlloc
vboxvfs: Unknown symbol RTErrConvertToErrno
vboxvfs: Unknown symbol vboxadd_cmc_call
vboxvfs: Unknown symbol RTSpinlockCreate
vboxvfs: Unknown symbol RTAssertDoBreakpoint
vboxvfs: Unknown symbol RTHeapSimpleFree
vboxvfs: Unknown symbol vboxadd_cmc_close
vboxvfs: Unknown symbol RTHeapSimpleInit
vboxvfs: Unknown symbol AssertMsg2
vboxvfs: Unknown symbol RTSpinlockDestroy
vboxvfs: Unknown symbol AssertMsg1
vboxvfs: Unknown symbol RTSpinlockAcquireNoInts

Any ideas? Virtualization is great, but if I can’t transfer data back and forth, it’s rather useless for me.


Try adding this repo f you don’t have it already
Index of /repositories/Virtualization:/VirtualBox/openSUSE_11.0

and run an update of all

I having same problem, but when i try to modprobe vboxadd and vboxvfs and i got FATAL: Module xxxxxxx not found.


Help page here
VirtualBox Installation - openSUSE