Virtual Box - Getting this error...

http://i42.tinypic.com/2ltpngz.png
http://i43.tinypic.com/2s5z3o4.png

Getting these two messages when trying to open an OS,
What do i do?

Check you have set up correctly
VirtualBox Installation - openSUSE

go thru the above step by step

You didn’t say if you were using the repo or the Sun .rpm
But it doesn’t really matter.

Only if you use the repos you can add the build service VBox

I did everything step-by step (I downloaded the sun.rpm) and i still get that message.

More info please. From which repo’s you installed it? Are you set vbox modules to start in runlevel editor? When you execute this command:


groups

is the vboxusers group listed?

yes, vboxusers is listed, and i don’t know what

Are you set vbox modules to start in runlevel editor?
means, so probably no.

You shouldn’t need to follow any tutorials or do anything exotic with your installation of virtualbox, simply follow what virtualbox itself is telling you what to do, it’s giving you the answer

As root run the command it’s giving you, /etc/init.d/vboxdrv setup

After doing that it should work fine, although you may need to logout and back in first

There can also be an issue if the user isn’t in the vboxusers group, but virtualbox will also pop up a message telling you to rectify that if you need to anyway, if it doesn’t tell you the user needs to be added to the vboxusers group then you shouldn’t need to worry about it

If something’s telling you to do something to fix a problem it’s usually a good idea to read what it’s telling you to do and … just do it

I did, all i got was

Recompiling VirtualBox kernel module                                 failed
  (Look at /var/log/vbox-install.log to find out what went wrong)

And when i look in that file there’s nothing there.

Hmmm … bit hard to troubleshoot if the log’s empty

Something just occured to me though, I had a problem with shared folders on a system I did a fresh install of suse and vbox on the other day

Popped over to vbox’s own forum to see what they had to say, apparently there’s a number of issues with virtualbox 2.1.0/2.1.1 and they were recommending people get version 2.0.6, which solved my shared folders issue

Might be worth checking what version you have and getting 2.0.6 if you’re using one of the later ones

If you need to, here’s where you can get earlier versions from:

Index of /virtualbox/

Also, I’ve had a couple of problems after installing virtualbox rpms before, but never have when installing from the binary, so the binary’s what I always use

Okay, i got the 2.0.6 version like you suggested, but i can’t install it cause I’m asked to install libpython 2.5.so.1.0 first, and i already have libpython, only a different version.

What do i do? where can i get the 2.5 version?

Thanks for your help btw

anybody have any advice?

Hi,

I have recently switched from Ubuntu to OpenSuse to give it a whirl! However I had the same issue in Ubuntu 8.10 with the USB subsystem not being able to be accessed.

Unfortuantely this is a bit vague as I have recently wiped ubuntu off and have now lost the line in my fstab file that corrected it. You maybe be able to do some googling to find it.

Basically I had to put an entry in my /etc/fstab file that mounted the usb filesystem. This corrected the issue and USB worked a treat.

I need to fix my own Virtualbox install, so if I find the solution again I will post it here.

Regards

Paul

OK I think I found the line I added last time, I would test but OpenSuse is giving me untold grief opening anything with sudo…not liking this distro so far!

So in your /etc/fstab you will need to add the following line:

none /proc/bus/usb usbfs devgid=123,devmode=664 0 0

Replacing the devgid with the group id of the vboxusers group…you can get this by just typing id in a terminal and it will list groups and their id’s.

Let me know how you get on.

Paul

Do you mean this?

/sys/bus/usb/drivers /proc/bus/usb usbfs devgid=XXX,devmode=664 0 0

If yes, then you may find this wiki useful:
VirtualBox USB Support - openSUSE

Oops, did not notice the last post and 10 minutes have passed…

Concerning the problem Original Poster asked about:
I had this problem to,
so I had to install OSE-version (from openSUSE repository),
so no USB support for now.

I’ll try installing that 2.0.6* binary version too
and post back if I have any success solving that python issue.

Who da man!!!

Thanks for pulling that line out, I eventually managed to find an article on opensuse:

VirtualBox USB Support - openSUSE

I obviously didn’t look very hard!!

The only other thing I had to do was edit /etc/init.d/boot.local and add the line “mount - a” without quotes.

Hope that helps anyone on this issue.

Thanks again

Paul

Thanks for your help, let me know if it works.

I found this thread
virtualbox.org :: View topic - Virtualbox 2.1.0 on Ubuntu 8.04 Kernel 2.6.24-23-386
and i wanna try the solution out, but the codes are for ubuntu, could someone tell me what they would be on suse??

I am successfully using VirtualBox 2.1.0 on Suse 11.1 KDE to run WinXP and check out other distros like Linspire. It sometimes takes a bit of setting up and most of the posts here help. I found the first thing was to get the
/etc/init.d/vboxdrv setup
to successfully compile. The usual cause of failure is that the kernel sources, gcc and make have not been installed. They are often not installed by default. You also must run the command as root, obviously. BTW I have found that I have to repeat this each time the kernel is updated.
Also your user id must be a member of group vboxusers.
Check and try again. Good luck.

I did all that already John, it was in the “how-to”,

> OK I think I found the line I added last time, I would test but OpenSuse
> is giving me untold grief opening anything with sudo…not liking this
> distro so far!

in openSUSE (using KDE), instead of using sudo, use kdesu