Virtual Box color definition message

Hi – I have an openSUSE 11.3 Gnome guest installed in VBox in an openSUSE 11.3 KDE host machine and it works OK.

I get this message when booting the VM guest: The virtual machine is optimised to work in 32 bit color mode but the virtual display is currently set to 16 bit…

Here’s a screenshot of the rest of the message:

http://forums.opensuse.org/attachment.php?attachmentid=778&d=1282507942

I can’t find a place in my Gnome oS guest to adjust the 16 bit mode up to 32 bit mode. Can you guide me please.

Thanks
swerdna

I think you need to change it in the Vbox controls not the VM os

Thanks gogalthorp. In the VBox GUI I set the video ram to highest as a result of your advice plus advice in the help file.
In the VM openSUSE guest I ran as root in “init 3” level the following command “Xorg -depth 24 -pixmap32”. Seems to me that made a difference to the screen, but I’m very susceptible to seeing what I hope to see.

I also ticked the option to turn off the nag message, so it’s now out of sight and out of mind :wink:

Hello, I am having the same problem and error message. I am running openSUSE 11.2 64bit under win7 64bit in a vm. But the SUSE screen in the vm won’t adjust to the window size of the vm. Is that due to the fact of the 32bit/16bit color setting also? And-how can I change that in the vm… I do not understand what that all means:

In the VM openSUSE guest I ran as root in “init 3” level the following command “Xorg -depth 24 -pixmap32”.

Thanks very much for the help.