'View First Unread' does not work

As the title suggests, the ‘View First Unread’-button does not work properly since a few days. It will lead me to the first comment on the page that contains the first unread comment instead of the actual first unread comment.

Tested with the current Firefox on openSUSE and WinXP.

Yes, I am seeing the same thing.

On the first page of a post, it works.

When the first unread post is on the second or later page, it takes me to the top of that page, rather than to the first unread message.

On Wed, 23 Feb 2011 09:36:02 +0000, gropiuskalle wrote:

> As the title suggests, the ‘View First Unread’-button does not work
> properly since a few days. It will lead me to the first comment on the
> page that contains the first unread comment instead of the actual first
> unread comment.
>
> Tested with the current Firefox on openSUSE and WinXP.

Can you provide me with steps to reproduce the issue? Also, if it makes
a difference, which threading mode are you using (flat, hybrid, or
threaded)?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

I am using the default threading-mode [simple chronological order] (that is “flat”, isn’t it?).

What I do is:

  1. Browse through threads via “What’s new?” → “New posts”

  2. Choose a thread I have already read but contains new posts

  3. Click “View first unread”

What it does:

It takes me do the first post of the page containing the first unread post

What it should do:

Taking me to the first unread post

As nrickert mentions, it does work when the first unread post is on the first page, but not when it is on page 2, 3 etc.

On Thu, 24 Feb 2011 23:36:02 +0000, gropiuskalle wrote:

> I am using the default threading-mode [simple chronological order] (that
> is “flat”, isn’t it?).
>
> What I do is:
>
> 1. Browse through threads via “What’s new?” → “New posts”
>
> 2. Choose a thread I have already read but contains new posts
>
> 3. Click “View first unread”
>
> What it does:
>
> It takes me do the first post of the page containing the first unread
> post
>
> What it should do:
>
> Taking me to the first unread post
>
> As nrickert mentions, it does work when the first unread post is on the
> first page, but not when it is on page 2, 3 etc.

Thanks, that’s good to know - will pass this along.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

This happens to me in Firefox and Chrome, on Windows and ChromeOS.

I believe this happens in Linux too.

Any news on that issue?

Funny, when I tried it with this post, it worked but all of the other threads I tried it on it didn’t.

On Mon, 14 Mar 2011 07:06:01 +0000, gropiuskalle wrote:

> Any news on that issue?

Not as of yet.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

As mentioned, when a thread has only one page yet or the first unread post is on the first page, it does work. The unwanted behaviour occurs with multiple-page threads only.

Awww. Okay. Um. Well, I’m sure you will keep it in your mind.

On Mon, 14 Mar 2011 18:06:01 +0000, gropiuskalle wrote:

> “hendersj” Wrote:
>> Not as of yet.
>
> Awww. Okay. Um. Well, I’m sure you will keep it in your mind.

I shall. We’ve had some internal staffing changes, so I’ll make sure the
new person knows about it.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C