Vidyo and LibXScrnSaver


I am trying to install VidyoDesktopInstaller using .rpm package provided from the manufacturer.

sjlphi@NGyro:~/Desktop> sudo zypper in VidyoDesktopInstaller-sl564-TAG_VD_3_6_3_017.rpm  
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libXScrnSaver needed by VidyoDesktop-3.6.3-017.x86_64
 Solution 1: do not install VidyoDesktop-3.6.3-017.x86_64
 Solution 2: break VidyoDesktop-3.6.3-017.x86_64 by ignoring some of its dependencies

**Choose from above solutions by number or cancel [1/2/c] (c): **

so it’s missing the libXScrnSaver, so I tried to download and install from software.opensuse provided YAST package, but without success. Now when I tried the source code with rpm package, I get:

sjlphi@NGyro:~/Desktop> sudo zypper in libXScrnSaver-1.2.2-11.19.src.rpm  
Loading repository data...
Reading installed packages...
'_tmpRPMcache_:libXScrnSaver=0:1.2.2-11.19' not found in package names. Trying capabilities.
No provider of '_tmpRPMcache_:libXScrnSaver=0:1.2.2-11.19' found.
Resolving package dependencies...

Nothing to do.

I tried looking online for a solution. I haven’t found one, could someone help me please?

it looks like the LibXScrnSaver build has been disabled and only a user has build it
I’d say add the home:syeg repo as there might be other dependencies needed

zypper ar -f

then try to install your rpm

For Leap 42.2 the package is libXss1, this should be installed already, so you can choose option 2 (and maybe advise the developers of the error), you also need to install libGLU1 (another developer packaging error) as well, then you should be good to go.

Noooooo, please don’t do that… :wink:

so what you are saying is that LibXScrnSaver has been depreciated and replaced with libXss1
and that he should ignore the nothing provides LibXScrnSaver warning

Yup… an easy check is to run ldd on the executable to find out…

 ldd /opt/vidyo/VidyoDesktop/VidyoDesktop (0x00007ffc3d68a000) => /usr/lib64/ (0x00007f249b58a000) => /usr/lib64/ (0x00007f249b346000) => /lib64/ (0x00007f249b142000) => /usr/lib64/ (0x00007f249ae4b000) => /usr/lib64/ (0x00007f249ac45000) => /usr/lib64/ (0x00007f249a9db000) => /usr/lib64/ (0x00007f249a75c000) => /usr/lib64/ (0x00007f249a555000) => /usr/lib64/ (0x00007f249a34a000)
    ===>>>> => /usr/lib64/ (0x00007f249a146000) => /usr/lib64/ (0x00007f2499ef4000) => /usr/lib64/ (0x00007f2499cec000) => /usr/lib64/ (0x00007f2499acf000) => /usr/lib64/ (0x00007f24998c4000) => /usr/lib64/ (0x00007f2499686000) => /usr/lib64/ (0x00007f24993e7000) => /usr/lib64/ (0x00007f24991d4000) => /usr/lib64/ (0x00007f2498e96000) => /lib64/ (0x00007f2498c92000) => /usr/lib64/ (0x00007f2498a8f000) => /lib64/ (0x00007f2498887000) => /usr/lib64/ (0x00007f2498577000) => /lib64/ (0x00007f2498359000) => /usr/lib64/ (0x00007f2497fd0000) => /lib64/ (0x00007f2497cd3000) => /lib64/ (0x00007f2497abb000) => /lib64/ (0x00007f2497718000)
    /lib64/ (0x000055ff9a03a000) => /usr/lib64/ (0x00007f2497513000) => /usr/lib64/ (0x00007f24972e8000) => /usr/lib64/ (0x00007f24970e5000) => /usr/lib64/ (0x00007f2496ee2000) => /usr/lib64/ (0x00007f2496cdb000) => /usr/lib64/ (0x00007f2496ad8000) => /usr/lib64/ (0x00007f24968aa000) => /usr/lib64/ (0x00007f24966a6000) => /usr/lib64/ (0x00007f24964a4000) => /usr/lib64/ (0x00007f249628c000) => /usr/lib64/ (0x00007f2496086000) => /usr/lib64/ (0x00007f2495e66000) => /usr/lib64/ (0x00007f2495c60000) => /usr/lib64/ (0x00007f2495a50000) => /usr/lib64/ (0x00007f2495847000) => /lib64/ (0x00007f2495630000) => /usr/lib64/ (0x00007f2495421000) => /usr/lib64/ (0x00007f24951e4000) => /usr/lib64/ (0x00007f2494f74000) => /usr/lib64/ (0x00007f2494d70000)

Everything it’s looking for is found…

I will give it a go Tomorrow in my office.

On another note.
Is there a way to re-establish screen savers for the lock screen, identical to that existed for KDE4 OpenSUSE 13.2?

I really liked BSOD screen saver.


I broke the dependency, and so far everything seems to be good:

sjlphi@NGyro:~/Desktop> ldd /opt/vidyo/VidyoDesktop/VidyoDesktop (0x00007ffdbbbbe000) => /usr/lib64/ (0x00007f4ca6620000) => /usr/lib64/ (0x00007f4ca63dc000) => /lib64/ (0x00007f4ca61d8000) => /usr/lib64/ (0x00007f4ca5ee1000) => /usr/lib64/ (0x00007f4ca5cdb000) => /usr/lib64/ (0x00007f4ca5a71000) => /usr/lib64/ (0x00007f4ca57f2000) => /usr/lib64/ (0x00007f4ca55eb000) => /usr/lib64/ (0x00007f4ca53e0000) => /usr/lib64/ (0x00007f4ca51dc000) => /usr/lib64/ (0x00007f4ca4f8a000) => /usr/lib64/ (0x00007f4ca4d82000) => /usr/lib64/ (0x00007f4ca4b65000) => /usr/lib64/ (0x00007f4ca495a000) => /usr/lib64/ (0x00007f4ca471c000) => /usr/lib64/ (0x00007f4ca447f000) => /usr/lib64/ (0x00007f4ca426c000) => /usr/lib64/ (0x00007f4ca3f2e000) => /lib64/ (0x00007f4ca3d2a000) => /usr/lib64/ (0x00007f4ca3b27000) => /lib64/ (0x00007f4ca391f000) => /usr/lib64/ (0x00007f4ca360f000) => /lib64/ (0x00007f4ca33f1000) => /usr/lib64/ (0x00007f4ca3068000) => /lib64/ (0x00007f4ca2d6b000) => /lib64/ (0x00007f4ca2b53000) => /lib64/ (0x00007f4ca27b0000)
        /lib64/ (0x000055d3864e4000) => /usr/lib64/ (0x00007f4ca25ab000) => /usr/lib64/ (0x00007f4ca2380000) => /usr/lib64/ (0x00007f4ca217d000) => /usr/lib64/ (0x00007f4ca1f7a000) => /usr/lib64/ (0x00007f4ca1d73000) => /usr/lib64/ (0x00007f4ca1b70000) => /usr/lib64/ (0x00007f4ca1942000) => /usr/lib64/ (0x00007f4ca173e000) => /usr/lib64/ (0x00007f4ca153c000) => /usr/lib64/ (0x00007f4ca1324000) => /usr/lib64/ (0x00007f4ca111e000) => /usr/lib64/ (0x00007f4ca0efe000) => /usr/lib64/ (0x00007f4ca0cf8000) => /usr/lib64/ (0x00007f4ca0ae8000) => /usr/lib64/ (0x00007f4ca08df000) => /lib64/ (0x00007f4ca06c8000) => /usr/lib64/ (0x00007f4ca04b9000) => /usr/lib64/ (0x00007f4ca027c000) => /usr/lib64/ (0x00007f4ca000c000) => /usr/lib64/ (0x00007f4c9fe08000)