Videos won't play properly (codecs problem?)

Hi, I’m using OpenSUSE 13.1 and I’m trying to watch videos. I read the official thread on the FAQ about this issue, but the link on the bottom seems to be broken. I searched this forum and I found this thread about this issue, which leads to this site. I used the “One click install” link and it installed a bunch of things, but it didn’t solve the problem. Then I searched Google and I found this site. I clicked the “One click install” link for Gnome, it installed a lot of things and gave some errors, saying there were missing dependencies and asked if I wanted to change vendor (here is a screenshoot). I accepted changing vendor (even though I don’t know what that is), but things are still not working.

Here is what happens when I try to open a video using Totem: (what happens if I click “Search”) (what happens if I click “Install”)

I also tryed using other video players (VLC, SMPlayer, SMPlayer2), but nothing seems to work. Could someone give me a hand, please? I don’t know what else to do.

there is no need to search around so much.
the very first post in the forum sub-section that you posted in is a sticky that explains how to get multimedia working in openSUSE and is much more up to date than the advice you have followed.


On 02/02/2014 08:36 PM, renatov wrote:
> ( I accepted (even though
> I don’t know what that is), but things are still not working.

Why did you accept if you didnt know what it was going to do? It could
have broken your system. In this case though, all it is doing is
switching the repository that the package manager uses for that
particular package to the packman repo (from the standard openSUSE repo)
which is what you want in this case. To get a better understanding of
how this works and how you can control it, see In this case you
shouldn’t have to do anything with vendor changing yourself, I am just
providing the link so you can get a better understanding of the concept.

For vlc just install the vlc-codecs package, that should let you use it
to play your videos.

Also can you post the output of zypper lr ?

On 02/02/2014 11:06 PM, farcusnz wrote:
> see

Didnt he(?) already link to the one click install the guide links to?

Was I helpful? Click that little star so that I can brag about it to my
invisible friends >:)
Bring the Penguins Back!

the first one-click link only points to the KDE install - and it seems the user is probably using gnome. (?)
merely pointing out that this hassle could have been avoided had the first sticky in the multimedia forum been read.

There are some broken links in the forum

The 13.1 guide is here

Please run the gnome code in that guide

Then do this

Ah okay, I didnt even notice that.

Is it not possible to edit the post in the multimedia guide to that link?

But we are working on solutions to restore the old URL’s. So I have my reasons for leaving it as it is
And it won’t help the OP

I forgot to mention I’ve already read this, it was the first thread I read actually. But that thread leads to the, which I already mentioned that I visited and installed the “one click install” Gnome link.

Thanks for providing me the working link, I’ll read it and try to get things working here.

Exactly, I already did.

caf4926, the working link you provided for me solved the problem! I performed the manual installation of multimedia related packages for Gnome and all type of videos are working. Totem still pops up the same error message, though. If I click “Search”, the same error appears, even though in the end the video is correctly played by this player. What could be causing these error messages?

ps: SMPlayer2 and VLC open everything flawlessly, they don’t prompt any errors.

Well, that automatic install just doesn’t work when more than one version of the package is found AFAIK. (1.0 in the standard repo and 1.2 from Packman)

Which error message do you get now? The one about the missing H.264 codec?
Or the other one as well?

Check if you have gstreamer-plugins-libav installed.

Try to switch all packages to the Packman repo versions, like explained here:
Maybe you have some of them still in the standard version.
In the Gtk version of YaST this looks slightly different:

  • Switch the Chooser (that says “Groups”) to “Repositories”.
  • Select the Packman repo.
  • Click on the button “Switch installed packages to the versions in this repository” below the package list.

ps: SMPlayer2 and VLC open everything flawlessly, they don’t prompt any errors.

Yes, they don’t use gstreamer like totem does.

VLC needs vlc-codecs though (as you have been told already), MPlayer(2) should bring all needed in its main package.
The reason for this is that openSUSE may not include those codecs for legal reasons. VLC and gstreamer are included/needed in the standard distribution, so those codecs had to be split out.
MPlayer(2) is not in the distribution anyway, so there was no need to split the package in that case.

Show me the error again

I use KDE
Though with gnome I still use smplayer and vlc.
Totem is used only in the browser plugin (which I also use in kde)

Thanks for the help so far, guys! The package gstreamer-plugins-libav is installed and I’ve already switched all packages to Packman Repo (it upgraded some other packages when I did this). Totem still can’t open the video which previously gave an error about H.264 codec, but this time it prompts no error at all, it just doesn’t open the file and doesn’t complain. All other video files I try to open with Totem I receive this error related to GStreamer: (when I click "Search) (when I click “Install”)

Is it possible to fix it?

I suggest you use smplayer, it’s a better player anyway

I can’t really say about the error. I don’t have a gnome install and I don’t have your video collection.

I’m not aware of any issues with Totem though

This is what I do too. VLC (for web browser and some streams) and some mplayer fork + frontend works great for all my media.

OK guys, I’ll let Totem be then. SMPlayer2 and VLC work great anyway. Thank you very much for your help!

The videoconvert plugin is in the package gstreamer-plugins-base, which you already should have installed.

Maybe try to remove the plugins cache:

rm -r ~/.cache/gstreamer-1.0/

Does it work then?

And again, those “Search” and “Install” buttons just don’t work well, or not at all.
But if you have the correct codecs installed, this dialog should not even appear.

Yes, it worked! I removed the cached gstreamer-1.0 directory as you suggested and now everything is working. Thank you very much lol!