videos and movies on opensuse seem gittery and bad quality

had windows 7 bfore i made the switch over to a comlete opensuse system and the videos and movies online like youtube were running great now that i have open suse its now **** at running videos and movies online its skips alot and has a gittery effect can anyone help me its obviously not my laptop as before it was fine on windows 7 now its not on opensuse please help thank you

Please ensure you have followed the guidance in caf4926’s multimedia guide: Multi-media and Restricted Format Installation Guide

Also, wrt streaming data from the Internet, ensure you disabled ipv6 during your install of openSUSE as with ipv6 enabled internet downloads tend to be far to slow.

i have done that tutorial but still to no avale how can i dissaple ipv6 since i have already isntalled opensuse thank you again

…how can i dissaple ipv6…

Follow the advice in this thread:

Disable IPv6

kungfu58 i have done that tutorial but still to no avale how can i dissaple ipv6 since i have already isntalled opensuse thank you again
if you have Disable IPv6 as suggested by deano_ferrari and still have a problem, I would request you consider downloading mmcheck, as shown in message #40 and post its results here for us to see:

MMCHECK - Check Your Multimedia in 10 Steps - Script File, as proposed by RedDwarf

This script may show that you have missed something. I ask this in light of your statement that the video quality is bad. I must tell you that after following the guide, the video quality is better in Linux than in Windows for me on several computers, some of which can’t play iTunes movies at all in Windows. Linux is by far better when used for such tasks, but does get left our with some special applications only written for Windows (such as playing Blue Ray Movies, for now).

Thank You,

I’d also be interested to know about your graphics device and installed drivers:

As su -

hwinfo --gfxcard

here you go cafe 4962

8: PCI 105.0: 0300 VGA compatible controller (VGA)
[Created at pci.318]
Unique ID: ul7N.uHBM3k22nu1
Parent ID: vSkL.2yY_xudKZ6E
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:05.0
SysFS BusID: 0000:01:05.0
Hardware Class: graphics card
Model: “ATI Mobility Radeon HD Graphics”
Vendor: pci 0x1002 “ATI Technologies Inc”
Device: pci 0x9712 “ATI Mobility Radeon HD Graphics”
SubVendor: pci 0x1025 “Acer Incorporated [ALI]”
SubDevice: pci 0x036e
Driver: “radeon”
Driver Modules: “drm”
Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
I/O Ports: 0x6000-0x6fff (rw)
Memory Range: 0xd2200000-0xd220ffff (rw,non-prefetchable)
Memory Range: 0xd2100000-0xd21fffff (rw,non-prefetchable)
IRQ: 18 (39355 events)
I/O Ports: 0x3c0-0x3df (rw)
Module Alias: “pci:v00001002d00009712sv00001025sd0000036Ebc03sc00i00”
Driver Info #0:
XFree86 v4 Server Module: radeonhd
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #28

ill now try dissabling it now

From that I note vendor-ID:device-ID is 1002:9712. That indicates your PC has an HD-4200 graphic card according to this reference: PCI Devices for 1002:9712

I also note from that you are using the “radeon” graphic driver. The “radeon” graphic driver is an open source graphic card driver for ATI hardware.

There is a higher performance proprietary graphic driver available from ATI known as the Catalyst driver, called the “fglrx” driver. Have you tried installing that ? Do you need guidance on installing that ?


Choppy playback of Youtube and other Flash movie sites can be elevated by doing two things, on the movie itself you can right click and disable hardware acceleration (this gave me slightly better playback) but the thing that really helped me get better playback was to disable desktop effects (Control Centre → Desktop Effects)… nothing else I have tried since installing openSUSE has helped but this did…

Please let me know if this helps…

(Please note I suggest this because OP specifies he has trouble playing back online videos with stutter, and not specifying problems with long buffer times and also not specifying having trouble with videos playing from his HDD etc.)


I think the information needed to assess what can cause bad (jittery/bad quality) playback of a video from YouTube is documented in the various posts on this forum thread, … and in summary, from the above and from what I have seen on my own PCs, there could be various causes:

  • selection of a video resolution from a site such as youtube, that is too high for the available bandwidth between the youtube server and one’s PC [presumeably is not the case for this thread if this works in Win7 for same video]

  • slow internet speed with one’s ISP [presumeably is not the case for this thread if this works in Win7 for same video]

  • internet speed on one’s PC to the web made slower by ipv6 being enabled

  • special desktop effects slowing down graphics

  • non-optimal graphic video driver slowing down graphics

  • non-optimal configuration in one’s plugin for playing videos

For example on my laptop PC, with ipv6 not disabled, Internet video playback was poor. Ensuring ipv6 was disabled helped.

But I also noted that playing some videos with higher bit rates, that they would be jerky with special desktop effects and the radeon driver. Disabling special desktop effects helped. After installing the proprietary fglrx driver, I was able to re-enable special desktop effects and have smooth video playback.

So there are various factors/considertions.