Video playback problem with XBMC


I’m having problems with playing video’s in XBMC.
When I try to play a video as a normal user I get a scrambled screen and XBMC locks up after a few seconds. When I do the same as root user everything works fine.
So I think the problem has something to do with rights. I already made my user a member of the video group but that didn’t make any difference.
Does anyone know the solution to this problem?

I’m running version 12.2-1.5 of XBMC on OpenSuse 12.3.


I found out today that when I run XBMC from console as user I get the message
“NVIDIA: failed to load the NVIDIA kernel module.”
When I run XBMC as root I don’t get this message.

I tried running
sudo /sbin/modprobe nvidia
as suggested here: Chapter
but it didn’t make any difference and google doesn’t give me any other solution.

Please post your /var/log/Xorg.0.log and the output of:

glxinfo | grep render

You may have to install the package “Mesa-demo-x” first.

Thanks for your reply wolfi323

I ran your code as user and got the following result.

direct rendering: YesOpenGL renderer string: GeForce GTX 650 Ti/PCIe/SSE2
    GL_NV_conditional_render, GL_NV_copy_depth_to_color, GL_NV_copy_image, 
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 

So your NVIDIA driver is working correctly.

How do you start XBMC exactly when you get that error message?
Did you logout/login or reboot after adding your user to the “video” group and before trying XBMC again?

Normally I just launch XBMC from the Application Launcher in KDE. To get the NVIDIA error message I open konsole in KDE and just type the command xbmc.

A kernel module can only be loaded with root permissions.
But why is xbmc trying to load the module? I can’t find code that does that anywhere. It would be senseless anyway since the module is loaded at boot, otherwise the nvidia driver doesn’t work and you end up using a different driver. And then loading the module would make even less sense and wouldn’t even be possible if the nouveau driver is already loaded.

What do you see in XBMC->System->System Information?

And could you maybe post the output of:

which xbmc

Not necessarily, i.e. the output states it’s working, yet the user may not have the permission to use the device.
At OP: make your user a member of the “video” group, reboot and try xbmc again.
BTW: how was xbmc installed?

He already did that.
Also if he would not have permissions “glxinfo” would report:

NVIDIA: could not open the device file /dev/nvidia0 (Permission denied).
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

@OP: If you’re using KDE you could try to disable desktop effects by pressing Shift+Alt+F12.
If that helps, please check that “Composite Type” is set to “OpenGL” and “Qt graphics system” is set to “Raster” in KDE’s “Configure Desktop”->“Desktop Effects”->Advanced.

Look here >

Cheers, missed that.

Did some testing: used optirun and primusrun to run XBMC on the NVIDIA in my laptop. An absolute no. Whilst XBMC runs fine on the Intel GPU, and other programs, like Google Earth ( I use that as sort of a reference app, since it’s quite picky about the0 proper functioning of the NVIDIA card) run fine with optirun/primusrun. But XBMC doesn’t even start OK.
Despite the link provide by the OP to the xmbc forums, I think it is a bug in xbmc.

According to that xmbc forums thread, it is already fixed in xbmc git. See and onwards.
So I guess it is just a matter of time until the fix is in the Packman package.
But maybe somebody should report that on the Packman mailinglist?

And it wasn’t the OP who provided the link. Or did I miss something? :wink:

Oké, problem is solved thanks to the link Ivonovak.
I downgraded my NVIDIA drivers to version 310.51.

Thanks everyone for the great help!