video playback on suse 11

this is really bugging me…as i had multimedia sorted fine on 10.3, i freshly installed suse 11 on my laptop… i added packman repo, installed vlc, smplayer, mplayer, and downloaded the 1click install for w32codec-all. which i think is all i did under 10.3, yet i can’t play .avi files under kaffeine (get a black screen, as with mplayer and mplayer) and vlc player just closes instantly. i ran it through a console and got this…

ross@linux-32e6:~> vlc
VLC media player 0.8.6h Janus
[00000317] dc1394 demuxer error: Bad MRL, please check the option line (MRL was: /home/ross/1.avi)
X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 140 (XVideo)
Minor opcode of failed request: 19 ()
Serial number of failed request: 84
Current serial number in output stream: 85

does this mean anything for you guys? what packages do i need next?

thanks in advance.

you don’t need any more packages. If all of your players don’t work, then there’s something wrong and you should submit a bugreport. I think it has something to do with Xorg

if you’re not afraid of compiling, get mplayer from SVN and compile it yourself. See if that solves your problem

svn checkout svn:// mplayer

the odd thing is avidemux plays them ok :confused: but it’s not exactly a good video player is it. who do i send the bug report to? i’ll see if i can do an online update later and see if that fixes anything. failing that, might try and install kde3 and then go back to that; right now it’s far better IMHO.


ah well, didn’t knew you were trying on kde4, here may lie your problem. Why do people force themselves to use beta software which is also broken is beyond my understanding… stick to what works, and in this case it’s kde3

for bugreporting, go to Novell’s bugzilla

Try running it with more verbose options, vlc will take vlc -vvv file/to/play.avi but probably mplayer will be better I’m dubious about vlc.

Think this is correct for
mplayer -msglevel all=9 file/to/play.avi

after installing kde3 off my install dvd…video play back works, thus it must be a fault with kde 4. i will update everything including kde4 core etc and see what happens. now all i need to try and fix is my darn k9copy problem :mad:

i think i will take your advice microchip, and possibly stick with kde3 until kde4.1 comes out, by which time it will be a lot more stable.

thanks for the help, will file bug report when i get time. now all i need to do is customise kde3 to how it was (except i can’t be bothered to install compiz fusion…) and get k9copy working…any ideas? see my other thread,

thanks you 2 for your help, it is really appreciated, and nice to know in a way that it wasn’t my fault that it wasn’t working :slight_smile:


for k9copy, you may want to wait till oldcpu comes. I’ve never used k9copy, so i’m no help here

thanks microchip for your help anyway. if not k9copy…what do you use for ripping dvds from the dvd into the folders (video ts)? come on…you are a multimedia expert no questions about it.

after going back to kde3 and customising it a little…i realise i much prefer it over kde4… at least for now anyway. it’s rock solid.

cheers mate.

Major opcode of failed request: 140 (XVideo)

I think you are using compiz under intel graphics card (or with agilx), so you should change your video output to “X Window System (noXV)”

Try this
Ubuntu Forums - View Single Post - X3100 Video Playback

I unlock the DVD with mplayer. That is, I start to play it and press on pause. Then i go inside the DVD mount point and copy the VIDEO_TS folder to my drive… it’s as simple as that. I don’t need k9copy or some other program for that.
note that this will not decrypt the DVD, it will just copy the VIDEO_TS folder to your drive. The content of the VIDEO_TS folder will still be encrypted

Alternatively if I need to create an ISO out of the DVD, i use h264enc -iso

but if you open it with mplayer, pause it, copy the video_ts folder… would something avidemux be able to copy it to .avi format?

I don’t know how avidemux handles encrypted VIDEO_TS folders. Best thing is to try it yourself and see if it works. I don’t use avidemux since it’s a bad program with a lot of bugs and crashes. I use simple shell scripts which do the job much better than avidemux

unfortunately, it doesn’t work :frowning: the picture comes out with lots of multi-coloured squares, possibly down to the encryption, since my multimedia players play it fine. so…i just need oldcpu to help me with k9copy :frowning:

cheers MC

I had a similar problem under kde 4.0 with both xine and mplayer.
Solved (for time being at least) by changing config
files for both as follows:





Along the lines of what 74141 said… compiz could be the problem.

Check this post for correct settings when using compiz (and intel chipset) : Desktop Effects interfers with Video playback - openSUSE Forums

I have seen this link posted multiple times but it is deceiving to say think that this is a fix. Using X11 over something like XV will dramatically increase the processor load, heat, and power requirements, and if you are running a laptop designed for business then using X11 at full screen is not possible. At best this is a temporary workaround, so stay tuned to updates and be prepared to switch back to the default settings.

That is good to know (the increased load). Although I’m running on a two year old laptop and can play full screen video with any problems. I did notice the laptop getting warmer than usual.

On the other hand the post does mention the issue has to do with the Intel driver that is being used along with compiz.
To avoid heat you could also disable compiz when viewing video, which is easy to do as you don’t have to logout and back in anymore…

I do agree that the settings mentioned are to be seen as workaround.


I don’t use 3D desktop affects. I have read of that fix helping various users, who wanted the 3D experience with videos playing.

IMHO if one is using a laptop designed for business, unless one has a very special marketing application, one should not be using any 3D affects. Hence the point about this possibly being a work around is IMHO a mute point.

You state it’s your opinion… but if I apply that logic to many other things it would not fly.
There have and will always be developments labeled ‘not done’ or considered a ‘waste of time’, in this case looking at a business environment, but yet later prove to be very valuable.

3D Desktop has matured greatly in the last years and in itself does not press heavy on resources. If there is a known solution for an issue that occurs when using it (in this case a driver update) then why state that it should not be applied or it’s not relevant?

In short I think it’s too easy to say ‘it’s a mute point’ :slight_smile:

I don’t disagree there. Nor did I state not to apply the work around. Hence I’m not sure that post is directed at me. By quoting my post you’ve confused me here.

Perhaps I need to restate my point.

Marketing people can probably use fancy 3D desktop displays to impress clients. But the average business user does NOT need fancy 3D desktops. Hence the comment “if you are running a laptop designed for business then using X11 at full screen is not possible” appears to me to be in the most part a mute point (since 3D is not needed). Business users can use X11 at full screen, because they do not need 3D.

As for home users, even though I am not a 3D user (my PCs are not powerful enough, and even if they were, I can’t see the use for 3D desktop) I’ve passed this URL on as a workaround fix to a number of users.