video phoning under skype -- transmission problem

I videophone (from Calcutta, India) with my son’s family at USA through logitech webcam using Skype under Windows XP.
I have now installed Linux Skype and uvcvideo packages through yast.
When I tried the same operation under my openSUSE 10.3 OS, I can see and hear them but they cannot.
Is it because of the conflict of OS, since they use Windows OS?
If not, then what is the solution?

It has nothing to do with the difference in operating systems. I have talked with someone using XP before with no ill effects on either side.

A few questions:

  1. Can you see yourself, outside of Skype? Install luvcview (if it isn’t installed already), and see if you can view yourself.

  2. Can you record your own audio? I remember a recent post that mentioned using something like arecord, but I can’t remember for sure. I installed recordmydesktop to test–it creates screencasts of your machine.

  3. If you can see and hear yourself, go to Skype’s settings and start trying again. They have a test button for the video, and a test call service that will test your audio in and out.

> It has nothing to do with the difference in operating systems. I have
> talked with someone using XP before with no ill effects on either
> side.

i agree…i have full video/audio with Skype from Denmark (using Linux) to the
USA (using XP)…


DenverD (Linux Counter 282315)
A Texan in Denmark

I assumed that audio & video must be working in suse also since it was woring in windows.
I now checked the ‘test call’ in skype and got the message
‘audio playback problem’.
Incidentally, I have installed luvcview.
What is the solution?

The hardware probably is working. You just now need to configure the software.

I mentioned installing luvcview; have you run the program to see if you can view yourself? Are you sure that your logitech cam uses the uvcvideo drivers? I assumed so (mine does), but some do not.

Obviously, your current audio setup needs tweaking in Skype (assuming your audio under other Linux apps is fine). There are audio settings in Skype that you can tweak.

I can’t tell you the solution until you have tried some of these things. You tried #3 in my previous post, but don’t mention if you tried #1 and #2.

I was searching skype forums and realized that this problem is quite widespread.
The problem is more basic than transmitting video. When I tested skype ‘test call’ I could hear their voice but my voice could not be recorded. According to skype I should test my audio settings.
This is what I found in my audio setting.
VOLUME CONTROL.
File —> Device: Intel82801DB-ICH4(Alsa Mixer)
Edit —> Preference: Enabled ALL (Master, Master Mono, Headphone, 3DControl-Center, 3DControl-Depth, 3DControl-Switch, PCM, PCM Output & Mute, PC Speaker, Line-in, Line-in Capture, Microphone Capture, Mic Boost(+20dB), Mic Select, CD, CD Capture, Video, Video Capture, Phone, Phone Capture, Aux, Aux Capture, Capture, Mono Output Select, Mix, Mix Mono, External Amplifier)

Playback: Everything has been enabled.
Recording: Speaker and Microphone under Capture have been enabled.
Switches: Microphone Capture and Mic Boost(+20dB) have been enabled.
Option: PCM Output & Mute (Pre-3D), Mic Select (Mic1), Mono Output Select (Mix)

I have built-in Speaker in my Dell Inspiron 1150 laptop, but external webcam (actually it is Microsoft LifeCam) and microphone-cum-headphone (Frontech which I think is an Indian franchisee of Logitech).

Another serious problem has arose after I set the above Volume-Control Setting (which I read about in the Skype forum).
The Headphone is capturing the local radio station broadcast.

The monitor light of the webcam is ON when the camera is plugged in the usb port, even if skype is not started. This does not occur in Windows XP.

As I wrote before, luvcview, uvcvideo-kmp-default and gspc-kmp-default have been installed via yast.

I have now stated all the data that I know of and am waiting for the solution.
Thanks.
P.Rudra.

What kind of microphone you are using to call? Is it a USB type?
I had the same ssue with logitech USB mike but later found that
one can chose the output/input device from skype setting. I have
changed settings there and everything works now (sound is better than in VISTA). I use opensuse 11.0.

I have a Dell Inspiron 1150 laptop where there are 2 holes which the Dell manual describes as audio connectors (not usb port) and the external microphone I am using is Frontech microphone, model
JIL 3401. It works fine on Windows XP platform.

I have installed skype_static-1.4.0.118.tar.bz2 in my /home/userid/
After installation a directory .Skype/ has been created which contains
skypeid/ shared.lck and shared.xml
So you have to tell me what I shall do to my skype setting.

Thanks.
P.Rudra.
P.S. I am just a user of linux having no expertise in system management.

are you using Gnome or KDE? We have Gnome installed, and on that if you go to Computer; bottom left and then More Applications; and then Internet you should see a Skype icon: single or double click on that; (depending on how you have your system setup); that should open the Skype; bottom left of Skype click on icon for settings; is this of any use?

as far as the webcam goes . . .
Have you added the webcam repostiory?
There are logitech specific deivers in the webcam repo.

I am using these files
quickcam-kmp-default
gspcav-kmp-default
gspcav1-kmp-default

I have absolutely no problems with video in any application that I use including skype and kopete.
I do not have uvcvideo installed on my computer.

For the audio
are you able to record any audio from your mike in anything other than skype?
I’d look at confirming your mike is actually working with your system before fiddling with skype.
If using KDE - try recording something with krecord.

My OS is openSUSE 10.3 Gnome installed from live CD with repositories main(oss), main(non-oss), main(debug), packman.iu-bremen.de, packman.unixheads.com, skynet.be and videolan.

Till yesterday I had skype installed from skype-static.tar.gz obtained from google and there was no icon on Computer—>More Applications—>Internet.
Today I have installed skype-2.0.0.72-suse.i586.rpm from skype homepage and an icon has appeared.

Let me first attend to the audio.
I was testing audio on ‘test call’ on skype and the problem as stated above. There is an icon ‘Sound Recorder’ in Computer—>
More Applications—>Multimedia. On testing sound I found a jumbling hum and the words were not resolved.
I have already stated the ‘Volume Control’ settings.

Then about video, though I want to to it after the audio problem has been resolved.
I have uvcvideo-kmp-default, luvcview, gspcav-kmp-default installed via yast. I could not find gspcav1-kmp-default in
package list of ‘install software’.
These are the raw data inputs of the problem.

I am really puzzled.
Thanks.

but does audio input with a microphone work in something other than skype?
you need to narrow this down to - audio input problem - or skype problem.

Don’t use gnome so can’t address that specifically. But for the logitech drivers you need to manually add the webcam repository.
Go to yast > software repositories > add > community repoitories > Opensuse Buildservice - Drivers for webcams

You will then be able to install the logitech drivers.
You need to remove the uvcvideo driver and add all the files I mentioned previously.

I now realize that it is more audio recording problem.
As I wrote in my last mail, I tested audio recording in
Computer—>More Applications—>Multimedia—>Sound Recorder
with the result stated.
Is there any other method of checking the audio?

‘Install Software’ has quickcam-kmp-default but mentioned a kernel-conflict with gspcav-kmp-default and uvcvideo-kmp-default.
Shall I proceed with the installation?

you need to remove the uvcvideo file

the files you install will depend on the kernel you have installed.

I have kernel . . . default installed so I install the quickcam and gspcav and gspcav1 default files.

If you have the pae kernel installed (which I think is the one installed by default rather than the default kernel)then you would install
quickcam-kmp-pae
gapcav-kmp-pae
gspcav1-kmp-pae

There should be no conflicts between the quickcam driver you select and the corresponding gspcav and gspacv1 files. That’s why they are named as such.

But yes - I would imagine that the uvcvideo file will cause a conflict as it is trying to do the same thign as the quickcam driver - so get rid of it.

Actually, we don’t really have any way of knowing what driver he needs. I have a logitech webcam, and can assure you that it only works with the uvcvideo driver. If you take a look at the quickcam driver webpage, you will see that it supports only a subset of logitech cams.

Sorry I have been away–school started. For your video, you need to find out exactly which camera you have, and which driver supports it. Open a shell (command prompt), and type

lsusb

. Make sure the webcam is connected when you do this. It should spit out a list of all your usb ports, along with devices connected to them. Somewhere, your camera should be listed. If it is not, then try farcusnz suggested, and remove uvcvideo and install the other drivers. The info you are looking for is the device and vendor ID, which are a couple of 4 digit hex strings. Mine looks like this:

Bus 002 Device 006: ID 046d:09a1 Logitech, Inc.

. The “046d:09a1” is what you are looking for.

As to your audio: My setup is exactly the same, only different hardware. You really should need no drivers or anything for a mic like that. I don’t run Gnome, so I would advise you to open a shell, and type

alsamixer

and type enter. From here, you should be able to see all of your audio settings, and can tweak them by using the arrow keys to move and adjust levels.

As mentioned, after all is working, you might need to tweak some Skype settings.

Here are the results.

uname -a:
Kernel 2.6.22.5-31-default

lsusb:
Bus 001 Device 002 ID 045e:00f5 Microsoft Corp
(My webcam is 'Microsoft LifrCam 1.3)

alsamixer:
Mic:12.00 Mic Boost:+20dB
However Master:0.00,0.00
Though Volume Control shows Master:100%

Here are the details of Volume Control Results:
VOLUME CONTROL.
File —> Device: Intel82801DB-ICH4(Alsa Mixer)
Edit —> Preference: Enabled ALL (Master, Master Mono, Headphone, 3DControl-Center, 3DControl-Depth, 3DControl-Switch, PCM, PCM Output & Mute, PC Speaker, Line-in, Line-in Capture, Microphone Capture, Mic Boost(+20dB), Mic Select, CD, CD Capture, Video, Video Capture, Phone, Phone Capture, Aux, Aux Capture, Capture, Mono Output Select, Mix, Mix Mono, External Amplifier)

Playback: Everything has been enabled.
Recording: Speaker and Microphone under Capture have been enabled.
Switches: Microphone Capture and Mic Boost(+20dB) and External Amplifier have been enabled.
Option: PCM Output & Mute (Pre-3D), Mic Select (Mic1), Mono Output Select (Mix)

And at this setting the computer speaker is producing the local radio programmes.

When the External Amplifier has been disabled under ‘Switches’
this broadcasting stops.

What next?
P.Rudra.