Video not working

Hello all.
How can I play video?
I have installed:mplayer,smplayer,vlc,banshee, gnomeplayer but nothing works.I hear the sound but no video.

 rpm -qa 'vlc*' 'libxine*' 'libffmpeg*' 'libav^a]*' '*gstreamer*' | sort


Do i need to install something else?

If you look at the version numbering, you will see “pm” in some of the version numbers. That stands for “Packman”. The video apps that you have installed that do not have “pm” are likely from Videolan, or from Novell/SuSE-GmbH.

With the exception of libdvdcss2, I never use rpms from Videolan, but rather use Packman packaged multimedia apps. And I’ve never had the problem you report.

My recommendation is to replace you videolan packaged apps with Packman packaged apps.

Another possibility is that you have special desktop effects enabled (ie 3D / ‘the cube’ ) where it is known that can cause problems with video. The typical work around in that case is to select ‘x11’ (and not ‘auto’ nor ‘xv’ (xvideo) as the video output module in one’s video player).

And finally, users with Intel graphic hardware are known to run into this problem.

Good luck.

I agree with oldcpu. It could be a video driver related problem. Post the kind of your video card. I had this problem with an intel 945 with compiz enabled. But fine tuning xorg.conf fixed the issue even with the effects on. So let us know something about your hardware.

Hello and thanks for your answers.
I have a graphic card ATI Radeon Xpress 1100 (on a ASUS laptop).
Please if you can tell me in detail what I have to do to tuning xorg.conf.
I have compiz runing.

And something else: the sounf is very low, althout the volume is maximum.
In WinXp i used Fn+F12 tastes.

Typically you can adjust your sound volume via:

  1. yast > hardware > sound > other
  2. move your mixer levels up (both master volume and PCM).

I still recommend you change your videolan packaged apps for packman packaged.

Also, take note of my comment above re: special desktop affects (if you are using them).

Thanks very very much!
I have disabled the Compiz :frowning: but i am glad that video is working.
Also the sound is good.
Thank you!