video in Firefox 3.6.10 has stopped working?


Over the last couple of weeks, Firefox has asked to be upgraded a few times. Shockwave Flash has also asked to be upgraded. Sometime last week after upgrading Shockwave Flash all video stopped. So I have no YouTube, video in webpages just shows a grey box, with a light grey arrow.

I have been very busy so I have taken time here and there to check the internet for solutions. There appear to have been problems with Macs’ and a lot of the problems appear to be from August 2009 onwards, so I am not sure it is the same problem.

I am running OpenSuse 11.1
Mozilla Firefox 3.6.10

Shockwave Flash 10.1 r82 is enabled

uname -a

gives me:

Linux linux-5oez #1 SMP 2010-07-29 20:06:52 +0200 i686 athlon i386 GNU/Linux

I was only asked to upgrade to Firefox 3.6.10 this evening. I have restarted the program. I am hoping that when I boot up my machine tomorrow it will all be fine, but I have had several days of doing this to no avail.

As it does not appear to be a problem for anyone else, can anyone see what I am doing wrong.


I have the same problem. If I roll Firefox back to ver 3.5.11-0.1.1 everything works fine, until I reboot. On reboot Firefox automatically updates to 3.6.10. I cannot find anyway to turn off the automatic update. I have updated all my software, no luck fixing Firefox 3.6.10. Can someone help us?

Working fine here.

Please post your repo list from:

zypper lr -d

I don’t know how to go back to an older version of Firefox? I have checked, but you can’t stop the Firefox update. I think you can do it if you are running it on Windows.

That gives this:

#  | Alias           | Name                                  | Enabled | Refresh
 | Priority | Type   | URI
               | Service
1  | 11.1 - VideoLan | 11.1 - VideoLan                       | Yes     | Yes
 |   99     | rpm-md |
2  | KDE3            | KDE3                                  | Yes     | Yes
 |   99     | rpm-md |
nSUSE_11.0     |
3  | openSUSE 11.1-0 | openSUSE 11.1-0                       | Yes     | No
 |   99     | yast2  | cd:///?devices=/dev/sr0,/dev/sr1
4  | repo            | Main Repository (DEBUG)               | Yes     | Yes
 |   99     | yast2  |
/oss/          |
5  | repo-debug      | openSUSE-11.1-Debug                   | No      | Yes
 |  100     | NONE   |
/oss/          |
6  | repo-non-oss    | openSUSE-11.1-Non-Oss                 | Yes     | Yes
 |  100     | yast2  |                              ss/            |
7  | repo-oss        | openSUSE-11.1-Oss                     | Yes     | Yes                                   |  100     | yast2  |                                              |
8  | repo-source     | openSUSE-11.1-Source                  | No      | Yes                                   |  100     | NONE   |                              o/oss/         |
9  | repo-update     | openSUSE-11.1-Update                  | Yes     | Yes                                   |   20     | rpm-md |                                                             |
10 | repo_1          | openSUSE BuildService - KDE:Backports | No      | Yes                                   |   99     | rpm-md |                              openSUSE_11.1/ |
11 | repo_2          | openSUSE BuildService - KDE:Community | No      | Yes                                   |   99     | rpm-md |                              openSUSE_11.1/ |
12 | repo_3          | Main Repository (Sources)             | Yes     | Yes                                   |   99     | yast2  |                              o/oss/         |
13 | repo_4          | Packman Repository                    | Yes     | Yes                                   |   99     | rpm-md |

At first sight: you have a KDE3 repo for 11.0 enabled…

Start FF from a terminal window by entering ‘firefox’ at the prompt. Copy and paste output that gives here.

I think I did it wrong? I typed ‘firefox’ at the prompt without the apostrophes and it opened another firefox. I then tried it with the apostrophes and it still opened another copy of firefox. I didn’t even get a message that said Firefox is already running.


I just ran the same update on 11.1 (64bit) and I do not confirm such an issue.
I should add that this machine has an ATI graphic card but I don’t use the fglrx driver on it.

Do people having that problem use an older version of Catalyst? Just asking.

There is no Mozilla repo there so how were you installing it?

Ah!! Was this for me, Nappy501?

Indeed it was…

Were you using the mozilla repo?
Index of /repositories/mozilla/openSUSE_11.1

Mmm! How was I installing it. I wasn’t trying to do anything. However, I turn on the machine. The first thing I open is Firefox and Thunderbird. Sometimes Firefox says, do I want to update add-ons and sometimes it tells me it has upgraded itself. I have no idea how it does it.

Also when I first installed Suse 11.1 I really didn’t like KDE4, so I was shown how to install KDE3, so it looked like I am used to. I like 4 desktops with different photos.

I was also thinking when this happened that maybe I should upgrade to Suse 11.3, (which hopefully would cure the problem) but maybe I should try it as a live disk first, so I can see what it looks like. I am hoping if I upgrade the problem will go away.


Updates to the FFox addons is nothing to do with updating the application itself.

I think there is an element of confusion going on here.

I don’t think I was clear or maybe I am confused? In the last couple of days Firefox has changed from 3.6.8 to 3.6.10. If I remember correctly I just opened the application and it told me it was now 3.6.10. That is not an add-on is it?


Try shifting to mozilla repo. In a su terminal do:

zypper ar -f mozilla


zypper ref

accept key


zypper dup -r mozilla

(I think all zypper commands work back in 11.1)

Hi, The first bit gave me this:

zypper ar -f mozilla
Adding repository 'mozilla' [done]
Repository 'mozilla' successfully added
Enabled: Yes
Autorefresh: Yes

then got this:

zypper ref
Repository '11.1 - VideoLan' is up to date.
File '/repodata/repomd.xml' not found on medium ''

Abort, retry, ignore? [A/r/i]:

I was brave went for r then i. There is some sort of error:

Abort, retry, ignore? [A/r/i]: r
File '/repodata/repomd.xml' not found on medium ''

Abort, retry, ignore? [A/r/i]: i
Error retrieving metadata for 'KDE3':
File '/repodata/repomd.xml' not found on medium ''

Skipping repository 'KDE3' because of the above error.
New repository or package signing key received:
Key ID: 026B47F3766DA614
Key Name: mozilla OBS Project <>
Key Fingerprint: AAA531905D829BDCBE4D5169026B47F3766DA614
Repository: mozilla

Do you want to reject the key, trust temporarily, or trust always? [R/t/a/?]: t
Retrieving repository 'mozilla' metadata [done]
Building repository 'mozilla' cache [done]
Repository 'Main Repository (DEBUG)' is up to date.
Repository 'openSUSE-11.1-Non-Oss' is up to date.
Repository 'openSUSE-11.1-Oss' is up to date.
Repository 'openSUSE-11.1-Update' is up to date.
Repository 'Main Repository (Sources)' is up to date.
Repository 'Packman Repository' is up to date.
Some of the repositories have not been refreshed because of an error.

Anyway I have done the next bit, there was loads so I haven’t put it here.

zypper rr 2

It’s for 11.0 and no longer supported

Ah mm! Sorry you have lost me again. Is this one of the commands you gave me before? Or do you want me to do it now?

Anyway I have rebooted my machine and Thunderbird looks different and asked lots of questions. Mozilla Firefox is still not showing video.

zypper rr 2

Is to remove that old repo, it’s not even for 11.1

What video are you trying to play in FFox

Did you do: zypper dup -r mozilla


zypper rr 2

Is to remove that old repo, it’s not even for 11.1

Right I’ve done that and got:

zypper rr 2
Removing repository 'KDE3' [done]
Repository 'KDE3' has been removed.

What video are you trying to play in FFox

I use noteflight:
Noteflight - Online Music Notation Software but I can no longer look at scores. Videos don’t play in Youtube, BBC iplayer, etc.
The videos don’t run in the advertisments anymore. One thing that has changed is instead of a grey box where the video is not running, now there is a photo still.

Did you do: zypper dup -r mozilla

Yes, I did there was a lot of information, it looked like it, installed some things (wish I had posted it now).