Video Error (Please Help) Desperate

I have been getting two error messages and probably will get more please help

Gnash Error <2>

MediaHandlerGst::createAudioDecoder: Couldn’t find a plugin
for audio type audio/mpeg! –
MediaHandler::createFlashAudioDecoder: no available FLASH
decoders for codec 10 (Advanced Audio Coding)

also

Gnash Error

VideoDecoderGst: initialisation failed

:o:|:’(

Please do the following

su -
zypper rm gnash

then reboot

test again. If it’s not working:

su -
zypper in flash-player

Thanks, it worked perfectly

Great
Thanks for letting us know