Video downloadhelper firefox extension not working on opensuse 11.3 kde 64 bit


I just downloaded and installed Opensuse 11.3 64 bit KDE on my laptop.

All my hardware seems to be working fine.

I installed the drivers for my Nvidia video card, and 3d is working along with KDE’s desktop effects.

I installed all my favourite Firefox extensions including Video downloadhelper DownloadHelper - Media download Firefox extension
an extension that can download videos from Youtube and other video sites.

All of my installed Firefox extensions seem to be working except Video downloadhelper.

When I try to download videos with it nothing happens.

Previously I had Opensuse 11.2 GNOME 64 bit installed on my laptop, and the
Video downloadhelper extension worked fine.

I think this problem might have something to do with the way Opensuse integrates Firefox with KDE.

Please help me to get Video downloadhelper working.

DownloadHelper is working fine for me on 11.3 64-bit. I’m running KDE 4.5, but it was working under 4.4.4 as well.

I do, however, find that is is a fussy extension. and is dependent on what is going on in other tabs. For example, if I have Facebook open in one tab, and youtube in another, I will not be able to capture youtube video until I close Firefox and restart it. :frowning: This was also true under 11.2.

Anyway, I’m not sure that I can help you. Just assuring you that it can be made to work. :slight_smile:

You might want to give UnPlug a try. Works fine for me, especially in conjunction with DownThemAll.

I can confirm it working too, in both 32 and 64 bit
Also in 11.4

Not all sites work mind you. Can you link us to an example (keep it clean :wink:


I changed some of Video downloadhelper’s settings and now it can download videos.

I think my problem is solved but I’ll tell you if it isn’t.