Video does not work...

When I play a video with real player (which I just removed) real player just exits without doing anything. Same with VLC, which is odd. Kaffeine will play the audio but not the video. I have installed all the codecs that I could find. Please help. I have tested .mp4, .wmv, and .ogg. I am not sure if .ogg even plays audio. Please help.

we need more information than what you have provided to help you. What are your system settings? have you downloaded the restricted media codecs? Are you using desktop effects, etc… If you are using desktop effects, than that is likely the culprit of your problem. simply disable it, and things should start working again

You were right. Disabling desktop effects worked. That is pretty lame. Ubuntu could play videos without disabling compiz.

Is it possible to make playing videos with compiz enabled?

I am not sure… I would love it if it were the case


Does anyone know how to make video work with compiz enabled?

Videos with compiz enabled work. They have been working for me with a nvidia card for a long long time, both with XGL and without it. And videos are “transformed” correctly when you rotate the cube or whatever.

Probably is all a drivers thing. So… which video card do you have? are you using XGL? etc.

I have integrated intel graphics. The driver that comes by default. But with the exact same hard ware everything worked perfect in ubuntu.

Why not compare your ubuntu xorg.conf file with your openSUSE xorg.conf file? Maybe that will give you some hints as to what ubuntu are doing differently.

Can’t :), I already deleted Ubuntu. :stuck_out_tongue: