Video codec problem

Hello,
I have problems with video codecs(mpeg4) in suse 11.0. I tried installing the codecs from Restricted Formats/11.0 - openSUSE-Community but both in KDE and Gnome it’s no use. I only hear the sound and have a black screen, no video. It’s the same thing in every player I tried (kaffeine, totem, mplayer).
Please help me!!!
btw i’m new to linux so please try to keep it as simple as possible:P

Given that you are new to openSUSE Linux, it might be worth your while brushing up on some basic openSUSE Linux concepts: openSUSE - concepts

Reference multimedia not playing (with the symptoms you describe), IMHO there could be various reasons:
a. it could be despite your best efforts to the contrary, you did not install the correct codecs, or
b. it could be you previous had setup Packman and videlan as repositories in your software package manager, and by following the one click install in the “restricted formats” URL you ended up with a mix of videlan and packman rpms, which may conflict with each other, or
c. it could be you have special desktop effects (ie “the cube” or “3D” ) setup, where video on openSUSE does not work well with those effects enabled, or
d. it could be that you have Intel Graphic hardware, where the driver for that hardware is known to have problems with some multimedia playback.

To know which of these applies to you, with your PC connected to the internet, can you copy and paste into a gnome-terminal or a konsole:zypper lr > zypper.txt && curl -F file=@zypper.txt nopaste.com/a
and post here the URL that will provide to you? That will tell us what repositories you have setup, to help determine if you may have a mix of videolan and packman repos and maybe we can recommend something after viewing that.

Could you also copy and paste into a gnome-terminal or a konsole:
rpm -qa | grep layer
rpm -q kaffeine
rpm -q libffmpeg0
rpm -q totem
rpm -qa | grep codec
rpm -qa | grep xvidand post the output here? That will also help us determine from where you obtained your various multimedia applications and maybe we can recommend something after reviewing that.

Could you also copy and paste into a gnome-terminal or a konsole:
su -c ‘sax2 -p’ and enter root pasword when prompted for a password. That will tell us what graphics hardware your PC has identified. (ie is it Intel ? ).

And finally, if you have special desktop effects enabled, you could go to the output video module of each of your players, and change the output video module from “auto” (or from “xv” (xvideo)) to “x11”. Alternatively you could disable special desktop effects.

Good luck.

Cheers,
thanks for such a quick reply.
Here are the results:

e?1034h# | Alias | Name | Enabled | Refresh
—±-------------------------------------±-------------------------------------±--------±-------
1 | repo-debug | openSUSE-11.0-Debug | No | No
2 | flash-plugin-10.0.12.36-release.i386 | flash-plugin-10.0.12.36-release.i386 | Yes | Yes
3 | MPlayer-1.0rc2_r27637-2.pm.1.i586 | MPlayer-1.0rc2_r27637-2.pm.1.i586 | Yes | Yes
4 | Main Repository (OSS) | Main Repository (OSS) | Yes | Yes
5 | Packman Repository | Packman Repository | Yes | Yes
6 | VideoLan Repository | VideoLan Repository | Yes | Yes
7 | repo-oss | openSUSE-11.0-Oss | Yes | No
8 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
9 | openSUSE-DVD 11.0 | openSUSE-DVD 11.0 | Yes | No
10 | repo-non-oss | openSUSE-11.0-Non-Oss | Yes | No
11 | Main Repository (NON-OSS) | Main Repository (NON-OSS) | Yes | Yes

rpm -qa | grep layer

RealPlayer-10.0.9-51.1
flash-player-9.0.124.0-10.1
MPlayer-1.0rc2_r27637-2.pm.1

rpm -q kaffeine

package kaffeine is not installed

rpm -q libffmpeg0

package libffmpeg0 is not installed

rpm -q totem

totem-2.22.0-41.1

rpm -qa | grep codec

libavcodec52-0.4.9.15661-1.1
opensuse-codecs-installer-10.3.1-45.1
libxine1-codecs-1.1.15-44.pm.0
w32codec-all-20071007-0.pm.1

rpm -qa | grep xvid

libxvidcore4-1.1.3-0.pm.2
xvidcore-1.1.3-0.pm.2

su -c ‘sax2 -p’

Chip: 0 is -> Intel 915 GM 00:02:0 0x8086 0x2592 PCI intel

Btw on suse 10.3 I had no video problems, I installed the codecs from suse community and everything worked perectly.

OK, there are some strange things in your repos list. …

  • I do not believe there should be repos called flash-plugin-10.0.12.36-release.i386 nor MPlayer-1.0rc2_r27637-2.pm.1.i586 (ie repos #2 and #3). Go to YaST > Software and remove those two repositories. You want the flash-player and mplayer applications installed as applications, NOT inappropriately listed as a repository.
  • I also note you have two OSS, i.e. repos #4 and repos #7 duplicate each other. You only need one. So delete one OSS and keep the other.
  • I note Repos #10 and #11 (non-oss) duplicate each other. You only need one non-oss, so delete one, and keep the other.
  • I note you have both videolan (#6) and packman (#5) listed as repos. That is bad practise for newbies (IMHO) as they do not understand the risks. There are cases where videolan will provide applications that store codecs in a location where media players from packman can not find the codecs. I recommend you remove the videlan repos and keep the packman repos.
  • I note you have SUSE-DVD listed as a repos. If your internet coverage is fast and reliable, I recommend you disable (don’t remove) that, so that your applications are downloaded from the internet, as opposed to asking you to insert your DVD all the time

Ok, this looks ok. I recommend you also install from Packman the applications “smplayer” and “mplayerplug-in”.

Did you not type that you tried kaffeine? Unless I spelled the rpm wrong, you do not have it installed. Please install the version of kaffeine from packman.

By installing libffmpeg0, one gets a bunch of codecs installed as dependencies. Hence it is highly recommended (by me) that users install the PACKMAN packaged version of libffmpeg0 (not the videolan packaged version). Please install libffmpeg0.

I don’t use totem myself, so I can not comment reliably on the version information. Maybe someone else can chime in. I do note on webpin that there are newer versions: Webpin search for totem

Are you using a 32-bit openSUSE? If using a 64-bit, I do not know how well w32codec-all will work for you. But it is a useful codec package to have installed.

This is good.

This could be a problem. No matter how well you fix your repos and codecs, it is possible you will have a driver problem. Did you try changing your video output module in your multimedia players from “auto” (or “xv” (xvideo)) to “x11” ? Note by installing “smplayer” you get much more user friendly control over MPlayer configuration.

Perhaps another Intel 915 GM user could chime in here if they had to “tweak” their /etc/X11/xorg.conf file ?

Note openSUSE-10.3 had a fix in the “release notes” for how to deal with the Intel problem. openSUSE-11.0 does not.

Finally I’m back from the trip and can try out the things you recommended. Packages are installing now, and we’ll see then. And considering kaffeine, I reinstalled suse so I didn’t have kaffeine installed :shame:

Even with installing all the packages and setting up the repos I got the same result, but then when I changed the output module to x11 everything became fine. Thanks for all the help!!!:wink:
Cheers

Thanks oldcpu so much, your advice also help me a lot;

Hello – I am a fairly new Gnu/Linux user and was experiencing a similar set of issues as the original poster - sound, but no video. I followed the instructions exactly regarding repo setup and packages to install. I now have mPlayer, kaffeine and SMPlayer installed. I have also cleaned up my repos and removed vidoelan.

This is an excellent and very thoughtful reply. I vote “sticky”.

Thank you oldcpu! You are a perfect example of what makes this community great. -devedge

just say thanks u.

actually my problem is gnome-mplayer can play xvid, rvmb but totem canot play. now i can play whatever video using totem.

smplayer is nice. OpenSUSE nice too.

[6 month using ubuntu karmic/ibex/jaunty, 1 week trying opensuse 11.1 gnome reload. windows from 3.11]

Did you consider using the awesome VLC media player with all necessary codecs built in? :wink:

s/awesome/buggies piece of cr@p around/

rotfl!

Yeah i know VLC is good (or bad) but the problem is totem not using VLC codec.

Why do you even use Totem?

I’ve been down the same route as you. Install the VLC player don’t waste any more of your life. Sorry if it seems a bit negative I’ve been looking into this myself for too long and we are not the only ones with this trouble. It is not just totem either:X. Having said that I haven’t had a problem with VLC.