VIA 24PT no surround

Hi, I got the mainboard with via envy24pt and suse 11.2 that detected as chaintech av-710, I update alsa driver and firmware via Index of /repositories/multimedia:/libs/openSUSE_11.2 but I got no surround, In fact in the pulse audio volume control theres nothing but stereo output.

It should not be necessary in most cases to update to that repository. I am a bit worried that update may have made things worse.

Please provide the information recommended to be provided in the second half of our multimedia stickie: Welcome to multimedia sub-area - openSUSE Forums

… and I quote this for you:

… please post … providing in your post the following information:

  • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
    SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script /usr/sbin/ and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL. Just the URL. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘alsa#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -qa ‘pulse#and post output here
  • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
  • in a terminal, or xterm, or konsole, type: uname -a #and post output here
  • for openSUSE-11.2 or later, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

Please also note this thread where I played around with surround sound: Exploring surround sound in Linux - openSUSE Forums

Thanks for post

hamed@linux-g6xp:~> rpm -qa ‘alsa
hamed@linux-g6xp:~> rpm -qa ‘pulse
hamed@linux-g6xp:~> rpm -q libasound2
hamed@linux-g6xp:~> uname -a
Linux linux-g6xp #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 i686 i686 i386 GNU/Linux
hamed@linux-g6xp:~> cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-ice1724

08OF.yDajJf_9bW7:Albatron PX865PE 7.1

alias snd-card-0 snd-ice1724

If you are going to update alsa, you should also update libasound2. You have not done that. That could cause problems. So update libasound2 also!

Also, the updates in alsa have likely been built with different kernel modules in place. I put guidance for updating alsa here: Alsa-update - openSUSE

To install the alsa-driver-kmp-desktop you could send the commands with root permissions and your pc connected to the internet:

         zypper rr multimedia
         zypper ar multimedia
         zypper install alsa-driver-kmp-desktop
         zypper rr multimedia

and a restart afterward is necessary.

Also, you did not include the script output URL as requested. You get the script by running:


IF it notes an update is available, then you need to run it as root in order for the update to write to /usr/sbin.

But normally just run as a regular user.

If after selecting the SHARE/UPLOAD option you still do not get pointed to a URL (ie web site) where output is posted, then run it with the no-upload option:

/usr/sbin/ --no-upload

and post the contents of /tmp/alsa-info.txt to New - Pastie and post here the URL. DO NOT POST SCRIPT CONTENTS HERE!

Hi and thanks for reply, I’ve update alsa via terminal and then restart, the 5.1 channel is selectable now but theres no output, there’s a option in kmix “alternate level to surround output” but it only active rear channels through headphone volume. (I’ve installed pulse audio)

#961477 - Pastie](

I don’t know enough (don’t know anything really) about your hardware to be able to comment on the specifics of your mixer settings that can be seen in that script output. But if you provide the output of the following I can check to see if your update was successful:

rpm -qa '*alsa*'
rpm -q libasound2

If you think it a pulse audio problem, you could open up a Terminal session and enter su - and then the password.

At the terminal prompt enter this command.

setup-pulseaudio --disable

restart and test.

If that does not work, then enable it again with:

setup-pulseaudio --enable

hamed@linux-ytqu:~> rpm -qa ‘alsa
hamed@linux-ytqu:~> rpm -q libasound2

That looks ok

Thanks for reply, I’ve another question I setup a software raid with raid1 for boot and swap and raid0 for root and home, there’s no disk information in my computer (sysinfo:/) can I do something to get this work?

You should start a raid question in a new thread. Our raid experts are unlikely to look at a threat entitled “VIA 24PT no sound”.

I got the new problem, I was disable the chip in bios and then remove from YaST->Sound and then re-enable the chip, but when I try to active the driver I got this message

Try moving the file /etc/modprobe.d/50-sound.conf to /home/your-user-name/backup where “your-user-name” is your username. Do NOT leave the file in /etc/modprobe.d even IF you change the name. Don’t leave it there.

Then try again what you tried, and see if it works.

Problem solved thank you