VGA + Bumbleebee

Hello guys,

I wasn’t sure if it’s more hardware or laptop. I decided to put it here. So I have external monitor Lenovo Thinkvision with resolution 1920x1200. Problem is my OS is detecting it only with resolution 1024x768. Each time I have to set it manually:

xrandr --newmode "1920x1200" 154.00  1920 1968 2000 2080  1200 1203 1209 1235 +hsync -vsyn
xrandr --addmode VGA1 "1920x1200"
xrandr --output VGA1 --mode 1920x1200 --right-of eDP1

On my Asus I have 2 graphical cards, I’m using bumbleebee and this it might be problem. I was thinking about editing “cat /etc/X11/xorg.conf”, but I don’t have such file. In “/etc/X11” only have:

qt_plugins_3.3rc  qtrc  xdm  xim  xim.d  xinit  Xmodmap  Xmodmap.remote  xorg.conf.d  xorg.conf.install  xorg.conf.nvidia-example  Xresources

I thought config might be in “/etc/bumblebee/xorg.conf.nvidia” and I edited it adding external VGA but it didn’t work.

For now I’m adding those 3 lines in /etc/init.d/after.local (I tried in “/etc/X11/xinit/xinitrc” and "/etc/X11/xinit/xinitrc.d/ but didn’t work) but I treat it more like workaround. Is there way to fix it?

Additional info:

LSB Version:    n/a
zenek@home:~> lsb_release -a
LSB Version:    n/a
Distributor ID: openSUSE project
Description:    openSUSE 13.1 (Bottle) (x86_64)
Release:        13.1
Codename:       Bottle

Laptop Asus X750J
Monitor Lenovo Thinkvision lt2452p
rpm -qa | grep bumble
rpm -qa | grep bbswitch


I’ve forgot about second thing I want to ask. I want to be able to use VGA in wine, to be more detailed - in PlayOnLinux. I was able to finally move game to VGA monitor but resolution in game was detected only from laptop display. Any advice?

Hi, it’s me again.

I was trying to do it and it somehow started to work at least at some level.

I tried to add few lines in file /etc/bumblebee/xorg.conf.nvidia

Section "Device"                                                                                                                                                                                                                 
    Identifier  "VGA"                                                                                                                                                                                                            
    Driver      "nvidia"                                                                                                                                                                                                         
    VendorName  "Lenovo"                                                                                                                                                                                                         
    BusID "PCI00:02.0"                                                                                                                                                                                                           
    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"

And comment out those 3 xrandr lines in after.local.

When I reboot, all I had was console mode, without X. So I comment out those lines in xorg.conf.nvidia and tried to run (after uncommenting) that after.local script. It gave me result that device is not found. I tried to run startx and … it reseted my KDE setting (like brand-new KDE desktop). I rebooted … and my old KDE desktop came back. Strange thing happened. My VGA display started to have all resolutions settings (not only manually added 1920x1200).

I’ve edited my after.local file, rebooted and again device started to have all resolution modes:

VGA1 connected 1920x1200+1600+0 (normal left inverted right x axis y axis) 518mm x 324mm
   1920x1200      60.0 +   60.0*    60.0* 
   1920x1080      59.9  
   1600x1200      60.0  
   1680x1050      60.0  
   1280x1024      75.0     72.0     60.0  
   1440x900       75.0     59.9  
   1024x768       75.1     70.1     60.0  
   800x600        72.2     75.0     60.3  
   640x480        75.0     72.8     66.0     60.0  
   720x400        70.1  

Before as far as I remember there was only:

  1024x768       75.1     70.1     60.0  
   800x600        72.2     75.0     60.3  
   640x480        75.0     72.8     66.0     60.0  

There is also one bug, when in GUI mode I try to change to resolution 800x600 or lower I can move it to higher one. But back to the point can anybody tell me why it worked out? Or at least give me some tips what should I read as I’m curious, very curious what files could have changed.

My second problem is to run bumblebee on second device, I mean to be able to run app with VGA resolution.
I tried to follow this one:

But when I do:

export DISPLAY=:8 LD_LIBRARY_PATH=/usr/lib/nvidia-current:$LD_LIBRARY_PATH
optirun playonlinux

It freezes and after stopping it I got error:

python: Fatal IO error 11 on X server :8

Any idea? :)