Very strange keyboard problem.

openSuse 11.4 (x86_64), Linux 2.6.37.6-0.5-desktop x86_64, KDE 4.6.00 “release 6”, Dell Optiplex GX 620 (Pentium D 2.8Ghz dual core, 4Gb Ram), and a Lenovo SK-8825 USB keyboard. This is not a hardware problem.

When logged into my normal user account the lowercase “p” has stopped working. Turning on Caps Lock and typing shift+P produces “p” as expected. However switching to the root account and it works properly! I tried another manufacturers keyboard and got the same result.

Is there a config file that could be corrupt? Do I need to look in the .kde & .kde4 folders or could this be in X.Org somewhere?

Stopping and starting X doesn’t do anything, neither does rebooting, and even shutting down, leaving it for a few minutes and starting up again.

openSuse 11.4 (x86_64), Linux 2.6.37.6-0.5-desktop x86_64, KDE 4.6.00 “release 6”, Dell Optiplex GX 620 (Pentium D 2.8Ghz dual core, 4Gb Ram), and a Lenovo SK-8825 USB keyboard. This is not a hardware problem.

When logged into my normal user account the lowercase “p” has stopped working. Turning on Caps Lock and typing shift+P produces “p” as expected. However switching to the root account and it works properly! I tried another manufacturers keyboard and got the same result.

Is there a config file that could be corrupt? Do I need to look in the .kde & .kde4 folders or could this be in X.Org somewhere?

Stopping and starting X doesn’t do anything, neither does rebooting, and even shutting down, leaving it for a few minutes and starting up again.

Hello Sid. Sounds like a very strange problem. Has this PC ever work properly with your keyboard? How long has openSUSE 11.4 been installed? Was openSUSE a Clean install or an upgrade of an existing but older openSUSE installation? Has any version of Linux worked properly on this computer. Is this a dual boot and if so, does the other OS work OK with the keyboard? Have you tried creating a new user and logging in as the new user to see if the problem is still there? Some questions may seem redundant in light of what you have already said, but lets go done the list anyway.

Thank You,

On 07/18/2011 03:06 AM, sid1950 wrote:
>
> However switching to the root account and it works properly!

you should not log into KDE as root ever…it is one of the more unsafe
things you can do in Linux…

instead of logging into KDE as root, always log in as yourself and then
“become root” in the approved ways, like:

  1. open a root powered application, like YaST or “File Manager -
    Superuser Mode” and see if you can create a new file with a ‘p’ in it…

  2. open a terminal, become root with “su -” and type into the terminal
    do yo see a ‘p’?

  3. press Alt+F2 and type in


kdesu kwrite

and, give your root password when asked…then, when kwrite pops up can
you type a ‘p’?

all three of those safe (and correct) ways to see if root can do what
you can’t…

but the best thing to try is what my friend in Austin has already
pointed out (create a new normal user [with YaST] and see if that user
can type a ‘p’)


DD
Caveat-Hardware-Software

DenverD, he didn’t even say he was doing so. Please stop being so monocausal all the time - it makes you overlook facts that are more relevant. 90% of your posts give the same two advices (1. not logging in as root (which basically is just FUD), 2. make sure the md5 of the install media is correct). OT: It would also be nice to remove the advertisement in your signature…

sid, try to check the ‘p/P’ input via

xev

Thanks for the advice.

jdmcdaniel3: I’ve had this Dell for about 6 months and it has always had 11.4 & KDE4. I have it set to check updates weekly, so it is no more than a couple of days behind the latest STABLE config. The Lenovo keyboard is only about a month newer, and has always worked OK till Sunday 17th. Previously I had an older Dell USB keyboard which I have passed on to a friend. I like the feel of the Lenovo better. This keyboard works fine on 2 other PC’s, one running Suse 11.1 KDE3, and the other Ubuntu 10.04 & Win XP Pro. A no-name cheap USB keyboard has the same problem.

DanielD: I do know about the “not using root”, I have been a Linux user for 12 years! However I will if I need to prove a point while trouble shooting or if I need to fix something. I would normally disconnect my home network from the outside world while doing so.

I hadn’t thought about running KWrite as root, so I’ll do that and report back.

I have tried setting up a second user and testing that and it works perfectly. In fact I am using the second user to type this.

I’m going to try a couple of other things and post the results. This does look like a GUI config, but whether it is in X or KDE I can’t tell. The user login screen is OK, it is only once I have logged in that the problem occurs.

			 					](http://forums.opensuse.org/members/jdmcdaniel3.html)

OK, tried some things.

  1. Opening a terminal as user and typing “p” has no effect.
  2. Running: kdesu kwrite in the user terminal and typing “p” has no effect.
  3. Opening a terminal as Super User and typing “p” has no effect.
  4. Running: kdesu kwrite in the Super User terminal and typing “p” has no effect.

My conclusion is that there is something in a KDE4 config that interprets the keyboard before it gets to X and that the file or whatever in my normal user account has been corrupt. I have some time over the next couple of days to chase this. Is it worth reporting a bug?

Again, have you tried

xev

to troubleshoot that behaviour?

Since I cannot really imagine which keyboard layout would lead to a no
longer working “p” button. The only idea I have is to create a test user and
login to the system as that new user and check if the lower p works. If it
does some configuration in your usual user is wrong.
Can it be that you assigned by accident the key “lower p” as a function key
in your desktop environment so that it now triggers some function instead of
printing a “p”?


PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.5 | GeForce
9600 GT | 4GB Ram
Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.5 | nVidia
ION | 3GB Ram

**gropiuskalle: **Thanks for that tip. I didn’t know about that.

Logged in to my normal account and typing a couple of letters I got this for “o” & “l”:

KeyPress event, serial 34, synthetic NO, window 0x9a00001,
    root 0xb0, subw 0x0, time 13031933, (-191,542), root:(618,593),
    state 0x10, keycode 32 (keysym 0x6f, o), same_screen YES,
    XLookupString gives 1 bytes: (6f) "o"
    XmbLookupString gives 1 bytes: (6f) "o"
    XFilterEvent returns: False

KeyPress event, serial 34, synthetic NO, window 0x9a00001,
    root 0xb0, subw 0x0, time 13035501, (-191,542), root:(618,593),
    state 0x10, keycode 46 (keysym 0x6c, l), same_screen YES,
    XLookupString gives 1 bytes: (6c) "l"
    XmbLookupString gives 1 bytes: (6c) "l"
    XFilterEvent returns: False

Typing lowercase “p” gave this:

FocusIn event, serial 34, synthetic NO, window 0x9a00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 34, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0

Caps Lock On, Shift + P gave:

KeyPress event, serial 34, synthetic NO, window 0x9a00001,
    root 0xb0, subw 0x0, time 13057868, (-191,542), root:(618,593),
    state 0x13, keycode 33 (keysym 0x70, p), same_screen YES,
    XLookupString gives 1 bytes: (70) "p"
    XmbLookupString gives 1 bytes: (70) "p"
    XFilterEvent returns: False

I then switched to the new temporary user account (note I haven’t logged out of the old account, so this is something in the user account configuration) and tried “p” & “P”. The only change now is that lowercase “p” works, but I note that the first line now says “serial 33” instead of “serial 34”.

KeyPress event, serial 33, synthetic NO, window 0x4e00001,
    root 0xb0, subw 0x0, time 13191051, (33,215), root:(1297,238),
    state 0x10, keycode 33 (keysym 0x70, p), same_screen YES,
    XLookupString gives 1 bytes: (70) "p"
    XmbLookupString gives 1 bytes: (70) "p"
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x4e00001,
    root 0xb0, subw 0x0, time 13200443, (-1263,404), root:(1,427),
    state 0x11, keycode 33 (keysym 0x50, P), same_screen YES,
    XLookupString gives 1 bytes: (50) "P"
    XmbLookupString gives 1 bytes: (50) "P"
    XFilterEvent returns: False

Turning Caps Lock On and Shift + P peroduced this:

KeyRelease event, serial 33, synthetic NO, window 0x5600001,
    root 0xb0, subw 0x0, time 14686841, (1098,773), root:(1101,796),
    state 0x12, keycode 66 (keysym 0xffe5, Caps_Lock), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x5600001,
    root 0xb0, subw 0x0, time 14689129, (1098,773), root:(1101,796),
    state 0x12, keycode 50 (keysym 0xffe1, Shift_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 33, synthetic NO, window 0x5600001,
    root 0xb0, subw 0x0, time 14689977, (1098,773), root:(1101,796),
    state 0x13, keycode 33 (keysym 0x70, p), same_screen YES,
    XLookupString gives 1 bytes: (70) "p"
    XmbLookupString gives 1 bytes: (70) "p"
    XFilterEvent returns: False

Its now obvious that this is somewhere in the user config and something has got corrupted. I’m going to take a break and then start comparing the user setting files in ~/home between the two users.

martin_helm: As you can see above this is very misterious, and I have been trying lots of things, but I will try your suggestion. Apart from the usual updates during the last week, the only new application I have is Clementine which I am trying out as a replacement for Amarok. I spent some time testing it on Saturday, and I remember changing some of the short cut key assignments. I’ll look at that later.

On 07/18/2011 04:36 PM, gropiuskalle wrote:
>
> DenverD, he didn’t even say he was doing so. Please stop being so
> monocausal all the time - it makes you overlook facts that are more
> relevant. 90% of your posts give the same two advices (1. not logging in
> as root (which basically is just FUD), 2. make sure the md5 of the
> install media is correct). OT: It would also be nice to remove the advertisement in your signature…

if you don’t like my posting habits or sig: keep it to yourself, or
use the report button.

the moderators have led me to believe that you have been told to steer
clear of lecturing on how to post here… so, please do so.


DD
Caveat-Hardware-Software

gropiuskalle’s suggestion of using xev proved it was something in the user account, and martin_helm’s hint about the short cuts proved the actual fault. I like using the keyboard - 40+ years of using computers, mostly without a mouse! So I had set-up what I thought were sensible hot-keys for Clementine using “p”, PageUp, PageDown, and the Left/Right arrows. Removed the hot-key settings and all was well again. I think this only occurs if you run Clementine in the SysTray. I will check that post in MultiMedia if that is true.

I always liked Amarok, but version 2 has made so many changes, that I really don’t like it any more. Very much like the way KDE4 has gone (buit that’s another issue!) I looked at Clementine and found it does everything that I need - batch transcoding tracks to OggVorbis for my Sansa Clip, playing anything you give it, including Internet Radio - and it has a much more intuitive interface (at least for me it has). So I would recommend it to anyone who doesn’t like the new Amarok.

Thanks for all the suggestions.

I can confirm that - I also have bind PageUp / PageDown (amongst others) to skip tracks in Clementine, so using those keys in a terminal emulator for example within ‘less’ will be interpreted by Clementine before they can be interpreted by the terminal. Not too much of a problem for me, as I usually use the arrow keys to scroll anyway, but one has to be aware of this if using such shortcuts.

Although offtopic, I also recommend to take a look at Clementine - I personally never liked any incarnation of Amarok, but Clementine is really nice.