Very Strange Install Problem

I have recently decided to give openSUSE a try and have had some minor issues with the install process. First i had to put a “brokenmudules=pata_ali” command in the boot install. That took an hour to figure out. Now my problem is that i can’t get an internet connection. The wierd part is that the installation detected my internet connection in the beginning of install and installed a bunch of online repositories. But now that i’ve come to the network configuration stage it won’t detect the internet and the test fails every time. I am using a built-in wireless network adapter which was already detected once by the installation program. If anyone has an idea what may be going on here please let me know. Thanks.

Finish the install then go back and worry about updates later. What wifi adapter is it and what is it’s onboard chipset?

I’m not worried about the updates. I have a bunch of online repositories that it tries to access and can’t. The wireless card linux driver is called AMBIT Microsystem Prism 2.5 Wavelan chipset.
Don’t know the manufacturer and model of the actual card.

That chipset is natively supported. I’d suggest running the following commands as su in a console. Post the results here if you need help;

cat /etc/resolv.conf

I’m very new to this whole linux thing and am not sure where to enter these commands. I am still in the graphical installation program at the network configuration stage. Should I continue without updating or accessing online repositories? I appreciate your assistance.

Yes, that is what I was trying (probably not so well) to say before. Complete the installation without configuring the Network piece. Once you boot into Linux, look for an application called konsole. Open it up, type su then enter, the root password then enter, then the commands I mentioned one at a time. Cut and paste the results here. This is assuming that you have a hard wired connection that will work while you are working on wireless. If not, paste the results into a OO writer file, put it on a flash drive or other removable media, and plug it into a working networked PC.

Here it is. Hope it helps. By the way the OS runs perfectly (minus driver issues) and looks beautiful.

fosk0006@linux-ico4:~> su
linux-ico4:/home/fosk0006 # ifconfig
eth0 Link encap:Ethernet HWaddr 00:02:8A:99:FA:CA
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

eth1 Link encap:Ethernet HWaddr 00:0B:CD:AA:00:90
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:10 Base address:0xc000

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:180 errors:0 dropped:0 overruns:0 frame:0
TX packets:180 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12988 (12.6 Kb) TX bytes:12988 (12.6 Kb)

linux-ico4:/home/fosk0006 # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
loopback * U 0 0 0 lo
linux-ico4:/home/fosk0006 # cat /etc/resolv.conf



domain site
linux-ico4:/home/fosk0006 # lsmod
Module Size Used by
microcode 15372 0
radeon 116228 1
drm 79636 2 radeon
rfcomm 43928 0
l2cap 30336 9 rfcomm
bluetooth 57172 4 rfcomm,l2cap
snd_pcm_oss 50432 0
snd_mixer_oss 20096 1 snd_pcm_oss
snd_seq 54452 0
snd_seq_device 12172 1 snd_seq
snd_ali5451 26252 1
snd_ac97_codec 97060 1 snd_ali5451
snd_pcm 82564 3 snd_pcm_oss,snd_ali5451,snd_ac97_codec
snd_timer 26756 2 snd_seq,snd_pcm
snd 58164 10 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_ali5451,snd_ac97_codec,snd_pcm,snd_timer
lp 14956 0
parport_pc 40764 1
parport 37832 2 lp,parport_pc
ip6t_LOG 10496 0
nf_conntrack_ipv6 22848 0
ip6t_REJECT 9216 0
xt_tcpudp 7168 0
xt_pkttype 5888 0
ipt_REJECT 8448 0
ipt_LOG 9984 0
xt_limit 6656 0
xt_state 6528 0
iptable_mangle 6784 0
iptable_nat 11140 0
nf_nat 21912 1 iptable_nat
ip6table_mangle 6656 0
nf_conntrack_ipv4 14856 2 iptable_nat
nf_conntrack 61684 5 nf_conntrack_ipv6,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4
nfnetlink 9752 4 nf_conntrack_ipv6,nf_nat,nf_conntrack_ipv4,nf_conntrack
ip6table_filter 6784 0
ip6_tables 17476 3 ip6t_LOG,ip6table_mangle,ip6table_filter
iptable_filter 6912 0
ip_tables 16324 3 iptable_mangle,iptable_nat,iptable_filter
x_tables 18308 11 ip6t_LOG,ip6t_REJECT,xt_tcpudp,xt_pkttype,ipt_REJECT,ipt_LOG,xt_limit,xt_state,iptable_nat,ip6_tables,ip_tables
sg 37036 0
st 40092 0
sd_mod 31104 0
sr_mod 19492 0
scsi_mod 140376 4 sg,st,sd_mod,sr_mod
ipv6 268152 17 nf_conntrack_ipv6,ip6t_REJECT,ip6table_mangle
af_packet 29064 0
apparmor 40736 0
loop 21636 0
dm_mod 56880 0
pcmcia 41076 0
firmware_class 13568 2 microcode,pcmcia
i2c_ali15x3 11652 0
orinoco_pci 10880 0
orinoco 42004 1 orinoco_pci
hermes 11136 2 orinoco_pci,orinoco
container 9088 0
ac97_bus 6272 1 snd_ac97_codec
battery 14724 0
ac 9604 0
button 12432 0
soundcore 11460 1 snd
snd_page_alloc 13960 1 snd_pcm
rtc_cmos 12064 0
i2c_ali1535 11012 0
rtc_core 23048 1 rtc_cmos
i2c_core 27520 2 i2c_ali15x3,i2c_ali1535
rtc_lib 7040 1 rtc_core
natsemi 31688 0
joydev 13632 0
yenta_socket 28684 1
ohci1394 36272 0
rsrc_nonstatic 15872 1 yenta_socket
shpchp 35092 0
hostap_pci 56208 0
pcmcia_core 40852 3 pcmcia,yenta_socket,rsrc_nonstatic
ide_cd 40324 1
ieee1394 91136 1 ohci1394
hostap 106372 1 hostap_pci
pci_hotplug 33216 1 shpchp
cdrom 37020 2 sr_mod,ide_cd
ieee80211_crypt 9728 1 hostap
ati_agp 12684 1
agpgart 35764 2 drm,ati_agp
ide_disk 20480 4
ehci_hcd 34956 0
uhci_hcd 27024 0
usbcore 123372 3 ehci_hcd,uhci_hcd
edd 12996 0
ext3 131848 2
mbcache 12292 1 ext3
jbd 68148 1 ext3
fan 9220 0
alim15x3 14988 0 [permanent]
ide_core 122948 3 ide_cd,ide_disk,alim15x3
thermal 19848 0
processor 40744 1 thermal

Ok, here’s what I know about that chipset. It can run on (2) drivers, hostap_pci and orinoco_pci. The good news is that both of those are showing up in your kernel modules list. Another good piece of news is that unless you have (2) onboard wired ethernet ports, the wireless is showing up as eth0. It is not however picking up an IP address from the DHCP server on your network (most likely your wireless router). Now, once upon a time you used to have to blacklist hostap_pci in order to allow this adapter to run, at that point on the orinoco_pci module. You can try going into YaST, network devices, network card, and edit/configure the wireless device there. If that does not work then you’re probably looking at the blacklist option, which requires an entire new set of instructions. I am not running 11.0 yet (is that your installed version?)so I can’t be of much specific help if that is the situation. I have tried to configure devices using this chipset unsuccessfully before honestly. At that point I just went out and purchased a card based on the Atheros chipset. Much better supported in linux.

Is this an installation from a live CD? I just tested the
gnome version on a machine and noticed that it defaults to
NetworkManager. If that’s the case for you I suggest you try
to switch to Traditional Method with ifup in the global op-
tions for Network Settings.

I installed OpenSUSE 10.3 32-bit. My cousin helped me with a little and we found that my wireless card found the wireless router called"linksys" using iwconfig but failed to receive a DHCP. I’m set to using IPv6 when maybe i shouldn’t be? I recently tried setting the network settings to “Traditional with ifup” but no results. Any ideas? My card is certainly recognized i just can’t get a connection with the router.