Very slow when booting 13.1


It has been long time since I updated from version 12.2 to 13.1 but lately I have noticed that my laptop spends a lot of time to boot (5 minutes).

The laptop that I have is an old machine, it’s a HP Pavilion DV4000 (Pentium III 2 GHz, 100 GB hard drive, graphics card ATI Mobility Radeon X700 and 1024 MB of RAM) and I have installed KDE 4.14.2

When typing this command Inxi add -Fpurz I get following:

System:    Host: Kernel: 3.16.6-2-desktop i686 (32 bit) Desktop: KDE 4.14.2
           Distro: openSUSE 13.1 (Bottle)
Machine:   System: Hewlett-Packard
 (portable) product: Pavilion dv4000 (ES984EA#ABE)
 model: 309E v: 52.0C Bios: Phoenix v: F.04 date: 12/09/2005
CPU:       Single core Intel Pentium M (-UP-) cache: 2048 KB speed: 2000 MHz (max)
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV410/M26 [Mobility Radeon X700]
           Display Server: 1.16.1 drivers: ati,radeon (unloaded: fbdev,vesa)
           tty size: 202x56 Advanced Data: N/A for root
Audio:     Card Intel 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller driver: snd_intel8x0
           Sound: Advanced Linux Sound Architecture v: k3.16.6-2-desktop
Network:   Card-1: Intel PRO/Wireless 2200BG [Calexico2] Network Connection driver: ipw2200
           IF: eth1 state: up mac: <filter>
           Card-2: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter driver: 8139too
           IF: eth0 state: down mac: <filter>
Drives:    HDD Total Size: 100.0GB (75.9% used) ID-1: /dev/sda model: TOSHIBA_MK1031GA size: 100.0GB
Partition: ID-1: / size: 20G used: 14G (75%) fs: ext3 dev: /dev/sda6 uuid: 76f289f8-c2b6-40eb-8e00-82e5301b1d83
           ID-2: /windows/C size: 34G used: 33G (98%) fs: fuseblk dev: /dev/sda1 uuid: 642870D42870A728
           ID-3: /home size: 35G used: 23G (69%) fs: ext3 dev: /dev/sda8
           uuid: 30f868b2-573a-4957-82d7-e38dbcbbbcbe
           ID-4: swap-1 size: 1.68GB used: 0.38GB (23%) fs: swap dev: /dev/sda7
           uuid: 6fad0531-2cbc-45a4-b07b-b518a5108119
Sensors:   System Temperatures: cpu: 66.0C mobo: 56.0C
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active yum sources in file: /etc/
           adobe-linux-i386 ~
Info:      Processes: 161 Uptime: 2:06 Memory: 616.3/1000.5MB Client: Shell (bash) inxi: 2.2.21

With systemd-analyze I get:

Startup finished in 7.924s (kernel) + 1min 58.507s (userspace) = 2min 6.432s

And with system-analyze blame I get this:

1min 19.026s display-manager.service
          8.805s NetworkManager.service
          8.461s ModemManager.service
          8.074s avahi-daemon.service
          8.047s systemd-logind.service
          8.017s wpa_supplicant.service
          7.663s sshd.service
          6.435s systemd-tmpfiles-clean.service
          5.831s apparmor.service
          5.179s rsyslog.service
          4.394s postfix.service
          3.521s lvm2-activation.service
          3.362s systemd-fsck@dev-disk-by\x2did-ata\x2dTOSHIBA_MK1031GAS_Z5DP8853S\x2dpart8.service
          2.720s systemd-udev-settle.service
          2.524s plymouth-read-write.service
          2.449s cycle.service
          2.311s udisks2.service
          2.052s systemd-vconsole-setup.service
          2.018s kmod-static-nodes.service
          2.015s systemd-udev-root-symlink.service
          1.385s systemd-readahead-collect.service
          1.384s systemd-readahead-replay.service
          1.384s dev-mqueue.mount
          1.383s dev-hugepages.mount
          1.383s sys-kernel-debug.mount
          1.311s polkit.service
          1.281s systemd-tmpfiles-setup-dev.service
          1.062s windows-C.mount
          1.037s cifs.service
          1.026s scpm.service
           724ms systemd-sysctl.service
           720ms user@1000.service
           629ms bluetooth.service
           602ms systemd-tmpfiles-setup.service
           573ms systemd-journal-flush.service
           549ms systemd-remount-fs.service
           451ms rpcbind.service
           420ms home.mount
           380ms systemd-update-utmp.service
           372ms auditd.service
           370ms nfs.service
           354ms systemd-random-seed.service
           316ms systemd-udevd.service
           313ms lvm2-activation-early.service
           310ms upower.service
           294ms console-kit-daemon.service
           292ms clos.service
           286ms plymouth-start.service
           259ms console-kit-log-system-start.service
           210ms systemd-modules-load.service
           141ms jexec.service

With “systemctl --all | grep found” I can see a lot of services that are disabled because are missing. I don’t know if this is correct or not:

amavis.service                                                                           not-found inactive dead      amavis.service
cyrus.service                                                                            not-found inactive dead      cyrus.service
dmraid.service                                                                           not-found inactive dead      dmraid.service
exim.service                                                                             not-found inactive dead      exim.service
ldap.service                                                                             not-found inactive dead      ldap.service
md.service                                                                               not-found inactive dead      md.service
openslp.service                                                                          not-found inactive dead      openslp.service
sendmail.service                                                                         not-found inactive dead      sendmail.service
syslog-ng.service                                                                        not-found inactive dead      syslog-ng.service
syslogd.service                                                                          not-found inactive dead      syslogd.service
winbind.service                                                                          not-found inactive dead      winbind.service
ypserv.service                                                                           not-found inactive dead      ypserv.service                                                                            not-found inactive dead

Any idea what can happen?

Thanks in advance!

Here I have

69ms display-manager.service

Do you have auto login on? Tell us more about the video/driver Is this Intel+AMD GPU???


Thanks for your answer! Autologin is disabled and the graphic card driver I have is:

 /sbin/lspci -nnk | grep VGA -A2
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] RV410/M26 [Mobility Radeon X700] [1002:5653]
        Subsystem: Hewlett-Packard Company Device [103c:309e]
        Kernel driver in use: radeon

Might try the AMD proprietary driver. Or try changing KDM to XDM or other display-manager. See if it makes a difference

On 2015-05-16 15:46, johnlewis wrote:

> And with system-analyze blame I get this:

Try with critical-chain

> Code:
> --------------------
> 1min 19.026s display-manager.service
> --------------------

That’s the important one.

> With “systemctl --all | grep found” I can see a lot of services that are
> disabled because are missing. I don’t know if this is correct or not:


Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

OK I tried with systemd-analyze critical-chain: @52.594s
└─ @52.594s
  └─postfix.service @37.922s +14.670s
    └─ @37.919s
      └─NetworkManager.service @24.517s +13.401s
        └─ @24.210s
          └─ @24.202s
            └─systemd-tmpfiles-clean.timer @24.201s
              └─ @24.199s
                └─apparmor.service @21.979s +2.219s
                  └─systemd-tmpfiles-setup.service @21.111s +859ms
                    └─ @21.105s
                      └─home.mount @20.611s +492ms
                        └─systemd-fsck@dev-disk-by\x2did-ata\x2dTOSHIBA_MK1031GAS_Z5DP8853S\x2dpart8.service @18.128s +2.407s
                          └─dev-disk-by\x2did-ata\x2dTOSHIBA_MK1031GAS_Z5DP8853S\x2dpart8.device @18.126s

I will try to install the AMD proprietary driver too.


Looking at I think my card is not supported by the AMD propietary driver and I need installing the open source radeon driver >:(

On 2015-05-16 19:16, johnlewis wrote:
> OK I tried with systemd-analyze critical-chain:
> Code:
> --------------------
> @52.594s
> └─ @52.594s
> └─postfix.service @37.922s +14.670s
> └─ @37.919s
> └─NetworkManager.service @24.517s +13.401s
> └─ @24.210s
> └─ @24.202s
> └─systemd-tmpfiles-clean.timer @24.201s
> └─ @24.199s
> └─apparmor.service @21.979s +2.219s
> └─systemd-tmpfiles-setup.service @21.111s +859ms
> └─ @21.105s
> └─home.mount @20.611s +492ms
> └─systemd-fsck@dev-disk-by\x2did-ata\x2dTOSHIBA_MK1031GAS_Z5DP8853S\x2dpart8.service @18.128s +2.407s
> └─dev-disk-by\x2did-ata\x2dTOSHIBA_MK1031GAS_Z5DP8853S\x2dpart8.device @18.126s
> --------------------

You have 13.4 S delay on Network manager, and then 14.6 on postfix (I
would have think that because of network not being available).

On the other hand, the graphical target doesn’t appear — the important
part are the digits after the ‘+’ symbol, and there is none. Which is
confusing, there is about a minute that does not show up.

A possibility is to change your mode of operation: instead of halting
the machine, hibernate it. In my experience, it starts faster.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

Thanks Carlos. On another forum they said I should try to install another desktop like Xfce. Perhaps KDE is getting to heavy for my old machine :’(

The large graphic target time seems to me to indicate the video driver being slow to start up maybe a look in the logs might show the cause

On 2015-05-16 20:46, johnlewis wrote:
> Thanks Carlos. On another forum they said I should try to install
> another desktop like Xfce. Perhaps KDE is getting to heavy for my old
> machine :’(

You can certainly try. I certainly do not use KDE nor Gnome in my older

By “five minutes” you mean till you get to the full kde desktop? Because
we don’t call that “boot time”. The 2 minutes shown by system-analyze is
reasonable for your machine.

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

How much memory do you have installed in this old HP Pavillion laptop? That is likely to be impacting here. FWIW, My old HP Compaq was becoming sluggish a couple of years ago, and I was able to upgrade it to 4GB.

On 2015-05-17 02:06, deano ferrari wrote:
> How much memory do you have installed in this old HP Pavillion laptop?

1 G (first post).

Cheers / Saludos,

Carlos E. R.

(from 13.1 x86_64 “Bottle” (Minas Tirith))

There’s the reason then. :slight_smile: I gave an old ThinkPad Z60m with 1Mb to another family member, and it was taking almost 2 minutes to get KDE up and running. Upgraded it to 2GB - enough to make it usable for basic tasks. Now takes around 50 seconds for KDE login stage.

Thanks for all your help. Finally I have installed Xfce and I can say it’s a lot faster than KDE in my machine. So, goodbye KDE and welcome Xfce! :wink: