Very slow video loading in gwenview


Not sure this is the right place to ask, but you have to start somewhere.

After the last round of KDE updates (for the 4.10 repos) video loading in gwenview has become very slow; it takes about a minute for a video to start playing in gwenview, where before it started playing immediately. Also gwenview becomes completely unresponsive while the video is loading, as does the desktop sometimes (though not reliably).

Has anyone else encountered this?

you should create a new “user” and use gwenview in it and eliminate “profile” issues

Yeah! Here both tumbleweed and 12.3 is experiencing the same as yours. Worst is when opening images from an iphone.

No problem here
kde 4.10.2
OS 12.3

No issue here either. How did you update from the 410 repo?

I updated through Apper’s automatic updates, but to make sure everything is up to date I also did a `zypper up’, and everything is up to date.

Unfortunately, creating a new user did not solve the problem: same very slow loading with a new user profile. Of course this applies just as much to videos that used to work just fine. I don’t see the problem with images, just with videos.

Please try doing this

Switching packages to packman did not solve the problem (I thought all these packages were already from packman, as I thought I installed all the multimedia stuff, following your guide of course :slight_smile: , after switching to the KDE repo, but no, so thanks for that).

I did find a solution on the KDE forum which worked for me. It seems it has something to do with the phonon backend. I was using gstreamer and swtiching to the vlc backend solved it. If you use the vlc backend switching to gstreamer might work too.

So if you’re having this problem try `Configure Desktop -> Hardware -> Multi-media -> Phonon -> Backend’ and switch the preference order of the backend, then log out and log back in.

I recently upgraded my 12.3 distribution to KDE 4.10.3 ‘Release 1’ and just about everything is slow and not just the KDE components. If I click a link in a Thunderbird email, it takes forever for Chrome to pop up with the web page, eventhough Chrome is already launched.