Very quick battery drain

Hi all. I am a first time user of openSUSE and pretty much a beginner with linux (tried Ubuntu for a litte bit). I just installed version 11.3 last night, and everything works fine except for the battery gauge. When I unplugged the AC charger to work off of the battery, the gauge indicated it was draining very quickly. Immediately upon unplugging it it dropped to 96% and then would drop about 1% every 30 seconds in powersaver mode with only the wireless card on. I know this can’t be right as it was running for about 2.25 hours on a full charge in Windows 7. I’ve looked at the power management and everything looks fine to me. I also scanned some threads where people had similar problems, but I didn’t really understand some of the solutions that were given. I did find out how to use acpi -b in the terminal so I tested the drain myself. I used acpi -b every 30 seconds and here are the results.

Zac@linux-eowr:~> acpi -b
Battery 1: discharging, 79%, 01:37:41 remaining
Zac@linux-eowr:~> acpi -b
Battery 1: discharging, 79%, 01:36:36 remaining
Zac@linux-eowr:~> acpi -b
Battery 1: discharging, 78%, 01:35:25 remaining
Zac@linux-eowr:~> acpi -b
Battery 1: discharging, 77%, 01:34:35 remaining
Zac@linux-eowr:~> acpi -b
Battery 1: discharging, 76%, 01:35:23 remaining
Zac@linux-eowr:~> acpi -b
Battery 1: discharging, 75%, 01:34:28 remaining
Zac@linux-eowr:~> acpi -b

It looks like it is draining twice as fast as it should. Oh, and I also tried draining the battery completely and recharging to try to calibrate it, and that didn’t seem to help.

Sorry for the long post. If anyone knows what the problem is and could explain it in terms for a beginner, I would really appreciate the help. I like openSUSE so far, but if I can’t get this problem fixed, I may have to try Kubuntu out (I really like the look and feel of KDE). Thanks in advance for your help.

You may give some more info about your system:

  • has it one or two graphic cards, and what are the brands?
  • how old is the laptop
  • how old the battery
  • has the battery an indicator and is the discharge consistent with the one the OS indicates?
  • what brand is the laptop (exact type)
  • what chipset has the laptop (as exact as possible)
  • what type of HDD does the laptop use
  • do you use diskencryption
  • are you using wireless or bluetooth devices during the drain when it occurs?

Beforehand: did you have Windows on that machine? What flavor? What is the difference between battery consumption if you compare it (in case you had Windows).
Has the usage you make of the laptop changed since you did install Linux?
In the BIOS did you set “non Windows operating system”?
Did you check if your battery charges correctly?

To answer as best I can:

  1. ATI Radeon HD 4650
  2. 1.5 years
  3. Same as above
  4. No battery indicator
  5. Sony Vaio VGN-FW490
  6. I’ll have to check the BIOS and see if I can find out
  7. SATA, I think
  8. No
  9. I was using wireless, but I turned it and the bluetooth off and got similar drain.

I was using Windows 7. On a full charge with wireless on I got 2.25 hours from Windows, but on openSUSE, I barely get an hour if lucky.
No change in use at all. Light internet and document editing.
I haven’t checked the BIOS but I will.
It seems to charge correctly, but I don’t know how to check for sure.

I also ran Powertop and it gave me this:

PowerTOP version 1.12 (C) 2007 Intel Corporation

Cn Avg residency P-states (frequencies)
C0 (cpu running) ( 3.7%) 2.10 Ghz 0.8%
C0 0.0ms ( 0.0%) 1.60 Ghz 0.0%
C1 mwait 0.0ms ( 0.0%) 1200 Mhz 99.2%
C2 mwait 0.2ms ( 0.4%)
C3 mwait 2.9ms (95.8%)

Wakeups-from-idle per second : 351.1 interval: 5.0s
Power usage (ACPI estimate): 19.4W (1.4 hours)

Top causes for wakeups:
32.3% ( 87.0) <interrupt> : extra timer interrupt
13.0% ( 35.0) <interrupt> : PS/2 keyboard/mouse/touchpad
10.1% ( 27.2) firefox : futex_wait_queue_me (hrtimer_wakeup)
9.0% ( 24.2) <interrupt> : iwlagn
8.8% ( 23.6) <interrupt> : radeon
7.9% ( 21.4) <interrupt> : ahci
3.7% ( 10.0) <kernel core> : run_timer_softirq (r600_audio_update_hdmi)
2.6% ( 7.0) Xorg : schedule_hrtimeout_range (hrtimer_wakeup)
1.9% ( 5.0) kbluetooth : schedule_hrtimeout_range (hrtimer_wakeup)
1.5% ( 4.0) <kernel core> : usb_hcd_poll_rh_status (rh_timer_func)
1.3% ( 3.6) <interrupt> : acpi
1.2% ( 3.2) knotify4 : schedule_hrtimeout_range (hrtimer_wakeup)
1.1% ( 3.0) kwin : schedule_hrtimeout_range (hrtimer_wakeup)
1.1% ( 3.0) Xorg : ttm_bo_cleanup_refs (delayed_work_timer_fn)
1.0% ( 2.8) k3b : schedule_hrtimeout_range (hrtimer_wakeup)
0.4% ( 1.0) <kernel IPI> : Rescheduling interrupts
0.3% ( 0.8) konsole : schedule_hrtimeout_range (hrtimer_wakeup)
0.3% ( 0.8) kwalletd : schedule_hrtimeout_range (hrtimer_wakeup)
0.2% ( 0.6) k3b : futex_wait_queue_me (hrtimer_wakeup)

Suggestion: Enable wireless power saving mode by executing the following command
:
iwconfig wlan0 power timeout 500ms

Don’t know what it all means though :slight_smile:

The 11.3 default kernel is not very efficient in energy saving. The new 11.4 will come with the 2.6.37 which is much better. I have this kernel currently running on my machine with good results. A good indication to update ASAP.

Substantially you have a few possibilities to gain autonomy in 11.3:
switch bluetooth off if you do not need it. It drains a lot as it is a sender.
Powertop offers a lot of options. One of them is not to check for changes in media (which wakes up the cpu continuously).

Desktop: There is a service called “nepomuk desktop search” running in kde. It is an indexing service that consumers a lot of energy because it makes the disk work continuously. While Nepomuk is not to be deactivated because needed by Plasma, the desktop search can be stopped (and should give some relief). I do not use KDE4 but if somebody reads this (s)he may propose a setting to deactivate this service while on battery power (provided a similar setting exists).

The ATI card may be also cause of consumption. This has nothing to do with Linux or OpenSuse but with the proverbial low quality of the ATI drivers that this industry provides. Somebody with experience with ATI could provide you with more insight if an alternative suitable to you exists. You should deactivate screen savers.

The biggest consumers in your system are the extra timer interrupt, the keyboard/mouse, wlan and the graphics card. You may activate the power saving of the wlan that powertop offers. The energy saving stages of the CPU seem to be set and appear to work as foreseen.

Have also a look on your power-savings setting of the very KDE.

Once you have done all this, you may tell me what values you achieve and if it got better.

PS. Watch out that PCMCIA cards are often badly integrated in ACPI and may be “big spenders”.

change the default brightness in the power management settings

Hi:
I’m having a similar problem here. I have a three year old hp f565 with opensuse 11.3. About six months ago, I had a problem with my battery (the battery indicator would show it as full, but when I unplugged the computer, it would loose all power and shutdown). I figured the battery was dead, so I replaced it with a new one.
Now I’m having a similar problem, when the battery is present, the indicator will show it as full, but when the computer is running on battery it will automatically shutdown after about 10 minutes or so.

I’m guessing there might be a problem with some other part of the hardware, though I’m not sure how to confirm it.

I tried the powertop advices, but still I have this problem. Any suggestions? Thanks.

This is a powerdevil related bug for what I know (as long as somebody does not tell me that 11.1 with the last official kernel and KDE3.5 had something in common with 11.3 default kernel and KDE4.x. The issue you have should be random (if it is identical to mine) and does not present all the time.
Furthermore this is not the battery draining the OP was speaking of. Your battery is perfect. It is powerdevil that apparently does not communicate / understand with the ACPI support of your machine.
You might try to update to a more recent version of kde to see if that helps. To me it helped to unistall powerdevil and use the 3.5 software (you cannot obviously).

Have you tried playing with the Power Profile settings? Helped me a fair bit!

Do you think it should go away with the upgrade to 11.4? BTW, I use gnome. Thanks

If I have to be honest, I cannot tell with certainty. I think you should as first step see if you have the latest version of the BIOS of your producer. Some producers do also offer a BIOS driven battery assessment program to represent the real battery duration through the BIOS.
Once ascertained this: although 11.4 is brand new, the kernel is much better suited for power management and does give you greatly less battery consumption. This alone may be worth the upgrade. All in all I have the feeling that this is a “good” edition, quite convinced that it outperforms 11.3.
So if you use Gnome and if you search for real change, an update to 11.4 could be a good idea.
Nobody can ever give you a guarantee however. For what it is good for: i changed to kernel 3.6.37 with 11.1 and I have to tell you that the result on battery consumption is veeeerrrry good.
Good luck for your endeavors.

Hi:

Looking around I came up with this WinFlash for HP Notebook System BIOS (for Notebooks with AMD Processors) - Microsoft Windows/Vista-Based Compaq Presario F565LA Notebook PC - HP Customer Care (United States - English)

It’s an update to the computer BIOS, the catch is, it’s to be used on Win Vista (Default OS of the computer). Would it be ok if I ran it using wine?

This can be very tricky. If it fails you may make your PC unusable. Don’t you have a spare disk to mount with a vista-install for these service issues? BTW, here you see why I did buy Lenovo. My laptop shipped without OS and the BIOS update is available as an iso that is OS indipendent.
I personally would not recomend trying to update the BIOS with WINE (somebody claimed he did this, maybe the ones that tried and where not making it do not claime anything anymore…

It’s an update to the computer BIOS, the catch is, it’s to be used on Win Vista (Default OS of the computer). Would it be ok if I ran it using wine?

hi

what do you mean by that? When I go to S.settings-> Power management settings all I can set is “Performance” there is no “power saver” option in Opensuse 11.4 kde…

In my laptop battery drains also very quick, much quicker than in Linux Mint which I used few weeks ago so I am looking for some options…

Strange … in my 11.4 install KDE–>SystemSettings–>PowerManagement, I have following Power Profiles:
Performance
Powersave
Agressive powersave
In global settings I can chose which one to use on battery power + screen brighness, etc.

Perhaps you need to install laptop tools … not sure why you would no see the profiles … I can even see them on desktop - though I cannot unplug desktop :slight_smile: