Very poor performance when zooming webpages

Hi guys,
I struggle with this issue for a while now and can’t seem to figure it out.

First, my office PC is made of an Athlon X2 240 CPU, 4GB DDR3, Leadtek 8600GT GPU, 1x160GB SATA2 HDD and 1x320GB ATA HDD, OpenSUSE x64 12.4 and Win7 x64.

On both OSes I experience this problem :

If I zoom in or out on any webpage that contains videos and\or images (like Youtube, 9Gag, news sites) etc, on ANY browser (Chrome, Firefox), the scrolling of the page becomes extremely sluggish. If I try to play a video zoomed in, its stuttering at low FPS.

I tried watching the CPU usage when viewing a page loaded with videos and it does not go above 40%, the RAM usage instead goes up to 1.5GB for Firefox but that is the maximul load I managed to get, still plenty of RAM left but the performance sucks.

What do you think ? Could the GPU play a role in this, I know the 8600GT is quite antique but I don’t think it should have something to do with flash content or images on webpages.

So, is your multimedia fully updated? Check out the next link for openSUSE 12.3:

Could consider loading the nVIDIA driver, the latest still works with your video card:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

You mention openSUSE 12.4, but I suppose you mean 12.3. You could give us the output of free from terminal:


and then a df command:


Just post the results of each here for us to see. The following bash script can install inxi which when run povides a whole lot of hardware info for us to see:

H.I. Hardware Information - A Bash script to install and run inxi with default options! - Blogs - openSUSE Forums

Thank You,

you can try turning off “Hardware Acceleration” and check if it helps
Edit==>preferences==>Advanced==>Browsing==> uncheck “Use hardware accele…”

Output of the “free” command

             total       used       free     shared    buffers     cached
Mem:       4054056    1835748    2218308          0      55944     820204
-/+ buffers/cache:     959600    3094456
Swap:      2108412          0    2108412

output of “df”

Filesystem     1K-blocks     Used Available Use% Mounted on
rootfs          18643256 13159948   4536264  75% /
devtmpfs         1985276       36   1985240   1% /dev
tmpfs            2027028      620   2026408   1% /dev/shm
tmpfs            2027028      660   2026368   1% /run
/dev/sda3       18643256 13159948   4536264  75% /
tmpfs            2027028        0   2027028   0% /sys/fs/cgroup
tmpfs            2027028        0   2027028   0% /media
tmpfs            2027028      660   2026368   1% /var/run
tmpfs            2027028      660   2026368   1% /var/lock
/dev/sdb1      307665016   195416 291841108   1% /media/HDD320
/dev/sda1       68430844 48204728  20226116  71% /windows/C
/dev/sda4       65758988 39235164  23183436  63% /home/roberto/Downloads

I have 2 HDDs, one has OpenSUSE and Windows 7, the other one is empty, I use it for large downloads only.

I will try with "hardware accceleration unchecked and report back. I will also try installing the nvidia driver according to the link above.

Thank You

I don’t see any problem with memory and your disk space is OK for now, but root is up to 75% used and worth keeping an eye out. As for the video driver, it will speed up operation. I have links to more than one way to install the driver and look at them all before making a choice.

Thank You,

Disabling hardware acceleration somehow improved the web browsing performance but every now and then I get Firefox to stuck on pages with high media content.

I also tried to install the latest nVidia driver available and after reboot my PC gets stuck after loading screen, I have to restart and select the third option in the Grub menu in order for the graphical interface to load.

And this is Grub Legacy I see with openSUSE 12.2 even though Grub 2 was the default. The nVIDIA driver has to be installed into the kernel you are using at the time and is not installed into every kernel you have on your PC. Each new kernel version requires that the driver be reloaded. When using the nVIDIA repository method and if you are sticking with the distro released kernel version, the nVIDIA driver will be installed for you on each kernel update. When you manually install the nVIDIA driver, you must reinstall it for each new kernel version that you use.

Thank You,

Can you please point me at the right tutorial to follow in order to correctly install the nVidia video driver ? I found so many tutorials and can’t figure out wich one to follow exactly.

If I understand correctly, I no longer can boot into the first option in my Grub menu because I tried to install the driver using the repository option and somehow I did not install it correctly ?

There are multiple entries listed in the Grub menu because I can choose between kernels or ?..what are the differences between them, something like the safe mode for windows ? I will also look for documentation regarding this, it is very interesting.

Do you have a file /etc/X11/xorg.conf (maybe created by nvidia-configure or nvidia-settings)?
Remove that, then you should be able to boot without the nvidia driver.

I guess you installed the nvidia kernel module for kernel-default, that’s why you have two kernels now and the first one (kernel-desktop) is not able to use the nvidia driver.

There are multiple entries listed in the Grub menu because I can choose between kernels or ?..what are the differences between them, something like the safe mode for windows ? I will also look for documentation regarding this, it is very interesting.

Yes. You have BOTH kernel-desktop and kernel-default installed, and both also provide a “Failsafe” entry which uses “conservative” settings that should work on all hardware.

Please do the following: (I suppose you already have the nvidia repo added, because you said you “tried to install the driver using the repository option”)

  • as mentioned above, remove the file /etc/X11/xorg.conf
  • Open YaST->Software Management
  • type nvidia into the search field and uninstall ALL packages that have “nvidia” in their NAME. (don’t remove the nouveau packages!)
  • type kernel-default into the search field and uninstall ALL packages that this finds.
    If there are some dependency conflicts and you are not sure what to do, just ask.
  • Press “Accept” and wait.

Then enter YaST->Software Management again.
Type nvidia into the search field, and install the following packages:


(yes, your card is still supported by the latest driver :wink: )

After that, reboot and you should be using the nvidia driver…

I have a blog on loading the nVIDIA driver the hard way, which is not hard. You can find that info here:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

The top default entry will be the most recent kernel. The Advanced menu lists all installed kernels, twice with both a standard and rescue mode startup. As time goes forward, you will collect new kernels, mainly due to security fixes, but for bugs too. You will keep up to the last three kernel versions and each version will have two entries. This is normal and provide you with extra options should a certain kernel not work for you. For help with Grub 2, please look here:

GNU Grub2 Command Listing Helper with --help & Input - Blogs - openSUSE Forums

Thank You,

Ok, it wants me to choose what to do with the dependency found (see picture)

Looks like you have tried to install all nVIDIA driver versions, but in fact you only need one version. What video card chip set are you using? I would find out the latest driver version my video chipset would take, and only have that installed. I use the open source driver and only have the following files for nvidia loaded (Searching for nvidia in YaST):


Once you find out the supported version, either only use that, such as 319.17 or get rid of it all like I have or consider loading the driver the hard way, outside of YaST:

Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums

But you do not load every file that has the word nVIDIA in it.

Thank You,

Well, as I said: Remove all the packages with “nvidia” in the NAME.
That doesn’t include “xf86-video-nv”, does it? :wink: So keep that.

Remove those:

  • nvidia-computeG02
  • nvidia-computeG03
  • nvidia-gfxG02-kmp-default
  • nvidia-gfxG02-kmp-desktop
  • nvidia-gfxG03-kmp-default
  • nvidia-settings
  • x11-video-nvidiaG02
  • x11-video-nvidiaG03

Then continue the way I wrote before.

Regarding “nvidia-settings”: this is a very old version (290.10) that doesn’t even work anymore with the current driver.
You don’t need that anyway, since it is included in the driver package.

I’ve installed the driver as stated and everything seems fine now, though the isse with poor performance on webpages with high multimedia content remains, I’m still trying to track down what hardware component could cause that.

Better install “Mesa-demo-x” and check with “glxinfo | grep render” if the driver really is working.

Also you could try to turn ON hardware acceleration again.
Check if hw acceleration is turned ON for flash: Right-click on a flash video and choose settings.

Also which desktop environment are you using?
IF KDE, open “Configure Desktop”->“Desktop Effects”->“Advanced” and check that “Composite type” is set to “OpenGL” and “Qt graphics system” is set to “raster”.

This is the result of “glxinfo | grep render”

direct rendering: Yes
OpenGL renderer string: GeForce 8600 GT/PCIe/SSE2
    GL_NV_blend_square, GL_NV_conditional_render, GL_NV_copy_depth_to_color, 
    GL_NV_path_rendering, GL_NV_pixel_data_range, GL_NV_point_sprite, 
    GL_NVX_conditional_render, GL_NVX_gpu_memory_info, 

I checked Desktop Effects ! Compositing type is indeed set to OpenGL. Instead, I do not find a Qt graphics system option. I have KDE on OpenSUSE 12.2 x64.

If I check Flash settings on any videos I have the “Enable hardware acceleration” checked, even though I disabled it in Firefox settings. Enabling or disabling that option in Flash settings does not seem to make any difference. I will try and enable “Use hardware acceleration when available” option in Firefox and see if anything improoves.

Thank you !