Very low microphone level

Using pulseaudio. Used on Skype. Tested with audacity. I have to shout right into it to get any signal. Is there any way I can boost it further. Output of “pactl list sources”

Source #2
State: SUSPENDED
Name: alsa_input.usb-YC1006_Usb_MIC-00.mono-fallback
Description: Usb MIC Mono
Driver: module-alsa-card.c
Sample Specification: s16le 1ch 44100Hz
Channel Map: mono
Owner Module: 22
Mute: no
Volume: mono: 99957 / 153% / 11.00 dB
balance 0.00
Base Volume: 65536 / 100% / 0.00 dB
Monitor of Sink: n/a
Latency: 0 usec, configured 0 usec
Flags: HARDWARE HW_MUTE_CTRL HW_VOLUME_CTRL DECIBEL_VOLUME LATENCY
Properties:
alsa.resolution_bits = “16”
device.api = “alsa”
device.class = “sound”
alsa.class = “generic”
alsa.subclass = “generic-mix”
alsa.name = “USB Audio”
alsa.id = “USB Audio”
alsa.subdevice = “0”
alsa.subdevice_name = “subdevice #0
alsa.device = “0”
alsa.card = “2”
alsa.card_name = “Usb MIC”
alsa.long_card_name = “YC1006 Usb MIC at usb-0000:01:00.0-8, full speed”
alsa.driver_name = “snd_usb_audio”
device.bus_path = “pci-0000:01:00.0-usb-0:8:1.0”
sysfs.path = “/devices/pci0000:00/0000:00:01.2/0000:01:00.0/usb1/1-8/1-8:1.0/sound/card2”
udev.id = “usb-YC1006_Usb_MIC-00”
device.bus = “usb”
device.vendor.id = “1b3f”
device.vendor.name = “Generalplus Technology Inc.”
device.product.id = “2008”
device.product.name = “Usb MIC”
device.serial = “YC1006_Usb_MIC”
device.string = “hw:2”
device.buffering.buffer_size = “176400”
device.buffering.fragment_size = “88200”
device.access_mode = “mmap+timer”
device.profile.name = “mono-fallback”
device.profile.description = “Mono”
device.description = “Usb MIC Mono”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-usb”
Ports:
analog-input-mic: Microphone (type: Mic, priority: 8700, availability unknown)
Active Port: analog-input-mic
Formats:
pcm
ion@localhost:~>

Check card number
aplay -l
then examine the mixer settings for the relevant card. For example
amixer -c0
*Check what mic settings are listed there and report back.

ion@localhost:~> aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 3: HDMI 0 [V173]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 0: ALC897 Analog [ALC897 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 1: ALC897 Digital [ALC897 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
ion@localhost:~> amixer -c0
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘IEC958’,1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘IEC958’,2
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
ion@localhost:~>

That’s the wrong card output. You need amixer output for the card that contains the recording hardware.

Then I think this must be it.

ion@localhost:~> amixer -c2
Simple mixer control ‘Mic’,0
Capabilities: cvolume cvolume-joined cswitch cswitch-joined
Capture channels: Mono
Limits: Capture 0 - 8
Mono: Capture 8 [100%] [0.00dB] [on]
Simple mixer control ‘Auto Gain Control’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
ion@localhost:~>

I’m confused. Could it be this c!?

ion@localhost:~> amixer -c1
Simple mixer control ‘Master’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 86 [99%] [-0.75dB] [on]
Simple mixer control ‘Headphone’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 0 [0%] [-65.25dB] [off]
Front Right: Playback 0 [0%] [-65.25dB] [off]
Simple mixer control ‘PCM’,0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 255 [100%] [0.00dB]
Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control ‘Front’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 87 [100%] [0.00dB] [on]
Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control ‘Front Mic’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Front Mic Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 1 [33%] [10.00dB]
Front Right: 1 [33%] [10.00dB]
Simple mixer control ‘Surround’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 87 [100%] [0.00dB] [on]
Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control ‘Center’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control ‘LFE’,0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 87 [100%] [0.00dB] [on]
Simple mixer control ‘Line’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Line Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]
Simple mixer control ‘IEC958’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [off]
Simple mixer control ‘IEC958 Default PCM’,0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 63
Front Left: Capture 63 [100%] [30.00dB] [on]
Front Right: Capture 63 [100%] [30.00dB] [on]
Simple mixer control ‘Capture’,1
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 63
Front Left: Capture 0 [0%] [-17.25dB] [off]
Front Right: Capture 0 [0%] [-17.25dB] [off]
Simple mixer control ‘Auto-Mute Mode’,0
Capabilities: enum
Items: ‘Disabled’ ‘Enabled’
Item0: ‘Enabled’
Simple mixer control ‘Channel Mode’,0
Capabilities: enum
Items: ‘2ch’ ‘4ch’ ‘6ch’
Item0: ‘2ch’
Simple mixer control ‘Input Source’,0
Capabilities: cenum
Items: ‘Front Mic’ ‘Rear Mic’ ‘Line’
Item0: ‘Front Mic’
Simple mixer control ‘Input Source’,1
Capabilities: cenum
Items: ‘Front Mic’ ‘Rear Mic’ ‘Line’
Item0: ‘Front Mic’
Simple mixer control ‘Loopback Mixing’,0
Capabilities: enum
Items: ‘Disabled’ ‘Enabled’
Item0: ‘Disabled’
Simple mixer control ‘Rear Mic’,0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 31
Mono:
Front Left: Playback 0 [0%] [-34.50dB] [off]
Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control ‘Rear Mic Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 0 [0%] [0.00dB]
Front Right: 0 [0%] [0.00dB]
ion@localhost:~>

YaST tells me there is only one sound card that’s configured
Family 17h (Models 10h-1fh) HD Audio Controller

Just to confuse matters further. When I run the YaST speaker test I get no sound, but radio, music player and videos work just fine. So the audio card is working for output.

Don’t use the YaST sound utility. It is not required for configuration purposes.

The output you shared shows a ‘Front mic’ and a ‘Rear Mic’. Not sure which is applicable in your situation. The former has a ‘Front Mic Boost’ level

Simple mixer control ‘Front Mic Boost’,0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 1 [33%] [10.00dB]
Front Right: 1 [33%] [10.00dB]

That might require adjusting perhaps.

You mentioned Audacity in your opening post - when it is running, try using ‘pavucontrol’ to check/adjust levels shown in the ‘Input Devices’ and ‘Recording’ tabs.

I had already done that before. It shows in my first post as…

Volume: mono: 99957 / 153% / 11.00 dB

That’s the maximum pavucontrol allows.

That is not the mic boost level I was referring to. Also, I think you can set recording levels per application using pavucontrol.

Well pavucontrol shows USB MIC Mono in Input Devices and it’s at the maximum (153db) and if I tap the mic with my finger there is some response. I would send you a screen shot buts it’s too complicated. As I said if I put my lips up against the mic, I do get some input. That’s just not handy when it’s on my desk.

Fire up alsamixer, choose the sound card with F6, and look for the mic boost. Try increasing that.

Tried that already at the start. Doesn’t show any adjustments.

Thanks for the help. Problem solved. The microphone is in the garbage. Aqui es Mexico!

1 Like

@ionmich if you have an old head phone not a usb type you can test it as a micropone in the mic slot it might work better.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.