Version mismatch kernel-default kernel-devel kernel-source

kernel-devel and kernel-source seem to be for an older version (6.6) than the current kernel-default (6.7).
Is this bad, or is this on purpose? Apologies if this a stupid question, I don’t have any experience with packaging software.
I am using OpenSuse Slowroll and was trying to install the proprietary nvidia dkms driver.

sudo zypper ref --force
zypper info kernel-default kernel-devel kernel-source

returns the following:

Repository         : base-oss
Name               : kernel-default
Version            : 6.7.4-1.1
[...]

Repository         : update
Name               : kernel-devel
Version            : 6.6.11-1.1
[...]

Repository         : update
Name               : kernel-source
Version            : 6.6.11-1.1
[...]

I’m looking at my slowroll system (running in a VM). I just updated it. And “kernel-default” is at version 6.6.11-1.1

My best guess is that you have added an incompatible repo somewhere.

1 Like

Hi, I’m using kernel-longterm 6.6.16. In the repositories there are:

https://cdn.opensuse.org/slowroll/repo/oss/x86_64/
Kernel-default-6.7.4.1.1

https://cdn.opensuse.org/update/slowroll/repo/oss/x86_64/
kernel-default-6.6.11-1.1.x86_64.rpm
kernel-default-base-6.7.4-1.1.31.8.x86_64.rpm
kernel-default-base-rebuild-6.7.4-1.1.31.8.x86_64.rpm
kernel-default-debuginfo-6.6.11-1.1.x86_64.rpm
kernel-default-debugsource-6.6.11-1.1.x86_64.rpm
kernel-default-devel-6.6.11-1.1.x86_64.rpm
kernel-longterm-6.6.16-2.1.g9e8fce2.x86_64.rpm
kernel-longterm-debuginfo-6.6.16-2.1.g9e8fce2.x86_64.rpm
kernel-longterm-debugsource-6.6.16-2.1.g9e8fce2.x86_64.rpm
kernel-longterm-devel-6.6.16-2.1.g9e8fce2.x86_64.rpm
kernel-longterm-devel-debuginfo-6.6.16-2.1.g9e8fce2.x86_64.rpm

1 Like

Thank you for checking with your own installation!

That would surprise me, because zypper says it got kernel-default from the base-oss repository. So version 6.7.4… should be the correct one AFAIK. :thinking:

I checked with zypper repos and my base-oss uses http://cdn.opensuse.org/slowroll/repo/oss/ as URI. This URI matches the instructions on the wiki page.

Though this doesn’t rule out an incompatible repo preventing kernel-source/kernel-devel from upgrading to the latest version. I need to figure out how to investigate this. My zypper skills are a bit lacking.

Seems like the difference is between the base-oss and update repos.

On my system update has priority 80 and base-oss has priority 99, so update should be preferred over base-oss.
But kernel-default was installed from base-oss, no idea whether this the correct way or a bug.

 ❯ zypper repos --details --show-enabled-only
#  | Alias        | Name                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                          | Service
---+--------------+---------------------------------------------+---------+-----------+---------+----------+--------+------------------------------------------------------------------------------+--------
 1 | base-non-oss | base-non-oss                                | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://cdn.opensuse.org/slowroll/repo/non-oss/                               | 
 2 | base-oss     | base-oss                                    | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://cdn.opensuse.org/slowroll/repo/oss/                                   | 
 6 | h264         | h264                                        | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | http://codecs.opensuse.org/openh264/openSUSE_Tumbleweed/                     | 
 7 | packman      | packman                                     | Ja      | (r ) Ja   | Ja      |   70     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Slowroll/Essentials/ | 
 8 | shells       | Shell Implementations (openSUSE_Tumbleweed) | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | https://download.opensuse.org/repositories/shells/openSUSE_Tumbleweed/       | 
 9 | sublime-text | Sublime Text - x86_64 - Stable              | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | https://download.sublimetext.com/rpm/stable/x86_64                           | 
10 | teamviewer   | TeamViewer - x86_64                         | Ja      | (r ) Ja   | Ja      |   99     | rpm-md | https://linux.teamviewer.com/yum/stable/main/binary-x86_64/                  | 
11 | update       | update                                      | Ja      | (r ) Ja   | Ja      |   80     | rpm-md | http://cdn.opensuse.org/update/slowroll/repo/oss/                            | 

Update:
zypper info --repo base-oss kernel-devel kernel-source shows that the base-oss repo does have version 6.7 for kernel-devel and kernel-source.
I have no clue why kernel-default was installed from base-oss and the other two from update.

Hi @PossiblePrinterPalace

I set up the whole system according to page. slowroll:

openSUSE:Slowroll - openSUSE Wiki

zypper ar --refresh /slowroll/repo/oss - openSUSE Download base-oss
zypper ar --refresh /slowroll/repo/non-oss - openSUSE Download base-non-oss
zypper ar --refresh -p 80 /update/slowroll/repo/oss - openSUSE Download update
zypper ar --refresh --disable /slowroll/repo/src-oss - openSUSE Download base-src-oss
zypper ar --refresh --disable https://download.opensuse.org/debug/slowroll/repo/oss/ base-oss-debug
zypper ar --refresh Index of /openh264/openSUSE_Tumbleweed h264
zypper ar --refresh -p 70 Index of /pub/linux/misc/packman/suse/openSUSE_Slowroll/Essentials/ packman

I’ve had problems with 6.7.x.x kernels. since I have an old 15 year old laptop and 2 vm on maybe too recent hardware.
All good with kernel-longterm

I believe I fixed it. I removed kernel-devel and kernel-source and re-installed them with

zypper in --repo base-oss kernel-devel kernel-source

Now they are on version 6.7…, the same as kernel-default.
I don’t know how I got the problem in the first place, nor why the package versions in the update repo are older than the ones in the base-oss repo. But at least they match now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.