Versión de docker compose

Hola a todos.

Al instalar docker compose a través de Yast, tengo lo siguiente:

docker-compose version 1.25.1, build a82fef0
docker-py version: 4.2.0
CPython version: 3.6.15
OpenSSL version: OpenSSL 1.1.1d  10 Sep 2019

Tengo que ejecutar el siguiente docker con:

docker-compose up 

y obtengo la siguiente salida por consola:

Version in "./docker-compose.yml" is unsupported. You might be seeing this error because you're using the wrong Compose file version. Either specify a supported version (e.g "2.2" or "3.3") and place your service definitions under the `services` key, or omit the `version` key and place your service definitions at the root of the file to use version 1.For more on the Compose file format versions, see https://docs.docker.com/compose/compose-file/

¿Cómo puedo instalar una versión más nueva de docker compose? el archivo que tengo que levantar es tiene la versión version: “3.8”

En su día, instale docker y funcionaba.

Voy a ver.

PD: No veo el paquete docker-compose, como no sea esto, ¿lo es?.

**zypper se docker | grep -i compose**
  | python2-docker-**compose**                | Tool to define and run complex applications using Docker     | paquete
  | python3-docker-**compose**                | Tool to define and run complex applications using Docker     | paquete


Para que sirve el comando
docker-compose

Hola:

Con permiso.

Según la web, es un programa o utilidad que sirve para trabajar con contenedores (contenedores de software) .

Y no se si necesita alguna cuenta de azure .

Saludos cordiales .

Prueba esto

https://www.how2shout.com/linux/quick-steps-to-install-docker-ce-on-opensuse-linux/

saludos