Version 13.1 xen freezes immediately with new install on Dell T7610

I have a Dell T7610:
Dual Intel Xeon E5-2630 (Six Core HT)
32 GB (4x8GB) 1666MHz DDR3 ECC RDIMM
2 x 500 GB SATA hard drive
2 x 320 GB SATA hard drive
2 GB NVDIA Quadro K2000

and I did a new install of 13.1 from DVD. I installed the Xen hypervisor along with the default kernel. I configured this as a UEFI unsecured boot.

The system will boot the default kernel just fine, but it won’t boot the xen kernel and freezes immediately in grub after printing:
Loading Xen 4.3.2_01-18.2 …
WARNING: no console will be available to OS
Loading Linux 3.11.10-17-xen …
Loading initial ramdisk …

The disks are configured such that a partition from each make up a RAID6 array with LVM on top. The LVM then has a root, swap, var and tmp with ext4 file systems.

I have some Dell T7600s that have nearly the same configuration and they boot fine (the main OS related difference is they have a RAID5 array instead of RAID6).

I also did an install on another T7610, but used BTRFS and that froze exactly the same way. I attributed that to BTRFS and assumed it was just too new and that’s why it didn’t work, but now with this second system failing exactly the same way I’m thinking it has something to do with the hardware not being supported.

Is there anyway to get debug information to help determine why it freezes? Or is this known to be an unsupported configuration?

I used to have lots of issues with Dell servers and their ACPI in the past (many years ago) - however I would’ve imagined they would have no issues with it any more.

Nevertheless, have you tried booting with ACPI disabled from Grub?

I changed the line in grub via hitting ‘e’ in grub to:
module /boot/vmlinuz-3.11.10-17-xen placeholder root=/dev/mapper/system-root ro acpi=off showopts

and hit ‘F10’, but there is no change.

I also checked if there is any BIOS update available and I already have the most up to date.

Of course this sounds like a crazy suggestion but have you tried the rolling Factory boot disk?

Mainly to test whether having a much newer kernel version makes a difference - not so much to see whether you want to install bleeding edge software :slight_smile:

That’s an interesting idea, but I assume it won’t be as informative if I don’t boot from a similar configuration, i.e. boot from the hard disks in the system, which at this point means overwriting what I already have installed. Since I can boot the default kernel my inclination is to move ahead by using KVM.