Verizon 3G - No default Route being set?

Hi,
So I’ve been seeing a bunch of issues with the /etc/resolv.conf not picking up the nameservers for 3g connections, and managed to fix that issue using tips found here… the one thing I m having a problwm with is my 3G USB modem not picking up a default route/gateway.

I can connect using KNetworkManager, get an IP and nameservers, but…


# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
66.174.120.64   *               255.255.255.255 UH    0      0        0 ppp0

ifconfig shows me the device is up

ppp0      Link encap:Point-to-Point Protocol
          inet addr:75.192.68.191  P-t-P:66.174.120.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:64 (64.0 b)  TX bytes:97 (97.0 b)



Relevent bt of /var/log/messages:

Dec  5 20:00:42 wing-ix pppd[23869]: Plugin /usr/lib64/pppd/2.4.4/nm-pppd-plugin.so loaded.
Dec  5 20:00:42 wing-ix pppd[23869]: pppd 2.4.5 started by root, uid 0
Dec  5 20:00:42 wing-ix pppd[23869]: Using interface ppp0
Dec  5 20:00:42 wing-ix pppd[23869]: Connect: ppp0 <--> /dev/ttyUSB0
Dec  5 20:00:42 wing-ix pppd[23869]: local  IP address 75.239.207.32
Dec  5 20:00:42 wing-ix pppd[23869]: remote IP address 66.174.120.64
Dec  5 20:00:42 wing-ix pppd[23869]: primary   DNS address 66.174.95.44
Dec  5 20:00:42 wing-ix pppd[23869]: secondary DNS address 69.78.96.14
Dec  5 20:00:44 wing-ix nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/autofs' exited with error status 1.
Dec  5 20:00:44 wing-ix if-up.d/21-dhcpcd-hook-samba: No dhcpcd info nor dhclient leases file found for ppp0.
Dec  5 20:00:44 wing-ix pppd[23869]: Script /etc/ppp/ip-up finished (pid 23874), status = 0x0
Dec  5 20:00:44 wing-ix rpc.statd[23427]: Caught signal 15, un-registering and exiting.
Dec  5 20:00:45 wing-ix sm-notify[24112]: Already notifying clients; Exiting!
Dec  5 20:00:45 wing-ix rpc.statd[24122]: Version 1.1.3 Starting
Dec  5 20:00:45 wing-ix rpc.statd[24122]: Flags:
Dec  5 20:00:45 wing-ix rpc.statd[24122]: statd running as root. chown /var/lib/nfs/sm to choose different user



Help? This all worked in 11.1 - but seems to be an issue in 11.2

And to top it all off, I cannot figure out what the default gateway should be from verizon to just write a script out myself that’ll do it automatically…

No thoughts huh?

Rats!

I would guess that the gateway is the same as the destination. At least that is the case with my provider (I connected using the live CD)
My 11.2 system doesn’t set a default route either, it used to before I decided to re-install 11.2 for no good reason now that I think back.Somehow networknmanager connection via 3G got broken and hasn’t work since.I have been crawling this forum and everywhere else for a solution but I haven’t found one.
How do you propose setting it with a script?

Hi i tryed this root account and it worked without any work arounds . Discovered this by chance actually , U should try it i think it may be an issue of authentication i.e when the knetworkmanger tries to access a restricted area it does not have a dialog to request for a password blah blah blah , just a guess maybe this could help the talented coders to get a solution

Hrrm…
I’ve made progress, but still not working correctly. I think I’ll file a bug report once I get some more data.

The default route isn’t being set for the mobile broadband.

simply running

# route add default ppp0

will fix the issue, and allow the 3g USB modem to work properly.

I cannot find a place to auto-run a script after connection, and I can’t quite figure out where NetworkManager keeps the ppp0 connection script.