Verifying DMI Pool Data, openSUSE 11.1

Hi group,

I built a new computer and installed openSUSE 11.1 on the new SATA disk (Seagate 500 GB) and things seemed to go fine. There are also some old ATA disks, a DVD-ROM, a DVD-RW and a good old floppy drive in place.

Ok, so v11.1 installed and the computer rebooted and froze on the “Verifying DMI Pool Data” message. I reordered the boot priority in BIOS and tried a bootable floppy, with Seagates test program, and it came up fine (no errors found on disk BTW). Changed boot order again, start with DVD-ROM and the openSUSE 11.1 DVD and it boots to installation menu and when I tell it to boot from hard disk it boots just fine?!? Nothing wrong with GRUB then I guess?

After numerous boot reorders and removal of old ATA drives and DVD drives etc “hacking” I still can’t get it to boot directly from the SATA drive. WTF???

Please, give me some good tips. (Don’t bother if the tips involves Windows somehow. There’s no such thing on the box.)

Have you tried running the firmware test on Install CD/DVD?

I think you should repair the MBR. Based on

Computer stops at verifying dmi pool data…
PC locks up at “Verifying DMI Pool Data…”

Yes, I ran firmware test. It is a very “nerdy” program, i.e. I don’t understand much of what it says. There are a few failures (4) and some warnings (3) but I don’t know how serious they are. Can I dump the output here for someone more knowledgeable than me to interpret? It’s just text.

FDISK/MBR does not help.

I have ran the repair option twice. First time it found errors on my root partition and repaired them (fsck). It also found some problem with base packages, four of them had to be reinstalled. It also found some error with boot loader configuration file…twice! I.e. in the same execution of repair it detected an error in boot loader configuration twice and repaired it twice…Hmmm…???

All of these errors could result in boot failure i guess. So with all of them repaired I rebooted but it still froze on “Verifying DMI Pool Data”. More WTF??? etc

Booted to installation DVD again and ran repair again. Again it found problems with the same base packages (cups, hal, ntp and postfix) and reinstalled the correct packages (or something - it says they have been installed anyway) and, what is even weirder, again it repaired boot loader configuration file twice!!!

I’m starting to think this openSUSE 11.1 doesn’t support my hardware, where can I check that?

CPU: AMD Phenom X4 9950 Black Edition, Socket AM2+, 2.6GHz
MOBO: Gigabyte MA790X-DS4
RAM: 4 GB (2x2GB)

Well, any ideas?